BUG - Security sold or cleared to 0 shares but pennies remain in some reports

Tom39 Member ✭✭✭
edited August 2023 in Investing (Windows)

Bonus: It appears in one report, but not in an identical report.

When I go to: Investing >> Allocations >> Show Full Graph tab (bottom left) >> Show Report >>
-- It shows the accounts I expect.

But When I go to: Investing >> Allocations >> Reports button >> Investment Allocations it shows more stocks, to include "Dodge & Cox Intl Stk (DODFX) with -0.000 shares and a -0.04 balance.

There were no stock splits during the duration I owned the stock. The sale was on 8/31/2011.

I stumbled on an option once that brought up a pop up box where you could zero out an security per a certain day. Now I can't find it. I'd appreciate any help.

Attempted Solutions:

— I have tried rebuilding the file, but the negative pennies issue won't go away.

— I selected "sell all shares in this account". Quicken allowed me to do this (see first link below—Quicken doesn't always let you sell all shares), but as you can see the mystery -$0.02 remains

I suspect that like the problem where shares do this on a stock split involving a repeating fractional number (1 for 3 = 0.333333), this might also be a base 2 vs base 10 math error. That's a wild guess. A more elegant fix would be for Quicken to utilize base 10 math in all instances.

See related posts about tiny leftovers at:





  • Tom39
    Tom39 Member ✭✭✭
    edited July 2023

    I also reported this problem by navigating within quicken to Help > Report a problem. I submitted this as a problem report with a screen snapshot, log files attached, and a sanitized copy of my data file.

    I tried the trick listed at the link below, posting a microshare or so to balance it out, but I could not find the correct amount. Dodge and Cox has zero shares and does not show up in my asset list here:

    Investing >> Dashboard >> Brokerage (or all accounts)

    I also went to the last transaction and selected "sell all shares". That didn't fix it.

    I unchecked "sell all shares" and went into the past, deleted the "fees" transaction, and one adjustment transaction. I then tried the "sell all shares" trick again (not worried about the cost per share being off a little). The cost basis and balance in the report kept changing, but did not go to zero.

    Just adding money made my total incorrect.

    For another situation where a problem shows up on some screens/reports, and not on other similar screens/reports, see this post:


This discussion has been closed.