Quicken Mac 2007 Conversion Fails - Help!

Second Member ✭✭

Sorry for what appears to be yet-another-thread on this, but all the previous ones were closed. I cannot seem to get the (nominally supported) conversion of Mac Quicken 2007 files to update/import into the current subscription Quicken Premier.

I am trying to convert Quicken Mac 2007 files (.qdfm) that are successfully working on a 2008-generation iMac running El Capitan (OS X 10.11.6.) That system has the "updated" version of Quicken 2007, version 16.2.4. No problems, other than the system is 15 years old…

I've acquired a new Mac Mini, running Ventura 13.5.1. I have a new subscription to Quicken Premier, version 7.2.2. When running the import routine there is a prompt to "Use Quicken Cloud." Accepting generates transient messages about uploading, converting, and downloading. Then a dialog box states, "Could not import 'filename.qdfm.' An error occurred while preparing the file to be imported."

Following the advice on other posts here and elsewhere, I have made sure the original files were re-indexed, saved as copies, zipped, brought to the new system and unzipped. I've tried to open them for conversion from HFS+, APFS, and FAT32 disk volumes. I even created a small test file with only two transactions in it. No joy.

I also spent some time with a helpful support person on the phone, but they were unable to solve the problem.

At this point my best guess is that the cloud converter is malfunctioning. This would be consistent with the thread below from last year.

As work a around I have also tried loading old versions of Quicken, starting with 5.3.0 on the old iMac, thinking I could do the conversion there. Unfortunately, none of them will run without generating an error during the initial launch.

I am hoping someone here has some suggestions. Otherwise, I'll be looking for a way to move my many years of data to another software package - none of which look as desirable as Quicken.

Thanks in advance for any assistance.


  • Second
    Second Member ✭✭

    As a follow up, this morning I attempted to import/convert the files again on the theory that the issue was on the cloud end. Sure enough, the same files that didn't convert yesterday went right through today. A HUGE thank you to whomever kicked the cloud conversion server!

    I am very happy to have my decades of Quicken data. Now to acclimatize to the new interface and workflow.

This discussion has been closed.