Quicken stopped downloading transactions from Discover Bank and no way to fix it

Options
Scott Lindner
Scott Lindner Member ✭✭

Long time Quicken user here running Quicken on Windows. About a week ago Quicken stopped downloading transactions from all Discover accounts. I know from experience this just happens sometimes and then resolves itself. Today I tried the Fix It thing since it has been a week and when I go through the process I authenticate with Discover again and it shows all of my accounts and offers to Link/Add/Don't Add. The problem is it doesn't give any option for the bank accounts. They are set to "Don't Add to Quicken" with no way to change it to Link or Add. Is there a solution to this?

Answers

  • bethlawyer
    bethlawyer Member
    Options

    Same problem. Is there a solution to this?

  • Scott Lindner
    Scott Lindner Member ✭✭
    Options

    At least it isn't just me! I'm hammering on it right now trying to find a work around. Something is screwed up with the User Interface for this. I think this is going to require a bug and fix from Quicken.

  • Scott Lindner
    Scott Lindner Member ✭✭
    edited August 2023
    Options

    What the ….? I just typed up a huge reply with a workaround on the website ate it on me.

    Short version. The UI is definitely broken for the "We found the following accounts" screen where you add/link/don't add screen for each account with the financial institution. But you can fix this today by Resetting each account in Account Details / Online Services / Reset Account. You have to do this for each account which is a new issue from previous times I have had to reset accounts.

    I have another work around theory to try. I might give it a go in just a moment.

    It feels like there was a design change in Quicken to capture authentication credentials per account rather than per financial institution and this process is flushing that through.

  • Scott Lindner
    Scott Lindner Member ✭✭
    Options

    Alright. I have a "fix" but it isn't fun. The UI definitely is broken but you can get this working again by doing the following per Discover account. I have 9 Discover accounts (one is an old CC that they are still showing but is long gone) so this was a major pain.

    For each Discover account do the following:

    1. Edit account details
    2. Online Services
    3. Reset Account
      1. Sign in to connect your accounts to Quicken.
        1. It will prompt you for your authentication credentials and likely offer the ones already saved. Check the box to save in
      2. We found the following accounts.
        1. It will show you all of your Discover accounts each time you do this.
        2. If you have any link/add/don't add changes to make, you'll need to do this every time for each account. I had to be careful to not select the old CC each time
        3. It will automatically suggest "Link to existing" for the account you are resetting but there is no way to change it. The UI is clearly broken at the moment.
      3. Finish
      4. OK to close
      5. Repeat for next discover account

    In the past when resetting accounts it would fix it for all accounts from that financial institution. This is something new in Quicken that is wrong. It almost feels like internally it is attempting to treat the authentication uniquely per account and likely how it got broken on us.

    The upshot is historically when restting an account it would download upwards of a half year of transactions and you would need to manually delete all of the ones that you had already downloaded in the past. This did happen this morning, but it wasn't a massive number like it used to be. So that's a plus.

  • Scott Lindner
    Scott Lindner Member ✭✭
    Options

    Don't follow either of those instructions unless you first take a backup of your quicken data. It screwed up the starting balance for every one of my Discover accounts and that took me a LONG time to figure out why things weren't matching anymore.

This discussion has been closed.