Tech Credit Union setup for online, but it is broken

raccah
raccah Member ✭✭

I have a Tech CU account that has online setup, but it is broken and cannot be reset. It says Financial Institution Unknown and the reset/deactivate are missing. It shows under Tech CU in the online center, but I don't see a way to do it there either. It used to download, but hasn't done so in a long time.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭

    In my list of available banks, there is an entry for Tech Credit Union at www.techcu.org
    Is that the CU you're trying to connect to?

    There are several credit unions with "Tech" in the name. Are you sure that you are looking for the correct CU? Or might they have changed names or merged or changed websites in the last few months?

    What kind of error codes or error messages do you get if you're trying to download now (use "Update Now" from the account register's Action gear icon)?

  • raccah
    raccah Member ✭✭

    I log in on the web to techcu.com. In quicken, it used to work and now I can't see how it's configured. There are no errors, but also no way to modify/reset/deactivate it

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭

    here's the entry - with both manual download from the TCU online website - along with Quicken One Step Update -

    04630 04630 04630 Tech Credit Union
    http://www.techcu.org/ 1-800-276-8324
    https://www.techcu.org/tob/live/usp-core/app/login/consumer ACTIVE
    BANKING&WEB-CONNECT
    BANKING,CREDIT,ACCOUNTINFO&EXP-WEB-CONNECT

    QWin - R54.16 - Win10

  • raccah
    raccah Member ✭✭

    But how do I disconnect/fix the one I already have connected? The UI is stuck and does not allow me to do anything.

  • kchafin
    kchafin Member

    I have the same issue with a Truist, formerly SunTrust account. Would really like to know how to correct this issue.

This discussion has been closed.