TD Ameritrade to Schwab w/ multi-currency support environment

Options
shibaha
shibaha Member

My account at TD Ameritrade has moved to Schwab and I'd like to update my Quicken file to support the account at Schwab.

I followed instructions described in the FAQ, (https://www.quicken.com/support/moving-your-td-ameritrade-accounts-schwab-quicken)

However, I haven't been able to setup the online service yet.
At first, I tried the Option 1(Keeping your accounts), but got problem on selecting link-account with existing TD Ameritrade. The document says that I need to choose existing account linked to TD Ameritrade. All accounts setup in my Quicken file except for the TD Ameritrade account are displayed in the list, see an image below,

Accounts with Japanese Yen as currency are displayed and only the TD Ameritrade is with US Dollar.
I'm suspecting that the multi-currency support in Quicken could affect this issue.

Any help would be appreciated.

Quicken Classic DELUXE
Version: R54.9
Build: 27.1.54.9
running on Windows 10 Pro

Tagged:

Answers

  • shibaha
    shibaha Member
    Options

    I forgot to say that Japanese Yen is specified as home currency in my Quicken file.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    Accounts with Japanese Yen as currency are displayed and only the TD Ameritrade is with US Dollar.
    I'm suspecting that the multi-currency support in Quicken could affect this issue.

    I suspect my next approach would be

    1. create this as a new added account (presumably as a yen account)
    2. Take note of the account details for that new account - financial institution and account number
    3. Copy those two items to the still deactivated older account.
    4. Delete the newly created account
    5. Try again to activate that account. I am thinking with the FI and account number pre-filled, the program will make the connection even though that account is a USD account rather than a home currency account.

  • shibaha
    shibaha Member
    Options

    q_lurker, thanks for your help!
    But it didn't seem to work in this case.

    In the step 5, reactivating the old TD Ameritrade account with the Schwab's FI and account number pre-filled, needed to pass authentication via a Schwab web site with login ID/PW and the process was same as adding a new account did in the step 1. Of course, no TD Ameritrade account didn't appear in the list as one of linked existing accounts in my Quicken file.

    BTW, I found a workaround this issue.

    After I changed home currency back to US Dollar, during setting up online service in Schwab, my TD Ameritrade account appeared as a linked existing account and I was able to finish the process successfully. Then I changed home currency to JPN Yen again.

    There appeared to have some bugs with multi-currency support in Quicken.
    It chose accounts used home currency(in my case, JPN Yen) to populate list items as existing linked accounts, but it should chose accounts used same currency as Schwab needs.

This discussion has been closed.