Blank Reports

Options
thyagocoan
thyagocoan Member
edited July 2 in Reports (Windows)

Hi Everyone, I`m a new user, and I believe this is a dumb question. Sorry about that.

I`m trying to get any report from my account, but the reports are blank. I already checked the settings/customize, but it was impossible to get the data.

I only got any information by selecting all the dates in the date range.

Below Spending by Category - Last Week and all Dates.

Tagged:

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Options

    That is extremely strange. I don't know what is going on. I notice on the "include all dates" report it is to the 3rd of July. That proves that in that report that it saw transactions up to that point. And of course, you have also nicely included the proof that the account has transactions from the account in the background. So, as long as that account is included in this report you should certainly get transactions for last week.

    You might try drilling down in the "include all dates" report and see if it will take you to transactions that are for last week. You can do that by double clicking on one of the amounts.

    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • thyagocoan
    thyagocoan Member
    Options

    I did what you suggested - double-click on one of the amounts - and i was able to get data.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    I wonder if the issue could be related to the odd (by US standards) date format you are using. While Quicken tries to use the Windows date setting your PC has, there are some places it can hiccup at something other than mm/dd/yy.

  • thyagocoan
    thyagocoan Member
    Options

    I found the problem; the file exported from my bank comes with the date in dd/mm/yy, and Quicken identifies the year as 1924.

    I just created a new file for the test and manually updated the qif file, and it worked fine.

    Tks for the help.

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Options

    To workaround the year 2K problem Quicken QIF files adopted these formats for dates.

    MM/DD/YY (years before 2000)

    MM/DD'YY (years from 2000 on)

    MM/DD/YYYY (this format is accepted too and doesn't have such problems)

    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Options

    Also note that a QIF import is always in that format for the US and Canadian versions of Quicken. It doesn't matter what format you might be using in Quicken for the register and such which follow your Windows short date format.

    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options

    I'm wondering … there's a Control Panel setting in Windows which controls a rolling One-hundred-year window and is supposed to control the conversion of 2-digit years to proper 4-digit 19xx or 20xx years.
    In my system this settings panel looks like this:

    The logic behind this setting, when used as shown is: interpret "24" as "2024"
    If a different setting, e.g., "1900 to 1999" were used, "24" would be interpreted as "1924" …

    What is your setting for the 100-year window? Is that what could/would have caused the bad 19xx date conversion?

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Options

    Quicken's QIF import uses none of that. It uses the formats that I stated. 1/2/24 is always going to be interpreted as January 2nd 1924. One has to realize that Quicken Inc barely supports the QIF import and probably has changed it in decades, so new settings in Windows aren't going to affect it.

    This is just another case of very old code that has never been changed. Another is the fact that the use of . or , in numbers is still controlled by an INI file and not by the Windows settings.

    Signature:
    This is my website: http://www.quicknperlwiz.com/