Register for all accounts only goes back one year.

SMCHome
SMCHome Member ✭✭
I noticed today while searching for a several year old transaction, that my register only goes back one year.
It is very possible in the past I set this up to archive transactions but, I'll be darned if I can find any option to do this or to stop it from happening. I''m hoping all the transactions are archived somewhere and I will be able to restore them.
Anyone that can offer some helpful advice is greatly appreciated!
Thanks,
Steve

Best Answers

  • Quicken Jared
    Quicken Jared Moderator mod
    edited March 20 Answer ✓
    SMCHome said:
    I noticed today while searching for a several year old transaction, that my register only goes back one year.
    It is very possible in the past I set this up to archive transactions but, I'll be darned if I can find any option to do this or to stop it from happening. I''m hoping all the transactions are archived somewhere and I will be able to restore them.
    Anyone that can offer some helpful advice is greatly appreciated!
    Thanks,
    Steve
    Hello @SMCHome

    I am sorry to hear about this issue with register entries. Thank you for reaching out regarding this problem and speaking with us about it here on the Quicken Community.

    First, I want to be sure that there are not any filters preventing the transactions from being viewed. If possible, try clicking Reset just above the register itself. Also, click on the box labelled Date at the top of the associated column so that the triangular arrow next to it is facing downward. This will ensure that your sorting is organized from oldest to newest in the register. Lastly, are you noticing this issue across multiple accounts, associated with multiple Financial Institutions?

    I look forward to hearing more from you about this.

    Thank you,

    Quicken Jared 
  • splasher
    splasher SuperUser ✭✭✭✭✭
    Answer ✓
    If you are in the "All Transactions" register, it automatically starts with a filter set for last 12 months:


    Check your actual account's register and you should see the rest of your transactions.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list

Answers

  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi @SMCHome,

    At the end of the calendar year, a lot of folks decide that they don't need prior year data in their current datafile and so they archive prior years.  Is it possible that you did this?  If so, and if you saved a copy of your datafile before you did the archive, you could restore from your backup.  However that will leave you starting over as of 1/1/22 and you'll need to enter all information over again from that date.

    If, on the other hand, that's not what happened, please give us more details and we'll see what other options may be available, if any.

    Frankx


                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • Quicken Jared
    Quicken Jared Moderator mod
    edited March 20 Answer ✓
    SMCHome said:
    I noticed today while searching for a several year old transaction, that my register only goes back one year.
    It is very possible in the past I set this up to archive transactions but, I'll be darned if I can find any option to do this or to stop it from happening. I''m hoping all the transactions are archived somewhere and I will be able to restore them.
    Anyone that can offer some helpful advice is greatly appreciated!
    Thanks,
    Steve
    Hello @SMCHome

    I am sorry to hear about this issue with register entries. Thank you for reaching out regarding this problem and speaking with us about it here on the Quicken Community.

    First, I want to be sure that there are not any filters preventing the transactions from being viewed. If possible, try clicking Reset just above the register itself. Also, click on the box labelled Date at the top of the associated column so that the triangular arrow next to it is facing downward. This will ensure that your sorting is organized from oldest to newest in the register. Lastly, are you noticing this issue across multiple accounts, associated with multiple Financial Institutions?

    I look forward to hearing more from you about this.

    Thank you,

    Quicken Jared 
  • splasher
    splasher SuperUser ✭✭✭✭✭
    Answer ✓
    If you are in the "All Transactions" register, it automatically starts with a filter set for last 12 months:


    Check your actual account's register and you should see the rest of your transactions.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • SMCHome
    SMCHome Member ✭✭
    Thanks for your help. I’m feeling a little silly right now, it turns out I did have a filter set for “Last 12 months” rather than “All Dates”for the register.
    Not sure how I didn’t see these filters earlier, but thanks again for responding Frankx and Quicken Jared!
  • Quicken Jared
    Quicken Jared Moderator mod
    SMCHome said:
    Thanks for your help. I’m feeling a little silly right now, it turns out I did have a filter set for “Last 12 months” rather than “All Dates”for the register.
    Not sure how I didn’t see these filters earlier, but thanks again for responding Frankx and Quicken Jared!
    @SMCHome,

    It is our pleasure to be of assistance, and it is nothing to be ashamed of. I am simply pleased that we were able to resolve the issue. Thank you for taking the time to update us on this change in circumstances, and thanks to @Frankx and @splasher for all of the help provided in this discussion.

    Feel free to reach out with any additional questions or concerns.

    Thank you,

    Quicken Jared 
This discussion has been closed.