Losing transfers in split lines.

I need to import a QIF file that contains transactions with split lines (paychecks). Some of those split lines are transfers to other accounts (e.g. 401K).

Unfortunately, when I perform the import in Q2013, it drops all of the split lines that are transfers. It then adds those transfers as separate transactions later, when I accept the transfer in the 401K account register.

Is there a way to combat it? All I want it to do is to important my QIF exactly as written, as I can guarantee that all the transfers are balanced.

Thanks a lot for any suggestions!

--Lev

Comments

  • Unknown
    Unknown Member
    edited October 2018
    No I'm afraid you are stuck with this behavior. It is one of the reasons export/import of a QIF doesn't recreate accounts exactly.

    [EDIT - Note as discussed below it was found that you can affect this behavior if you deselect "special treatment for transfers" AND you select a Cash account as where the import account, instead of <All Accounts>. Further note that the QIF file should have the account name and type in it, so that it will in fact import into that account and not the cash account]

    If you think about a transfer it is actually a transaction that has to be connected between two accounts, but you are importing for one account.
    This causes a "matching" problem between the two. Intuit sidestepped the issue by removing "from" side of the transfer when you do the import, and expects the "to" side import to put in the transfer.

    Why they picked the "from" side to remove is beyond me. Since the "from" side is always the one in a split, so this always results in the transfers in splits becoming new transactions.

    And of course to make this problem worse, there could be several "to" accounts, that they think they don't have to import just to fix one account, but there is the ripple effect, which might affect lots of accounts.
    BTW this is a key reason why if someone deletes an account and then thinks they are going to simply export that account from an old data file as a QIF and import it, they are going to be quite shocked at the results.
    They will basically end up with an account that is missing lots of transfers, depending on whether this is the "from" or the "to" side of the transfer.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited October 2018
    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.
  • Unknown
    Unknown Member
    edited July 2016
    QPW said:

    No I'm afraid you are stuck with this behavior. It is one of the reasons export/import of a QIF doesn't recreate accounts exactly.

    [EDIT - Note as discussed below it was found that you can affect this behavior if you deselect "special treatment for transfers" AND you select a Cash account as where the import account, instead of <All Accounts>. Further note that the QIF file should have the account name and type in it, so that it will in fact import into that account and not the cash account]

    If you think about a transfer it is actually a transaction that has to be connected between two accounts, but you are importing for one account.
    This causes a "matching" problem between the two. Intuit sidestepped the issue by removing "from" side of the transfer when you do the import, and expects the "to" side import to put in the transfer.

    Why they picked the "from" side to remove is beyond me. Since the "from" side is always the one in a split, so this always results in the transfers in splits becoming new transactions.

    And of course to make this problem worse, there could be several "to" accounts, that they think they don't have to import just to fix one account, but there is the ripple effect, which might affect lots of accounts.
    BTW this is a key reason why if someone deletes an account and then thinks they are going to simply export that account from an old data file as a QIF and import it, they are going to be quite shocked at the results.
    They will basically end up with an account that is missing lots of transfers, depending on whether this is the "from" or the "to" side of the transfer.

    Thanks, Quick.  Is the 'From' side defined simply as the one with the negative 'Amount' field, so there is no way to influence Quicken's decision in the matter?

    It seems that when importing from Microsoft Money, it works correctly.  Have you heard of anyone attempting to go the route of QIF -> Money -> Quicken to work around?

    At this point, it has become a point of personal pride with me! :-)
  • Unknown
    Unknown Member
    edited July 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Thanks, *Jose, I did try that.  Appeared to have no effect.  I even tried putting a !Option:AllXfr into the .QIF which I found in the spec, still no effect...
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    I did a very simple test: I exported one Q2013 paycheck transaction with a 401k pre-tax deduction with employer match. I modified the QIF file to allow importing directly into a Quicken checking account, imported that file with "Special handling ..." off; and both the employee and employer transfers were posted to the 401k account. Said another way: the imported transaction looked and acted exactly like the exported transaction (with the exception that the imported transaction no longer had the paycheck "form").
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    I wonder if the preference for automatically detecting transfers is having an effect on the import?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Good point.

    I have mine set to "confirm" ... and Q2013 did not detect any transfers for me to confirm, in my very small test.

    It's also possible that Transfer Detection is not applied to QIF file imports.
  • Unknown
    Unknown Member
    edited December 2016
    QPW said:

    No I'm afraid you are stuck with this behavior. It is one of the reasons export/import of a QIF doesn't recreate accounts exactly.

    [EDIT - Note as discussed below it was found that you can affect this behavior if you deselect "special treatment for transfers" AND you select a Cash account as where the import account, instead of <All Accounts>. Further note that the QIF file should have the account name and type in it, so that it will in fact import into that account and not the cash account]

    If you think about a transfer it is actually a transaction that has to be connected between two accounts, but you are importing for one account.
    This causes a "matching" problem between the two. Intuit sidestepped the issue by removing "from" side of the transfer when you do the import, and expects the "to" side import to put in the transfer.

    Why they picked the "from" side to remove is beyond me. Since the "from" side is always the one in a split, so this always results in the transfers in splits becoming new transactions.

    And of course to make this problem worse, there could be several "to" accounts, that they think they don't have to import just to fix one account, but there is the ripple effect, which might affect lots of accounts.
    BTW this is a key reason why if someone deletes an account and then thinks they are going to simply export that account from an old data file as a QIF and import it, they are going to be quite shocked at the results.
    They will basically end up with an account that is missing lots of transfers, depending on whether this is the "from" or the "to" side of the transfer.

    That might work. I have never tried it.  The import on the MS money is a full conversion program so it doesn't suffer the same limitations as with QIF.
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    I'm not sure what is different for NWJ.  My experience has always been that the "special handling" does nothing, no matter which way it is set.

    I tried it again both with and without it set.  With a paycheck reminder not created and created.
    Nothing I did changed the behavior.

    In each case I got the paycheck as a split, without the transfer.

    Please note that you have to make sure all needed accounts either by having them in the QIF or manually otherwise it will create categories for the accounts, instead of transfers to them.

    Please note I'm not doing the 401K side of the import at this stage, just the checking account and checking the splits.

    I can't see how the Transfer Detection comes into this for the very reason of how transfers (at least in my data) are being handled.  There is nothing to "detect" if you leave off one side of the transfer on purpose.
  • Unknown
    Unknown Member
    edited December 2016
    QPW said:

    No I'm afraid you are stuck with this behavior. It is one of the reasons export/import of a QIF doesn't recreate accounts exactly.

    [EDIT - Note as discussed below it was found that you can affect this behavior if you deselect "special treatment for transfers" AND you select a Cash account as where the import account, instead of <All Accounts>. Further note that the QIF file should have the account name and type in it, so that it will in fact import into that account and not the cash account]

    If you think about a transfer it is actually a transaction that has to be connected between two accounts, but you are importing for one account.
    This causes a "matching" problem between the two. Intuit sidestepped the issue by removing "from" side of the transfer when you do the import, and expects the "to" side import to put in the transfer.

    Why they picked the "from" side to remove is beyond me. Since the "from" side is always the one in a split, so this always results in the transfers in splits becoming new transactions.

    And of course to make this problem worse, there could be several "to" accounts, that they think they don't have to import just to fix one account, but there is the ripple effect, which might affect lots of accounts.
    BTW this is a key reason why if someone deletes an account and then thinks they are going to simply export that account from an old data file as a QIF and import it, they are going to be quite shocked at the results.
    They will basically end up with an account that is missing lots of transfers, depending on whether this is the "from" or the "to" side of the transfer.

    BTW on the "From"/"To" side.  No you can't just flip the amounts to negative.

    Think of it this way.  Have you ever gone to a transaction that is a transfer and tried to change the amount and it tells you that you can't change it there, you have to go to the other side of the transfer to change it?

    Well you were on the "To" side of that transfer.
    Now this is where it gets really tricky.

    If you are talking about a transfer in a split, then it 100% that the "From" side is a split, because there is no way to enter a transfer into and existing split.

    Now on regular transactions the "From" side is the account you enter the transaction in, which could be either account.  So I'm not exactly sure how they decide in this case.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    My first test imported with "Special handling ..." selected. No transfers from the paycheck occurred. In fact, both the two 401k contribution transfers were completely missing from the paycheck transaction ... which also changed its net amount.

    My second test imported with Special handling ..." not selected. That one worked as described earlier. An exact duplicate of the exported paycheck ... without the form.

    "Special handling" is supposed to expect more than one QIF file to be imported ... with subsequent imports potentially containing half of transfers previously imported.

    [I only imported one QIF file, the one with the checking account transactions; both the checking and 401k account were already defined in the .QDF file, before the import. In fact: I imported into the same file (but different account) that I exported from).]

    Not sure why different users/files would get different results either.
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Hmm.  My test case I exported one checking account from my existing data file.
    Then a created a new data file, created the needed accounts, and then imported the QIF.

    I'm going to play around with it in the same way you did, and see if I get different results.
    When you exported, did you have it export the account list or did you fix up the QIF account name/time so that it be imported?
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Actually I guess you had to change the QIF information since you did import into different account name, but I guess what I'm wondering is if your QIF file lists all the accounts names/types (selected Account List on export).
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    P.S. Automatic Transfer Detection does apply to QIF imports.  I thought so before, but I wasn't sure, but I just had it pop up for my test where I did it in a copy of my existing account.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    No account info in QIF file.

    I created two new test checking accounts for my test. The account I exported from had only the one paycheck transaction (no other transactions in the account); the account I imported to had no transactions before I imported.

    The only thing checked in the "Include in Export" section was "Transactions". For the second import (the "successful" import), the only thing checked in "Include in import" was "Transactions".

    I told the import to import into a cash account; got the message that there were transactions in the QIF file for the checking account and did I want to import those transactions. Answered yes, and the transaction was placed in the "Accept transactions into register" window, where I Accepted it.
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Thanks.  I'm still testing different combinations.
    BTW For a while now Quicken has been including the account list in the QIF exports even if you don't select it as part of the export.  So I believe if you open the QIF file you will find that.  That is why you didn't have to fix up the QIF account/type information.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Actually, I did have to open the QIF file ... when I added the records at the beginning to allow me to import directly into the checking account. Only thing in the QIF file is the one transaction I exported.

    Sorry, I did mention that in an earlier post here ... but not in the recent ones.
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    OK I have found the difference.
    It is the fact that you are saying to import into the Cash account.
    I have always just used <All Accounts>.

    When you use <All Accounts> you will always get the behavior "special treatment", and certain transfers (like in the splits, but not limited to the splits) will be missing.  For instance my number of transactions was 450 for "Into Cash without special treatment".  And 255 for any time going into <All Accounts> or if into Cash account with "special treatment" on.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Just to try to be clear (for those trying to follow): I did choose a cash account in the Import dialog; but that is not the account I imported to. Quicken recognized that the transactions in the QIF file were for a checking account (because I went to the trouble to add the 4 records to the beginning of the QIF file to tell Quicken the QIF file records were for a specific checking account), so Quicken offered to import the QIF file data to that checking account ... and I accepted Quicken's offer.
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016
    QPW said:

    No I'm afraid you are stuck with this behavior. It is one of the reasons export/import of a QIF doesn't recreate accounts exactly.

    [EDIT - Note as discussed below it was found that you can affect this behavior if you deselect "special treatment for transfers" AND you select a Cash account as where the import account, instead of <All Accounts>. Further note that the QIF file should have the account name and type in it, so that it will in fact import into that account and not the cash account]

    If you think about a transfer it is actually a transaction that has to be connected between two accounts, but you are importing for one account.
    This causes a "matching" problem between the two. Intuit sidestepped the issue by removing "from" side of the transfer when you do the import, and expects the "to" side import to put in the transfer.

    Why they picked the "from" side to remove is beyond me. Since the "from" side is always the one in a split, so this always results in the transfers in splits becoming new transactions.

    And of course to make this problem worse, there could be several "to" accounts, that they think they don't have to import just to fix one account, but there is the ripple effect, which might affect lots of accounts.
    BTW this is a key reason why if someone deletes an account and then thinks they are going to simply export that account from an old data file as a QIF and import it, they are going to be quite shocked at the results.
    They will basically end up with an account that is missing lots of transfers, depending on whether this is the "from" or the "to" side of the transfer.

    "Have you heard of anyone attempting to go the route of QIF -> Money -> Quicken to work around?"

    I'd assume that the import (File > File Import > Microsoft Money file) would be just as accurate as any other Money conversion.

    But there were some considerations with converting Money investment accounts. One issue of concern had to do with converting Money "retirement" accounts. As I recall, you needed to remove the "retirement" designation from the Money accounts before converting.

    Also, as I recall, you can't convert Money files into an existing Quicken file that has data.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    I always use the <all accounts> selection. I haven't done any paycheck transactions recently, but have been doing 401(k) transactions.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited December 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Until today I certainly didn't know there was a difference between the <All Accounts> and "cash" imports.  It was certainly an eye opener.

    BTW while we are sort of on the subject.  One thing that I have noticed.
    Say you really do have a cash account/QIF you want to import.
    Well it doesn't work right if you import into <All Accounts> you need to import it into the right cash account.  In other words the "redirecting" of the import to the right account by putting the account name and type at the top of the QIF file, doesn't work for cash accounts, use the right account name in the selection pull down menu during the import.
  • Unknown
    Unknown Member
    edited July 2016

    You may get "better" results, if you uncheck the option "Special handling for transfers" when you import the QIF file.

    Wow!  This is genius, thanks guys!  It seems that the trick is:

    1) Pre-create all the accounts
    2) Import into a Cash account
    3) Unselect 'Special Handling'
    4) Select 'Account list'

    Thanks again!
  • Howard Roark
    Howard Roark Member ✭✭✭✭
    edited August 2016
    "It seems that the trick is: ...".

    Actually, while your step #1 appears to be correct, from that point on, I think a better plan would be to follow the steps in this discussion:

    https://qlc.intuit.com/questions/dQMNaWtX4r3OK1acfArQA8?legacy=true

    making sure you turn off "Special handling for transfers" when you do the import.