Quicken H&B 2016 Placeholder Entries 0 shares

Unknown
Unknown Member
edited November 2018 in Investing (Windows)
I'm posting this in order to keep open a conversation about an annoying issue that's been discussed previously but without any satisfactory resolution so far as I can tell.

As described in earlier conversations (now closed), Quicken is creating placeholder entries with 0 shares for every security each time I download transactions from my brokerage (in my case, Morgan Stanley). It seems that the only way to get rid of them is to delete them individually: a major nuisance. There must be a persistent problem bug that accounts for this. Of course I'd like to see it eliminated, but for now I'll accept any reasonable workaround.

Thoughts, anyone?.

Comments

  • splasher
    splasher SuperUser ✭✭✭✭
    edited October 2018
    One way to delete them more than one at a time is to run a Transaction Banking Report

    Reports -> Banking ->Transaction

    The placeholders should all be together in the report if it is sorted by date.  You can select a range of transactions by using normal Windows selection methods (Click - move to end Shift Click to get a range or CTRL Click to select individuals).  Once you have a group selected, right click on the highlighted transactions and select Delete Transaction(s).

    While this doesn't prevent the placeholders, it should make them easier to get rid of.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited March 2017
    I recall the prevention is to turn off automatically add downloaded investment transactions to transactions list preference.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited September 2016
    Thanks, that worked. But it's an obvious program bug that Intuit should swat.
  • Unknown
    Unknown Member
    edited September 2016
    splasher said:

    One way to delete them more than one at a time is to run a Transaction Banking Report

    Reports -> Banking ->Transaction

    The placeholders should all be together in the report if it is sorted by date.  You can select a range of transactions by using normal Windows selection methods (Click - move to end Shift Click to get a range or CTRL Click to select individuals).  Once you have a group selected, right click on the highlighted transactions and select Delete Transaction(s).

    While this doesn't prevent the placeholders, it should make them easier to get rid of.

    That's what I've been looking for...not only to get rid of placeholders, but for other investment register edits as well. For a long time I've been frustrated by Quicken's refusal to recognize the standard Windows multiple selection keys.
  • Beijing Mac
    Beijing Mac Member ✭✭✭✭
    edited November 2018
    I have the option to auto add downloaded transactions Quicken does not automatically accept them and let's me manually review and either except or delete the transactions However it automatically created multiple placeholders for me I am having difficulties in deleting these placeholders since they do not show up in the register from my investing account but do show in the placeholder tab at the bottom section Maybe the bank report option will provide me the ability to delete the placeholders Strange and that they will show up in a downloaded excel CSV the limited tab file but will not show up in the register view



    Hopefully quick and Dave will not close this post prematurely like he has done numerous others recently
  • Unknown
    Unknown Member
    edited October 2018
    First off in Quicken 2016 R8 there was a feature added.
    On the Placeholders tab they added a Delete All button.

    Next @Beijing Mac you will not see placeholders in the register unless you turn on the "Show hidden transactions" option in the preferences for Investment transactions or through the gear icon in the register -> Register preferences.

    Second as Ms. Higgins says it is the very fact that you are using this option that triggers this bug:
    Edit -> Preferences -> Downloaded transactions -> Automatically add to investment transactions lists

    As it says transactions are automatically being entered into the register.  Placeholders are transactions.  You have told Quicken to put placeholders into your register without asking you.
    Turn the option off to get get the Downloaded Transactions tab to accept transactions into your register and it will also prompt you to see if you want to enter a placeholder or not.

    And yes the bank transactions report is will show all the investment transactions and can be used to do a multiple select delete as Splasher has stated above.  It is a very useful workaround for dealing with investment transactions since the Investment register doesn't have multiple select.

    Now back to the placeholders.  With the automatic entry on, it triggers a bug as described above where zero share placeholders are created for every security in the register.  Now with a lot of these it can slow things down and fill up the register, so indeed this bug should be fixed.

    BUT note there is no way for a zero share placeholder to change the values in your register.  If you are getting placeholders that are not zero, this is not a bug.  A placeholder is to an investment account as a balance adjustment is to a regular account after a reconcile.

    As in when the transactions are downloaded to Quicken the financial institution sends the share balances too.  And if the shares in Quicken don't match this information, Quicken is going to suggest, or in the case of automatic entry put placeholders in your register.
  • Unknown
    Unknown Member
    edited December 2016
    QPW said:

    First off in Quicken 2016 R8 there was a feature added.
    On the Placeholders tab they added a Delete All button.

    Next @Beijing Mac you will not see placeholders in the register unless you turn on the "Show hidden transactions" option in the preferences for Investment transactions or through the gear icon in the register -> Register preferences.

    Second as Ms. Higgins says it is the very fact that you are using this option that triggers this bug:
    Edit -> Preferences -> Downloaded transactions -> Automatically add to investment transactions lists

    As it says transactions are automatically being entered into the register.  Placeholders are transactions.  You have told Quicken to put placeholders into your register without asking you.
    Turn the option off to get get the Downloaded Transactions tab to accept transactions into your register and it will also prompt you to see if you want to enter a placeholder or not.

    And yes the bank transactions report is will show all the investment transactions and can be used to do a multiple select delete as Splasher has stated above.  It is a very useful workaround for dealing with investment transactions since the Investment register doesn't have multiple select.

    Now back to the placeholders.  With the automatic entry on, it triggers a bug as described above where zero share placeholders are created for every security in the register.  Now with a lot of these it can slow things down and fill up the register, so indeed this bug should be fixed.

    BUT note there is no way for a zero share placeholder to change the values in your register.  If you are getting placeholders that are not zero, this is not a bug.  A placeholder is to an investment account as a balance adjustment is to a regular account after a reconcile.

    As in when the transactions are downloaded to Quicken the financial institution sends the share balances too.  And if the shares in Quicken don't match this information, Quicken is going to suggest, or in the case of automatic entry put placeholders in your register.

    I see that Beijing Mac has another thread, and clearly has some other kind of Placeholder bug (a very strange one indeed), hopefully that thread will lead to a solution for that problem.
    Too bad you don't have Quicken 2016 or you might have been able to try the Delete All option.
    https://getsatisfaction.com/quickencommunity/topics/placeholder-question-with-vanguard-acct
  • Unknown
    Unknown Member
    edited October 2018
    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    Which financial institution?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited December 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    Even though you have said that you have tried all the suggestions it still sounds like you have the option to automatically entry transactions on.

    First off except for some rounding error problems that they said they fixed, I have not seen anyone talk about 0 share placeholders unless they had this option on.  (Other placeholders share values are a different story.)

    Second if you don't have the that option on Quicken asks you if you want to put the placeholders in, and the default for OK is no.   Since you are saying the "appear" I take it that you are not getting this prompt?
    That is again an indication that the automatic entry option is on.  With it on you are telling Quicken to enter all transactions without asking, including placeholders.

    If the option is off you should see this at the bottom of the register:
    image

    Note that there are two places to set this preference.  The one in the global preferences and the one for each register.
    If you select the gear icon in the register and select Edit Account Details -> Online Services, there is a link for what Automatic entry is set to.  And you can click on it to change it.

    Note this is what you will see if it is on:
    image
  • Unknown
    Unknown Member
    edited April 2017

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    Thanks David for keeping getting this bug going again after my earlier post when I finally dared to try 2016 assuming multiple releases would have fixed the multitude of expected bugs from Intuit now. My conversation was closed after someone concluded 'Placeholders are a FEATURE, not a bug", apparently a math genius who knows how to reconcile a zero (nonexistent) difference. None of the above suggestions are practical . . . turning off automatic download costs as much time to manually add dozens of transactions to a dozen accounts every week. Intuits laughable "bug fix" with Release 8 (June 2016) "IMPROVED: Handling of placeholders by giving an option to delete all placeholders if user doesn’t want to solve them". So after going back to 2015 (which is now plagued by new release bugs), I tried H&B 2016 again and spend fifteen minutes erasing hundreds of "Zero Placeholder" transactions every download. MY QUESTION FOR ALL IS, HAS the "ZERO PLACEHOLDER" BUG BEEN FIXED WITH THE 2017 H&B VERSION? Hopefully, the quicken sale will purge Intuit's programmers responsible for killing this product . . . one of the most durable and used products since the origin of computing I'd have to say. Intuit kinda reminds me of the Romans. I have over 500 GB of data transactions for this program and many many hours of suffering correcting bug induced crap over the past 30 years. Any worse and I will be retiring my data to a proper memorial, and let the brokers keep the data for me. Brokers now track the sales purchase dates to calculate the realized capital gains for taxes. and the bank check pay systems are reasonably functional now.  That's probably the reason Intuit unloaded it for $500+ million, as I predict a mass exodis from desk top financial software..
  • Unknown
    Unknown Member
    edited December 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    "MY QUESTION FOR ALL IS, HAS the "ZERO PLACEHOLDER" BUG BEEN FIXED WITH THE 2017 H&B VERSION?"

    No it hasn't.

    "Hopefully, the quicken sale will purge Intuit's programmers responsible for killing this product"

    From what has been told Quicken Inc is basically take the Quicken department and form the new company, and in the case of the Mac side and customer support add more developers.
    Most likely the only developers that left would be the ones that wanted to stay with Intuit.

    They seem "more responsive" now, but I certainly wouldn't look for any radical shifts in basically anything.  And in fact I think a lot of "constraints" that people think were associated with Intuit, were in fact natural ones that aren't going away anytime soon.

    The financial institutions didn't just get better using a standardized download method.

    The Quicken code didn't get "newer".

    The Quicken code base and salary for working on such didn't get any more attractive.

    One thing it will get is "more love".  Quicken was a drop in the bucket for Inuit, and a pain in the backside.  I'm sure the upper management hate it.  And the "love" for it was only because it was the product that started the company.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    A CR, I do not see any prior posts on this forum from you. I suspect if you did post previously, your posts have been closed and archived for violating the terms of service for this site. If you want your posts to remain open and unarchived, I recommend you refrain from personal insults and inappropriate language.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited November 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    I have "Automatically add to investment transactions lists" set to un-checked and still am getting 0 share placeholders.  I did just turn off the view hidden transaction, so we'll see if that works.  This is a very annoying bug that could probably be fixed by one line of code..."If share_balance = 0.0000, then exit placeholder_creation"
  • splasher
    splasher SuperUser ✭✭✭✭
    edited December 2016

    I have Quicken Premier 2016 and have tried all the suggested solutions to prevent placeholder entries and they still appear each time I download transactions into my investment register -- many times listing the number of placeholder shares as 0. This is very annoying.

    @Steve Gulgas
    Go to the Account List (Tools menu) and edit the account.  On the Online Services tab, make sure that auto enter is turned off there also.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited October 2018
    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.
  • Unknown
    Unknown Member
    edited December 2016
    Jerry said:

    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.

    Yes that is exactly how you are suppose to handle them.
    On #2 good question.  Most consider that a bug, especially since you can go into the placeholder and enter the information needed to create the proper transactions from there, and still it won't remove the zero share placeholders.  It use to delete them in that past versions of Quicken.
  • Unknown
    Unknown Member
    edited December 2016
    Jerry said:

    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.

    Zero means no quantity or number; naught; you can't reconcile "zero" differences in shares. . . It's a bug introduced in quicken 2016 mid release. the only way to handle them was to delete every one downloaded every time, wasting considerable time for those of us with many accounts and stocks.


  • Unknown
    Unknown Member
    edited October 2017
    Jerry said:

    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.

    2016 Quicken Zero Placeholder bug is fixed in Quicken H&B 2017!!!

    I finally had the nerve to upgrade to 2017 R3 (figuring after three releases most of the bugs would be fixed) and long and behold, the hundreds of Zero Placeholders being downloaded every week disappeared. So if anyone else is plagued with this bug, try the upgrade. After a few weeks, I can't find any other problems, which is a first for me for the past six years of quicken releases until at least the 7th Release of bug fixes. Hopefully, this quicken sale will end the parade of new bugs with all these useless new features every year. I don't mid paying every year, but the time wasted with these update bugs is getting me close to moving to the web brokerage data compilers available now, especially since they have to track the realized gains now. After 30 years with Quicken, I have hope again.

  • Unknown
    Unknown Member
    edited December 2016
    Jerry said:

    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.

    Thanks for point out this is fixed.  Of course the release notes didn't mention it.  :-)

    I just tried it and yep it is fixed for me too.
  • Unknown
    Unknown Member
    edited December 2016
    Jerry said:

    I have a related question.


    When I get an occasional Placeholder I try to correct it by finding or adding the missing transaction. That results in the Placeholder now becoming one with 0 shares discrepancy. I usually delete these resulting 0 shares placeholders but I have worried that I might be causing a problem somewhere by doing so.


    1. Is it OK to delete placeholders that after resolution result in 0 shares placeholders?


    2. Since I have resolved the missing or erroneous downloaded transaction, why does the placeholder not just disappear and no longer exist? Is that a bug or am I missing something.

    BTW it wasn't fixed in R2, it is something new for R3.
  • Unknown
    Unknown Member
    edited October 2018
    The problem with the Placeholders is extremely frustrating.  Based on one of the comments above, I upgraded from 2016 to 2017 hoping to resolve the zero shares/amounts Placeholder entries - did not work.  I then went to the Placeholder tab to click on the delete button, which I could not see.  Also, it showed that I do not have any Placeholder entires.  However, when I print out the summary account reconciliation, lots of outstanding Placeholder Entry (all showing 0 shares and 0 amount) are being printed out on the reconciliation - wasting a lot of paper and/or storage on my computer.  How can I get these deleted or cleared so they no longer show up on the reconciliation?
  • Unknown
    Unknown Member
    edited January 2017

    The problem with the Placeholders is extremely frustrating.  Based on one of the comments above, I upgraded from 2016 to 2017 hoping to resolve the zero shares/amounts Placeholder entries - did not work.  I then went to the Placeholder tab to click on the delete button, which I could not see.  Also, it showed that I do not have any Placeholder entires.  However, when I print out the summary account reconciliation, lots of outstanding Placeholder Entry (all showing 0 shares and 0 amount) are being printed out on the reconciliation - wasting a lot of paper and/or storage on my computer.  How can I get these deleted or cleared so they no longer show up on the reconciliation?

    Linda Sheldon what I think you are missing is this option:
     Edit -> Preferences -> Investment transactions -> Show hidden transactions

    Placeholders are hidden transactions, and will not show up in your register until you select this option to show them.
  • Janet Batchelor
    Janet Batchelor Member ✭✭
    edited October 2018
    I joined this group tonight seeking an answer to the annoying placeholders. I have Quicken 2016 Premier and have been using Quicken since 1987. If I couldn't fix the problem I was going to look for some other way to track my finances. I tried going to Edit, preferences, Investment Transactions and unchecked the box for show hidden transactions and unchecked the box for show attach button. Magically, all the placeholders that just downloaded a few minutes ago disappeared. It's sad that the Intuit/Quicken managers don't realize the benefits of working on resolving issues so that folks like me will keep using the product. Since I now know that 2017 version didn't fix this problem, I'm not going to bother upgrading to 2017.
  • Unknown
    Unknown Member
    edited February 2017

    I joined this group tonight seeking an answer to the annoying placeholders. I have Quicken 2016 Premier and have been using Quicken since 1987. If I couldn't fix the problem I was going to look for some other way to track my finances. I tried going to Edit, preferences, Investment Transactions and unchecked the box for show hidden transactions and unchecked the box for show attach button. Magically, all the placeholders that just downloaded a few minutes ago disappeared. It's sad that the Intuit/Quicken managers don't realize the benefits of working on resolving issues so that folks like me will keep using the product. Since I now know that 2017 version didn't fix this problem, I'm not going to bother upgrading to 2017.

    I don't think you read all the comments.  If your problem is with the zero placeholders created when you have "automatic entry mode" on for investment accounts, it was fixed in Quicken 2017 R3 (current version is now R4).

    Note it isn't going to remove the zero placeholders that are already there just not create them in the future and that is why the comment above on how to find them if they need to be deleted.

    Also in Quicken 2016 if you just turn off the "automatic entry mode" for investment accounts you won't get them either.
  • Unknown
    Unknown Member
    edited March 2017
    I just wanted to thank those who posted above on this topic. Out of the blue I began experiencing Placeholder entries with 0 shares in Quicken 2016. In my case it was not possible to work around the problem with "automatic entry mode".

    However, upgrading to Quicken 2017 V4 did fix the problem for me. Thanks!   
This discussion has been closed.