Double-paste of amounts in "Inv. Amt" Field

Unknown
Unknown Member
edited November 2018 in Investing (Windows)
I have Quicken 2017 Premier.  When entering investment transactions in the register (as opposed to opening the dialog box to enter information about a transaction), the Quicken program pastes the amount that I have copied into the clipboard two times in the "Inv. Amt" field, which requires me to then delete the second pasting of the amount before hitting Enter to record the transaction.

So, for example, let's say I am recording a dividend that appears on my brokerage statement.  I go to the PDF of the brokerage statement (or go online to the brokerage website) and copy the amount of the dividend using CTRL-C (to copy the amount into the Windows clipboard).  Let's say the dividend is $31.29 for example.  So I go back to quicken, to the investment page for this brokerage, and I first enter the date in the date field, then I hit tab to advance to the "Action" field and enter Div, then I hit tab to advance to the Inv. Amt field, where I type CTRL-V to paste the dividend amount of $31.29.  But instead of pasting it once into the field, Quicken pastes it twice, back to back, so it looks like this:  31.2931.29.  If I hit Enter at that point, as I often do by mistake, the program says "Please enter a valid amount."  Indeed.

I hope that Quicken will be able to fix this problem, because it is very annoying.  And by the way, it is not a problem originating with my Windows software, my mouse, or any root cause other than Quicken.  How do I know this.  Well, if I paste the dividend anywhere else, including in a different field of the investment register area (say the Security field), it only pastes one time.  Likewise, if I paste it in a different program, Microsoft Word for example, it only pastes one time.  So this is a Quicken problem.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018
    If you search this website you will find that, unfortunately, there are plenty of posts about this, that or the other "Copy and Paste not working" related issue.
    I sincerely wish that Quicken would eventually get a round tuit and fix these issues.
    But until then I am going to stay away from copy and paste like I stay away from placeholder transactions in investment account registers.

    May I recommend that you do the same?
    Forget copy and paste. Just type the amount in. Much faster, and hopefully less error riddled.
  • Mark Coil
    Mark Coil Member ✭✭
    edited January 2018
    I've experienced this bug for many years/versions of Quicken. I keep hoping they'll fix it, but alas.....
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited November 2018
    Not to encourage bad practices, but have you checked to see whether pasting this value into another application like Notepad also gives a double number?

    It's possible that the number is printed twice in the PDF with a slight offset to simulate a Bold font, and the Copy is picking up both of them.
    QWin Premier subscription
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited November 2018
    I tried to reproduce this in QW2018 and could not. Perhaps it's fixed. (I don't have any other Quicken versions running at the moment to check earlier years.)
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited January 2018

    I tried to reproduce this in QW2018 and could not. Perhaps it's fixed. (I don't have any other Quicken versions running at the moment to check earlier years.)

    Oops, wrong again. I usually operate with "Quicken Standard" key
    mapping under Edit > Preferences > Setup. With that option chosen,
    the bug does not occur.

    Using "Windows Standard" key mapping causes the bug
    to occur when CTRL-V is used. Other methods of Paste such as SHIFT-INSERT and right-click+Paste do the right thing.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited January 2018

    I tried to reproduce this in QW2018 and could not. Perhaps it's fixed. (I don't have any other Quicken versions running at the moment to check earlier years.)

    Aha! I see the same thing:

    I used a freshly created file in Q 2018 R4.10 set to Windows keymapping, Note that this is the default keymapping for new files.

    I copied a cell from Excel with Ctrl-C and set up a Div in the Transaction list as Bob describes. pasting the value into the Amount field with Ctrl-V, and the number was pasted twice. It is also wrong when you paste the number into Amount field on a Deposit or Withdraw.

    Setting up a Buy and pasting into the Shares or Price fields is OK, but it also pastes twice in the Amount field..

    So it looks like it is only pasting with the (default) Windows keymapping into the Amount field in the Transaction list where it is wrong. Unfortunately it appears this is not uncommon among those who enter transactions directly into the list.

    This should be old code, but pretty localized. Since I think there is other repair work going on in this area, this fix might be a good one to add to the list.
    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited January 2018

    I tried to reproduce this in QW2018 and could not. Perhaps it's fixed. (I don't have any other Quicken versions running at the moment to check earlier years.)

    Further note to developers: Please do not "fix" this by making the Quicken keymapping the default! That will cause even more confusion I think.
    QWin Premier subscription
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited January 2018

    I tried to reproduce this in QW2018 and could not. Perhaps it's fixed. (I don't have any other Quicken versions running at the moment to check earlier years.)

    The other oddity here is that CTRL-V performs a Paste in investment registers even when "Quicken Standard" key mapping is chosen. In banking registers, it Voids the selected transaction. This can be an unpleasant surprise because it loses information; the transaction amount is erased.

    Historical Note for Nerds: the Quicken Standard key map dates from MS-DOS days and predates the Windows Standard, which itself was copied from the Macintosh user interface. If Quicken had been born a year or two later, it would probably have only the Windows Standard mapping.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Mark Coil
    Mark Coil Member ✭✭
    edited May 2018
    "Not to encourage bad practices, but have you checked to see whether pasting this value into another application like Notepad also gives a double number? 
    It's possible that the number is printed twice in the PDF with a slight offset to simulate a Bold font, and the Copy is picking up both of them."
    I have been using copy and paste extensively for many years using windows standard Ctrl-C and Ctrl-V. I copy from PDF's & web pages to ensure accuracy/speed of my data. I use it to paste dates, memos, number of shares, price, total amounts, names. It all works very well, except for this one field, Inv. Amt in the investment account register.
    Historical Note for Nerds: the Quicken Standard key map dates from MS-DOS days and predatesthe Windows Standard, which itself was copied from the Macintosh user interface. If Quicken had been born a year or two later, it would probably have only the Windows Standard mapping.
    Regardless of the history, Quicken and it's users have had over 20 years to learn how to make work/use the standard that the rest of the world has adopted. When I'm copying from PDF readers and browsers and pasting into quicken, using a work-around for a bug that has existed for as long as I can remember (quicken user since 1992) doesn't seem like a reasonable solution.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited January 2018
    Mark Coil said:

    "Not to encourage bad practices, but have you checked to see whether pasting this value into another application like Notepad also gives a double number? 
    It's possible that the number is printed twice in the PDF with a slight offset to simulate a Bold font, and the Copy is picking up both of them."
    I have been using copy and paste extensively for many years using windows standard Ctrl-C and Ctrl-V. I copy from PDF's & web pages to ensure accuracy/speed of my data. I use it to paste dates, memos, number of shares, price, total amounts, names. It all works very well, except for this one field, Inv. Amt in the investment account register.
    Historical Note for Nerds: the Quicken Standard key map dates from MS-DOS days and predatesthe Windows Standard, which itself was copied from the Macintosh user interface. If Quicken had been born a year or two later, it would probably have only the Windows Standard mapping.
    Regardless of the history, Quicken and it's users have had over 20 years to learn how to make work/use the standard that the rest of the world has adopted. When I'm copying from PDF readers and browsers and pasting into quicken, using a work-around for a bug that has existed for as long as I can remember (quicken user since 1992) doesn't seem like a reasonable solution.There is something else going on.  

    I too have used Quicken since DOS days.  I never saw the issue before QW2017.  The issue did start appearing for me, but I have not seen it recently.  

    My preferences have always been set to Windows Standard.Copy/Paste.  

    I'll continue to look for it, especially with the Amount field.  
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited January 2018
    Mark Coil said:

    "Not to encourage bad practices, but have you checked to see whether pasting this value into another application like Notepad also gives a double number? 
    It's possible that the number is printed twice in the PDF with a slight offset to simulate a Bold font, and the Copy is picking up both of them."
    I have been using copy and paste extensively for many years using windows standard Ctrl-C and Ctrl-V. I copy from PDF's & web pages to ensure accuracy/speed of my data. I use it to paste dates, memos, number of shares, price, total amounts, names. It all works very well, except for this one field, Inv. Amt in the investment account register.
    Historical Note for Nerds: the Quicken Standard key map dates from MS-DOS days and predatesthe Windows Standard, which itself was copied from the Macintosh user interface. If Quicken had been born a year or two later, it would probably have only the Windows Standard mapping.
    Regardless of the history, Quicken and it's users have had over 20 years to learn how to make work/use the standard that the rest of the world has adopted. When I'm copying from PDF readers and browsers and pasting into quicken, using a work-around for a bug that has existed for as long as I can remember (quicken user since 1992) doesn't seem like a reasonable solution.Saw the issue again today.  Did enough testing to see it only applies in the Amount field of an investment account.  Pasting same string into any other field behaved normally.  Windows std setting == Ctrl-V paste is the problem.  Rt-click paste OK, File Edit Paste OK.  Copied from outside of Quicken or inside Quicken made no difference.  
This discussion has been closed.