Budgeting with "_DivIncTaxFree" and "_IntIncTaxFree" Categories in Quicken Premier 2017.

Jerry_
Jerry_ Member ✭✭✭✭
edited November 2018 in Investing (Windows)
Ever since the new Budget Logic was introduced in Q2014 (I think), there has been a flaw in showing tax-free income as actual amounts in budgeting for the Investment Categories of “_DivIncTaxFree” and of “_IntIncTaxFree” (when entering the income in Investment Accounts). When entering or downloading the actual income as a dividend or interest in an Investment Account, the income is actually recorded by the Program in the corresponding taxable “_DivInc” or taxable “_IntInc” Category. I have made sure that the “Tax-Free” Box is checked in the “Edit Security Details” Window of the affected securities. One cannot assign categories in Investment Accounts.



I asked about this about 10 months ago with no satisfying answers. I am using the Windows version of Quicken Premier 2017 (R3) on a Windows 10 System. This needs to be corrected for the Program does allow the budgeting of investment income.



I cannot believe that I am the only one not having this problem. (g)
Now running the 2019 Windows Subscription Plan
Retired - former Computer System Analyst

Comments

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited May 2018
    For the record, the prior discussion from 10 months ago I'll withhold further comment until I better understand the issue.  
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    q.lurker - Are you awaiting further input from me? If so, what additional information are you seeking?
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited May 2018
    I was not awaiting a response from you.  I was putting off reading through that prior discussion.  Having now done so, I think it was a pretty solid factual discussion and I inherently agree with the remarks put forth by NoWayJose (aka Howard Roark), especially:
    This all may mean nothing, but it occurs to me that the _xxxxTaxFree category may not actually be part of the transaction, but may only be displayed when needed; in a report for example, where the display sees that it has an investment income category for a tax-free security being subtotaled by category, and displays the appropriate tax-free category name as the Group category name. (Emphasis added)
    That doesn't make the answers any more satisfying.    It does admit that the user has no real way to get the TaxFree categories to fill all the time and it does admit that the budget and planning modules may operate differently than other parts of the program.  

    I don't dispute your observations.  I don't know of any applicable workaround.  I do not use the budgeting modules myself so I cannot offer an opinion on the idea that this issue prevents all budgeting of investment income.  It seems perfectly reasonable to me that Quicken, Inc. should acknowledge this as a problem and provide some feedback on their intentions to address it or not.  (I am currently involved in another similar discussion.  I hold little expectation of getting any such acknowledgement in either case.)
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    Thank you for your valuable input. Like you, I also feel that Quicken Inc. should acknowledge this as a problem and provide feedback. I only see this problem in budgeting via the Planning Tab, When one generates budget reports showing the tax-free categories, the actual amounts do appear with their budgeted counterparts.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Ron McCall
    Ron McCall Member ✭✭
    edited June 2017
    I agree with you. This should be addressed. I am retired but not withdrawing from my IRA yet. The budgeting section shows _DivINC and _intINC as income when this is actually being reinvested in my IRA. I want to know how much return my IRA has, but that money is different than regular _intINC and _DIVinc that I am actually receiving and owe taxes on. Glad to see some one else is concerned over it. As well I cannot find any method to change the Categories. I will keep an eye on this thread in the hope that someone comes up with a solution.
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    Ron McCall, thanks for your support.
    Quicken Team, has this Budget condition been addressed in Quicken 2018?
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited November 2018
    Ron,

    One approach that *may* help address your issue with the handling of dividend and interest income in IRAs and other investment accounts, taxable or not and reinvested or not, is not make budget categories for _DivInc or _IntInc, and let them be lumped into the "Everything Else" part of your income. Then you create budget categories for transfers between your investment and spending accounts.

    With this approach, you are using the budget tool to plan and track flows in and out of your spending accounts, and not for tax planning. After all there are reports and a whole tax planning section in Quicken which are designed to help with tax planning (not very well IMO, but that is another topic...)

    If you want to include interest on accounts in the Banking section of Quicken in your budget, you can make a separate Category called Interest Inc or whatever with the correct tax category and credit your bank account interest to that. 
    QWin Premier subscription
  • Unknown
    Unknown Member
    edited October 2017
    I am using Quicken 2017 R15.  I thought I have the same problem, but when I run the report: "Tax/Tax Summary", the tax-exempt income correctly shows up under _DivIncTaxFree. 

    In the transaction register it still is ReinvDiv.  I guess Quicken determines the difference when the “Tax-Free” Box is checked in the “Edit Security Details”

    Somewhat Confusing
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    jheroen_dorenbos Ah, another interesting scenario. I think that you have an educated guess when stating the determination of being tax-free is when the "Tax-Free" Box is checked in the "Edit Security Details".
    It seems that generated (budget) reports do show the correct actual and budgeted amounts in the Investment Categories of “_DivIncTaxFree” and of “_IntIncTaxFree”.
    My problem is not seeing the actual amounts showing in the bar graphs of the corresponding tax-free categories when utilizing the budgeting tool via the Planning Tab,
    The amounts are actually accumulated and shown in the bar graphs of their corresponding tax categories.
    I am now using the latest version of Windows Quicken 2017 (R15) on Win 10.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Charlie C.
    Charlie C. Member ✭✭
    edited October 2017
    Ditto on the issues Jerry mentioned. In my case It is same for "-divinc" and "-intinc". I am using Q2017 V: R15 - Windows 10.
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    Has the inconsistency of not showing actual amounts in the tax-free dividend and interest category bar graphs in budgeting under the Planning Tab been addressed in QW2018?

    If not, for me, I see no reason to upgrade to QW2018. I do not have to upgrade until my QW2017 (R15) goes off-line in 2020.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Charlie C.
    Charlie C. Member ✭✭
    edited November 2017
    Jerry, That is a great solution and works for me as well. I ran some investment reports and it looks like all funds are hitting properly in the budgets. Thanks for your efforts. It's appreciated.
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited May 2018
    Charlie C.  Thanks for your kind words. I hope that others might find this solution beneficial.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Unknown
    Unknown Member
    edited November 2017
    Jerry said:

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Thanks Very Much for this great solution
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    edited November 2017
    Jerry said:

    Has the inconsistency of not showing actual amounts in the tax-free dividend and interest category bar graphs in budgeting under the Planning Tab been addressed in QW2018?

    If not, for me, I see no reason to upgrade to QW2018. I do not have to upgrade until my QW2017 (R15) goes off-line in 2020.

    @Jerry

    I am running QW2018 with divinctaxfree as a selected budget category. Actuals do NOT show up in the planning tab. (The actuals do correctly show up in budget reports).
    Quicken Premier Subscription, Windows 10 Home
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited November 2017
    Jerry said:

    Has the inconsistency of not showing actual amounts in the tax-free dividend and interest category bar graphs in budgeting under the Planning Tab been addressed in QW2018?

    If not, for me, I see no reason to upgrade to QW2018. I do not have to upgrade until my QW2017 (R15) goes off-line in 2020.

    Bob L, Thanks for your update. Have you tried my "Work around" that I have below outlined? If you can think of a better solution for QW2018 (and QW 2017), feel free to contribute.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited September 2019

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Thanks, guys, for your kind remarks.[removed]
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    edited November 2017
    Jerry said:

    Has the inconsistency of not showing actual amounts in the tax-free dividend and interest category bar graphs in budgeting under the Planning Tab been addressed in QW2018?

    If not, for me, I see no reason to upgrade to QW2018. I do not have to upgrade until my QW2017 (R15) goes off-line in 2020.

    Looks like it would work, but I really do not use the budget much. And, if I do it is via the reports, not the planning tab.
    Quicken Premier Subscription, Windows 10 Home
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited November 2017
    Jerry said:

    Has the inconsistency of not showing actual amounts in the tax-free dividend and interest category bar graphs in budgeting under the Planning Tab been addressed in QW2018?

    If not, for me, I see no reason to upgrade to QW2018. I do not have to upgrade until my QW2017 (R15) goes off-line in 2020.



    Bob L Thanks for the info on QW2018. I think that I will still hold off on updating to QW2018 from QW2017. I see now where the reviews on Amazon are turning more Negative. 
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Unknown
    Unknown Member
    edited December 2017
    This is still not working.  Schedule B Interest and Div report will work for 2016 transactions but not 2017 Transactions.
  • Unknown
    Unknown Member
    edited December 2017

    This is still not working.  Schedule B Interest and Div report will work for 2016 transactions but not 2017 Transactions.

    In the report settings, have you changed it to Current Year? 

    Also, what year version of Quicken are you using?  If it is 2016, it may only include the Schedule B up to and including the year 2016.  
  • Unknown
    Unknown Member
    edited May 2018
    Jerry, I had the same problem and agree that quicken should fix this.  I found the same solution that you did for dividends and Interest earned in Tax free accounts.  Where you able to find a solution for the reinvested dividends without breaking the transaction into multiple lines (e.g. dividend earned, then buy)?
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited January 2018

    Jerry, I had the same problem and agree that quicken should fix this.  I found the same solution that you did for dividends and Interest earned in Tax free accounts.  Where you able to find a solution for the reinvested dividends without breaking the transaction into multiple lines (e.g. dividend earned, then buy)?

    Nathan, I really have not expanded my testing to include Reinvested Dividends. All of my tax-free investments are now in-state municipal bonds (with far out maturity dates (lol)). Sounds like you found a solution. Maybe others have worked on this problem, and have found solutions as well.

    All this started around 4 or 5 years ago when Mint became part of Intuit/Quicken. Intuit seemingly adopted the Budget GUI from Mint (showing horizontal graph bars in the monthly view). As I have seen, little work as been done since adopting from Mint.

    Thanks for mentioning your solution for handling reinvested dividends.
     
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • dmhump1
    dmhump1 Member ✭✭
    edited February 2018
    Jerry said:

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Unfortunately, I was unable to use this workaround because those options aren't present for the internal transactions I've been seeing under the _RlzdGain category. This is characterized as a Sell transaction. If I recharacterized it as Income, I'm not sure what dominoes might get knocked over in the process. Maybe I'll try it and see.
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited February 2018
    Jerry said:

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Go back to this Thread: 
    https://getsatisfaction.com/quickencommunity/topics/is-it-possible-to-recategorize-investment-accoun.... Remember it? (grin)

    Pay attention to the remarks that User "QPW" made a year back.

    If I might paraphrase his remarks. He states that;

    I am thinking of a situation where I want to change a Sell from _RtzdGain to another category so I could report it separately. The only way you can currently do this would be to add in new transactions for every sell.

    They would be "Misc Income/Expense" actions.  One to offset the default category and another to put it into the category you want.
    
    However, he does not give a pictorial procedure on how he would accomplish the feat. My "thinking cap" is not awake at this point; so can anyone give an example of such a procedure?
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • Jerry_
    Jerry_ Member ✭✭✭✭
    edited February 2018
    Jerry said:

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Ah, my "thinking cap" is awaking. (grin).

    1. Enter a Misc Expense transaction for the amount in the _RtzdGain category specifying the Category of "_RtzdGain".
    2. Enter a Misc Income transaction for that amount in whatever other Category you choose. The Category can even be a "non-investment" one.
    Now running the 2019 Windows Subscription Plan
    Retired - former Computer System Analyst
  • dmhump1
    dmhump1 Member ✭✭
    edited February 2018
    Jerry said:

    I have come across a "Work-around" which I can accept for now. I download all of my investment transactions into their respective investment accounts. After accepting them all, I search for transactions that are associated with tax-free securities. When I find one, I highlight it, double-click on it to generate the following window:
    image
    This particular transaction is tax-free interest from a state muni bond. So I move the dollar amount from the "Interest" entry to the "Miscellaneous" entry on the right side. This action activates the Category for Miscellaneous drop-down category list on the left. There I choose the "_IntIncTaxFree" Entry from the list.
    (If this were a tax-free dividend, I would have moved the dollar amount from the "Dividend" entry to the "Miscellaneous" entry on the right side, and would have chosen the "_DivIncTaxFree”  Entry from the list on the left side.)
    When I select the "Enter/Done Button, the result for the transaction in budgeting via the Planning Tab appears like this:
    image
    Budget reports still look good. The only problem might be in viewing investment reports and security lists. The action associated with utilizing the Miscellaneous method show as "cash" vs "div" or "int".
    I am satisfied with this work-around until the Quicken developers can program the logic into Quicken.

    Bullseye, Jerry, this does work. That transaction & amount no longer appears in the Planning>Budgets bar graph. I added the word "Workaround" in the Memo field so I could find them easily if I need to undo this.

    It is however a cumbersome procedure if you have a lot of them, and I have about a dozen plus a new one every time I sell shares, etc. Not sure it's worth the trouble, but at least I have a process now.
This discussion has been closed.