Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Investment allocations graph won't exclude cash in HSA account

KnnNike
KnnNike Member ✭✭✭
edited January 2018 in Investing (Windows)
I use the Portfolio > Allocations graph quite regularly to get a sense of my holdings. One of my investment accounts is an HSA, which in addition to the investments balance, has a $1,000 cash balance. I cannot invest this cash, as the bank requires this amount as a minimum balance, so I would like to exclude it from my allocations report (because it's throwing off my reported allocations). When I customize the allocations graph, I can go to the "Securities" tab, and uncheck "No Security (includes cash)". However, when the graph updates, the cash amount from my HSA account is still shown.

I think the problem may be that in my HSA account settings, I have it set so that the cash balance shows as a separate account under "Banking" - when I turn this off, the cash balance is correctly excluded from the allocations graph. In my mind, however, setting the cash balance as a separate account should still have it excluded when I uncheck the "No Security" box. Is this a bug with the software, or is there some other setting I'm missing?

Comments

  • Unknown
    Unknown Member
    edited June 2017
    Your cash balance is in the Banking area.

    Therefore, it's not an investment account.  

    "No security" pertains to investment accounts.

    Connect the dots from there.  Excluding the account is the way to do it.  
  • KnnNike
    KnnNike Member ✭✭✭
    edited June 2017
    So what you're saying completely makes sense, and is logically the way to approach this. However, I do not have the option to exclude the cash account in the accounts list when I customize my allocations graph. In Quicken, I have one account, call it "HSA-Investing" listed under investments, and another account "HSA-Cash" listed under banking. Both accounts tie to the same physical account, but are represented as two separate ones in Quicken.

    I want to completely exclude "HSA-Cash", but in the allocations graph, I am only given options to exclude accounts listed under investing --> "HSA-Cash" doesn't even show up. Quicken appears to be lumping it back into the "HSA-Investing" account for the purpose of graphing, because when I click for a detailed view of the cash allocation, it shows a $1,000 balance tied to "HSA-Investing".

    What's weird is if I fold "HSA-Cash" back into "HSA-Investing" outside of the allocations graph (so, on the account bar over on the left-hand side), checking the "No Security" box in the customize view window properly excludes the $1,000. That's why I think I might be dealing with a bug here.
  • KnnNike
    KnnNike Member ✭✭✭
    edited June 2017
    KnnNike said:

    image

    This is literally what I see on my end - "Alliant HSA" is the account in question. The separate cash account, named "Alliant HSA-Cash" doesn't even appear in this list. But its balance of $1,000 is still showing up in the allocations graph.
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited June 2017
    KnnNike said:

    image

    Try setting up a savings plan for the HSA and contributing $1,000 to the savings plan.  That seemed to work for me, though I don't have my HSA set up as "two" Accounts like you do.
This discussion has been closed.