How to copy investment transactions?

Rich
Rich Member ✭✭
edited October 2018 in Investing (Windows)
I just recently upgraded to Quicken Premier 2018 for Windows and I'm having difficulty in successfully copying investment transactions.  I've tried to copy by using both the dropdown menu and by using right click to get a menu.  Either way, I get the "copy" option ok, but when I try to enter the transaction on a new line the "paste" option is grayed out and does not allow the transaction to be copied.  I would appreciate any recommendations anyone might have. 

Comments

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited October 2018
    What kind of investment transaction are you trying to copy/paste?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Rich
    Rich Member ✭✭
    edited May 2018
    mshiggins said:

    What kind of investment transaction are you trying to copy/paste?

    There are a variety of transactions that for some reason didn't come through on downloads to my 401K account.  I intend to manually enter, but because of the number of transactions, copying and pasting would be very helpful.
  • Rich
    Rich Member ✭✭
    edited May 2018
    mshiggins said:

    What kind of investment transaction are you trying to copy/paste?

    Most of these transactions are buys and sells of securities.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited May 2018
    mshiggins said:

    What kind of investment transaction are you trying to copy/paste?

    Right-click on an empty line in your investment register and select Paste Transaction.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited October 2018
    The Copy command under the Edit menu won't copy a transaction, and neither will the keyboard shortcuts for Copy. You have to use the right-click and choose Copy Transaction, then use right-click again and Paste Transaction. Alternatively, you can use the main menu if you go an extra level, e.g., Edit > Transaction > Copy Transaction.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Rich
    Rich Member ✭✭
    edited October 2018
    I've tried both the right click method of copying and pasting as well as using the main menu using Edit>Transaction>Copy Transaction.  In both cases, when I move the cursor to where I want to enter the transaction, the Paste option is dimmed out and will not let me paste the transaction.  I feel like there is something simple that I'm missing, but I'm not seeing it.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited May 2018
    Rich said:

    I've tried both the right click method of copying and pasting as well as using the main menu using Edit>Transaction>Copy Transaction.  In both cases, when I move the cursor to where I want to enter the transaction, the Paste option is dimmed out and will not let me paste the transaction.  I feel like there is something simple that I'm missing, but I'm not seeing it.

    If the Paste transaction(s) is not selectable, either the transaction paste buffer is empty or Quicken thinks you're attempting to paste a transaction in an inappropriate location.
  • Rich
    Rich Member ✭✭
    edited May 2018
    Rich said:

    I've tried both the right click method of copying and pasting as well as using the main menu using Edit>Transaction>Copy Transaction.  In both cases, when I move the cursor to where I want to enter the transaction, the Paste option is dimmed out and will not let me paste the transaction.  I feel like there is something simple that I'm missing, but I'm not seeing it.

    After some experimentation, I've realized that the problem is limited to two of my accounts, both of which are Schwab retirement accounts (one 401K, one deferred comp plan).  The transaction copy/paste function seems to work fine in my other investment accounts, both brokerage and IRA.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited May 2018
    Rich said:

    I've tried both the right click method of copying and pasting as well as using the main menu using Edit>Transaction>Copy Transaction.  In both cases, when I move the cursor to where I want to enter the transaction, the Paste option is dimmed out and will not let me paste the transaction.  I feel like there is something simple that I'm missing, but I'm not seeing it.

    You should find some transactions may be pasted but others may not.  For example, within a 401(k), you should be able to copy and paste a ReinvDiv but not a Deposit.  
This discussion has been closed.