Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Tax free muni bond interest showing as taxable in Quicken 2018

Unknown
Unknown Member
edited January 2019 in Investing (Windows)
Quicken 2018 Home, Business & Rental Property version R9.30. Running on Windows 10 Pro x64 with all updates applied.

I noticed this as I was running tax reports for Jan - May: an old Quicken bug has resurfaced. When I download transactions from Schwab, interest on my tax-free muni bonds (which have been marked as Tax Free for each bond in the Security List), the interest is recorded as _IntInc instead of _IntIncTaxFree. This was working fine in Quicken 2015 Home & Business, but I do recall this bug popping up in some earlier version (may have been Q 2015, but if so it was fixed by a patch).

This bug is back, and the only work around I have found is to manually edit each and every Muni Bond interest transaction to manually move the Income from the Interest to the MISC field, then force the use of _IntIncTaxFree instead of _IntInc.

PLEASE FIX THIS!

Comments

  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    edited January 2019
    Not seeing this in QW 2018 R9.30 Premier. The register shows IntInc but all tax and investment reports properly segregate all the munis to the _IntIncTaxFree category. I suspect you have some corruption in your data file.
  • splasher
    splasher SuperUser ✭✭✭✭
    edited October 2018
    Have you checked and confirmed that all of your tax-free muni bonds are marked as "tax free"? 

    Maybe something in the conversion from 2015 to 2018 unchecked them as tax free.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited January 2019
    Markus: I've previously verified and super-verified my file, so if there is corruption it is not being found by any tools I can use. Perhaps it is a diff between HBR&P and other versions (like Premier). The fact that I've seen this bug in the past (and am seeing it again now) indicates a change made in Quicken (indicates, not proves). There may be many factors contributing, like the size or particular configuration of my data file.

    Splasher: I checked enough of them to know it is happening. I did not check every single one. 
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited October 2018
    Tax-free interest and dividend transactions show Categories as _IntInc and _DivInc. However, when you run the appropriate reports, the tax-free-ness appears. You don't need to keep adjusting the categories of those transactions. You're making extra work for yourself.


    This is probably non-obvious and non-intuitive. But it's the way Quicken works. If you feel like experimenting, make a copy of your data file and edit all the transactions you've changed to Miscellaneous Income back to regular Interest and Dividends. Then run the Investment Income report. You'll see separate, correct rows for the TaxFree categories. If you don't, then something is indeed wrong with your data.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    edited June 2018
    Dennis Ad said:

    Markus: I've previously verified and super-verified my file, so if there is corruption it is not being found by any tools I can use. Perhaps it is a diff between HBR&P and other versions (like Premier). The fact that I've seen this bug in the past (and am seeing it again now) indicates a change made in Quicken (indicates, not proves). There may be many factors contributing, like the size or particular configuration of my data file.

    Splasher: I checked enough of them to know it is happening. I did not check every single one. 

    The one thing I do know is that munis are recorded in the register as _IntInc just like any other bond. Quicken then looks for the check box in Security Details to determine special handling for a tax free bond when rendering reports or queries. 

    Manually changing the category as you have is forcing the category to be applied and moving that transaction outside of the special handling processes. I wonder if it is also confusing the reporting queries. When I look at the Category List and the Usage link for _IntIncTaxFree, I see only 4 usages. If I click though I see the many hundreds of Tax Free bond and fund interest entries categorized as _IntInc.

    If it is not corruption, then I will suggest it may be query confusion caused by transactions tied to securities with the tax free box checked that also have the _IntIncTaxFree category forced upon them. I do have 4 forced entries but they are tied to the Vanguard tax managed mutual fund that maintains a stock index and tax free bond portfolio which I do not have the Tax Free box checked in Security Details.

    Try running an investment transactions report and changing back all of the forced entries to regular entries in the Interest box. Or you might try Recategorize from the Usage link in the Category List for _IntIncTaxFree.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited June 2018

    Tax-free interest and dividend transactions show Categories as _IntInc and _DivInc. However, when you run the appropriate reports, the tax-free-ness appears. You don't need to keep adjusting the categories of those transactions. You're making extra work for yourself.


    This is probably non-obvious and non-intuitive. But it's the way Quicken works. If you feel like experimenting, make a copy of your data file and edit all the transactions you've changed to Miscellaneous Income back to regular Interest and Dividends. Then run the Investment Income report. You'll see separate, correct rows for the TaxFree categories. If you don't, then something is indeed wrong with your data.

    From C. D. Bales:


    " ... the interest is recorded as _IntInc ....".


    I can confirm Rocket J Squirrel's claim.


    What you see is not a bug: interest income for tax-free securities has always been recorded to the category _IntInc.


    Confirmed in Q2012, Q2014, Q2015, Q2016, Q2017 and Q2018.


    The problem in Q2015 (and Q2016) was that, unlike all the other tested versions, it failed to retain the tax-free designation in reports.


    When Quicken creates reports by category, it normally recognizes that transactions for tax-free securities are non-taxable.


    So in reports Quicken reports them in the _IntIncTaxFree category (or sometimes in a variation of that name) - and it excludes such transactions from Tax reports. Q2018 is no different in this regard. [Check out a Q2018 Banking > Transaction report subtotaled by Category, or a Spending > Itemized Categories report - as well as a Tax > Tax Schedule report]


    Of the versions I tested, ONLY Q2015 and Q2016 failed to recognize that transactions for interest income from tax-free securities were actually tax-free transactions. Q2015 and Q2016 did not report tax-free income transactions correctly, and incorrectly included them in Tax reports.


    None of the other Quicken versions I tested (including Q2018) have that problem.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited June 2018

    Tax-free interest and dividend transactions show Categories as _IntInc and _DivInc. However, when you run the appropriate reports, the tax-free-ness appears. You don't need to keep adjusting the categories of those transactions. You're making extra work for yourself.


    This is probably non-obvious and non-intuitive. But it's the way Quicken works. If you feel like experimenting, make a copy of your data file and edit all the transactions you've changed to Miscellaneous Income back to regular Interest and Dividends. Then run the Investment Income report. You'll see separate, correct rows for the TaxFree categories. If you don't, then something is indeed wrong with your data.

    I've been traveling and finally had time to look into this further. I examined all of my Muni Bonds, and only 3 of them were missing the tax-free check mark. I decided to go through my entire Securities list and verify each bond. Other than the 3, all had the check mark set for Tax Free. I also unchecked Download Quotes for all the bonds I'd sold (some still had CUSIPs as they had not matured),

    After that long process, I started changing the bond interest transactions back to using the Interest Income (instead of Misc. Income / _IntIncomeTaxFree). When I reran the Tax Schedule, the bonds did not reappear in the Schedule B Interest section. I was not clear in my initial post that what drove this entire effort was Interest from these Tax Free Muni's (all but 3 of a dozen or so had that bit set originally) was showing up in the Tax Schedule as taxable interest. Apologies for leaving that important fact out.

    CD Bales - thank you for your exhaustive review of the problems in earlier versions of Quicken. The 2015 issue was what I ran into in the past, and seeing the same report issue before (with the same workaround fixing it) led me to believe that old bug had resurfaced.

    Not sure which steps did the trick, but I am glad the reports are giving me the correct info again. 

    As for the potential for data file corruption -- well if that happens I am well and goodly screwed. I have regular backups I can go to, but this data goes back to the 1990's on some investments, and recreating all of that would be a nightmare.

    This issue is closed for me now, thanks!
  • zkaps
    zkaps Member ✭✭
    Tax-free interest and dividend transactions show Categories as _IntInc and _DivInc. However, when you run the appropriate reports, the tax-free-ness appears. You don't need to keep adjusting the categories of those transactions. You're making extra work for yourself.


    This is probably non-obvious and non-intuitive. But it's the way Quicken works. If you feel like experimenting, make a copy of your data file and edit all the transactions you've changed to Miscellaneous Income back to regular Interest and Dividends. Then run the Investment Income report. You'll see separate, correct rows for the TaxFree categories. If you don't, then something is indeed wrong with your data.
    I was having this problem with a tax-free mutual fund where dividends were being reported as taxable.  The problem was that the Tax Free box in the security definition was not checked.  Checking it fixed the problem.
    Thanks,
    zkaps
This discussion has been closed.