Stock Prices All Crazy Starting this Year

Every quarter I do a thorough analysis of my portfolio in Excel via a QKN Export of my portfolio at quarter end. My first salvo into wrapping up the 4th quarter 2018 gave me no prices for much of the portfolio. In going through various observational checks, come to find out there were no prices prior to 2018! So I asked it to download historical prices to way back. Having done so, the prices I got were all over the place, almost like the wrong ones were assigned to each ticker. There were also a number of spike in prices. I worked on one particular ticker to eliminate the spikes then realized the weird share pricing all over the place, that the historical prices are WRONG! I the prices for this one investment to my broker's reports and it is obvious.

In trying to resolve the problem from what I see with the Community I was reminded that perhaps the various validation tools might correct the problem. Validate did it's thing but locked up at, I guess, completion; I had to run Task Manager to see that it was "not responding" and I closed it. Tried again and same thing. The logs that came out seemed to say all is well. I tried the next one on the list and same problem. Right now I am running correcting price history; it's taking a long time but I don't have a "not responding" message (yet) in Task Manager.so I am assuming it's just doing it's thing.

What's going on and is anybody else having this problem? What is my fall back if this doesn't work?

Best Answer

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Quicken imports security price history from a third-party service provider.  If the data from the provider is not available or inaccurate, we may import the security price history using a CSV file:


  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    "Not responding" doesn't necessarily mean the task is dead. It can also mean the process has usurped the event loop. In this case, "not responding" is completely accurate, because events aren't being handled. Better to wait it out than to kill it.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Allen Horner
    Allen Horner Member ✭✭
    Hi Guys and thanks for the insights.

    As it turns out, Contestant No. 2 COME ON DOWN! Altho I am a bit mystified.as to how my file got corrupted in the first place. Probably happened this morning and it was not a busy-busy day with Quicken (meaning little activity on my part to screw things up). My guess is the data coming in from the outside provider (as Contestant No. 1 cited) was corrupt to begin with. Anyway scrupulous backer-upper that I am, I had made a backup just the night before that worked fine when I brought it in.

    Don't get me wrong, after all the years of using Quicken (and it's a lot, probably from the start of WYSIWYG) it has been pretty much trouble free.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    Ooooh what do I win?!?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.