Quicken Essentials Not Working with Mojave

This discussion was created from comments split from: Issue: Unable to open Quicken Essentials on the new Sierra Mac OS.

Comments

  • If you updated your Mac operating system to the recent Sierra release, Quicken Essentials will no longer work.  
    Your Quicken Essentials data file is still safe and on your system, and can be opened on your Sierra system by converting the file to Quicken Mac 2017.  

    If you have Quicken Essentials and have already upgraded to Sierra, you can purchase and install Quicken 2017 for Mac and easily migrate your Essentials file to Quicken 2017.
    this information is old 2016. now in 2019 I have similar problem with quicken essentials 1.7.4 not working with mac os mojave.  Can I upgrade to quicken deluxe and retrieve my essential data files?  Also note original purchase of quicken essentials was thru the apple store and product was not registered with quicken.  Quicken will not allow registration at this time. Will this affect being able to retrieve  essential data files?
  • RickO
    RickO SuperUser, Mac Beta Beta
    The information provided by Kathryn is still valid. The current subscription version of Quicken for Mac will open and convert your existing Quicken Essentials data file.

    This article has all the details:

    https://www.quicken.com/support/converting-your-data-quicken-mac-0

    Quicken Mac Subscription; Quicken Mac user since the early 90s
This discussion has been closed.