can't print negative numbers in red in investment register

I can't get the negative numbers in the investment registers to print in red. I tried checking and            un-checking the check mark in the colour box , but does not seem to make any difference, negatives  print in black only. My other registers, credit cards, chequing print the negatives in red.
 I am using Quicken 2019 with windows 10

Best Answer

Answers

  • Quicken Sarah
    Quicken Sarah Administrator, Moderator mod
    Hello @joe2774

    Thank you for taking the time to report this issue to the Community, although I apologize that you have not yet received a response.

    I attempted to replicate this issue on my version of Quicken for Windows Canada 2019, R16.18, but could not, the negative value investment transactions print in red as expected.

    What is the release number of your Quicken 2019 software?  If you aren't sure, this information may be found in the Help menu > About Quicken.

    What steps are you taking to print the Investment register?  Are you selecting "Print Transactions" from the Account Actions gear wheel icon?

    Using the Report menu > Investing > Investment Transaction report?  Or perhaps using short cut keys "Ctrl +P" or the File > Print Account option?

    If you preview the report before printing does the negative transactions appear in red in the preview? 

    If the report is saved as a PDF, do the negative transactions save correctly in red?

    Does this behavior happen in all data files?  If you aren't sure, please create a new "test" data file (File > New Quicken File), add a manual account and a couple of negative value transactions then try to print the register - does the negatives print in red or still in black?

    Please let us know, thank you.

    Sarah
  • joe2774
    joe2774 Member ✭✭
    edited June 2019
    I can't get the red numbers in my investment registers to print out in red. I tried checking and un-checking the the colour box in the print window, but does not seem to make any difference. My other registers, credit cards, chequing accounts, print the red numbers in red.

    In the attached JPG, which is a test file I set up, you can see on the left, the investment register shows $375.00 in red. But when I go to print preview, window on right, the $375.00 is in black. I tried printing anyway, hoping that perhaps it will print in red, no red, just black. I tried CTRL P, print to PDF, gear icon in the register, file > print.... I even tried print preview on Quicken 2016 version on another computer. Results are the same for all.
    I am using Quicken 2019; Ver: R16.22; Build 27.2.16.22; Edition: Canada on windows 10.
    I originally posted this issue back in March 2019 to which I received a response from Sarah, but I did not follow through on it at that time ( my fault).
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    In the Print dialog that comes up after you select the date range, is the Print in color box grayed out? If so, Quicken thinks your selected printer does not support color.

    If the print in color box is enabled, is it checked? Of course it needs to be checked to print in color.

    Note if you cancel the print dialog without printing or previewing, any changes to your settings are not saved.

    You might also try File > File Operations > Validate and repair and select the Reset all Quicken printer setting box.

    Please post back and let us know what happened.
    QWin Premier subscription
  • joe2774
    joe2774 Member ✭✭
    No it is not grayed out. I have a check mark in the box to print in colour.
    Yes I realize this if you cancel the print dialog without printing or previewing, any changes will be lost.
    Tried the reset printer option. Still a no red .
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited June 2019
    It is certainly strange that the red works elsewhere in Quicken but just not when printing investing registers. 

    Does the preview show up in red if you pick a different color printer, print to PDF for example?

    Also of course if you go to Properties for the printer you must pick color there too. 
    QWin Premier subscription
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    FWIW, I just tried it using Quicken US Subscription R19.44 and the red amounts show in the print preview.
    Quicken Subscription HBRP - Windows 10
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Could this be a problem specific to the Canadian version of Quicken for Windows?
    Perhaps we can get @Quicken Sarah or any other Canadian user to check his/her Canadian Q 2019 R 16.22 ...
  • joe2774
    joe2774 Member ✭✭
    Correct, red works elsewhere except when printint investments registers.

    No red in the print preview window. It doesn't matter if you print to pdf or one of the 2 printers I have. Both printers are enabled to print in colour.

    As I said before, I tried to print in Quicken 2016 and have the same issues, no red in print preview. So if it is a Canadian problem, its been around for a while.

    Could Sarah have a look at this?
  • MarcR
    MarcR Member ✭✭✭
    I have tried to print an investment register using my Home & Business edition 2019 R16.22 Build 27.1.16.22 on Windows 10 Version 1803 and it works perfectly fine.  I see the red numbers in my register and in print preview.  I printed a test page and it shows in red as well.
    Joe2774, are you using Home & Business edition or different version of Win10?

    Interestingly, I cannot say the same for printing my investment portfolio where I unfortunately also see red numbers. Initially, print preview, the colour box was greyed out but when I switched printers (from PDF to an HP) it allowed me to check the colour box.  Still, it did not show red in print preview either. Switching back to another printer also failed to show red numbers. 
  • joe2774
    joe2774 Member ✭✭
    I am using Quicken Deluxe 2019; Ver: R16.22; Build 27.1.16.22; Canada. Windows 10, Ver 1803

    The red numbers in my investment registers will not print out in red, nor, as I have just discovered, is there is no minus sign in front of the the red numbers when I do a print preview.

    In the investment register, the $375.00 is in red with a minus in front of it. In the print preview the $375.00 is black with no minus in front of it. See the attached PDF. My other registers, credit cards, chequing accounts, print the red numbers in red.

    Interestingly, as MarcR pointed out, the investment portfolio will not print out any red numbers as well. Initially, in the print preview, the colour box is grayed out. But when I click on the printer, and re-select the same printer, all of a sudden, there is a check mark in the colour box. The print preview shows the minus sign in front of the numbers, but will not print in red with a minus.
  • MarcR
    MarcR Member ✭✭✭
    So the only difference is you are using the Deluxe version versus the Home & Business.  I guess it is time a Quicken official rep gets involved.  I will also send a Report a problem under the Help section for the Portfolio printing issue.  Joe2774, you should also do the same for your issues.  It may help for future update fixes.
  • joe2774
    joe2774 Member ✭✭
    thanks MarcR. I will do that.
  • joe2774
    joe2774 Member ✭✭
    Thank you, Sarah. The Reports > Investing >... will do for now.
    Regards,
    Joe
This discussion has been closed.