Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Register 'buttons' (Enter, Specify Lots) don't always respond to clicks

Quicken 2019 on Windows 10. But I've had this problem a long time. When I'm in an Investment Account register and I am editing transactions, the 'buttons' don't always click. For example, If I hold the mouse over 'Specify Lots' (I wish I could embed a picture here), The mouse pointer alternates between the arrow icon and the hand icon. So long as I click when it is the hand icon, it works, but doesn't when it is the arrow icon. Its like the whole rectangle 'button' that contains the text "Specify Lots" doesn't act like a button, only random and changing parts of it do. I have to slowly move the mouse pointer over the button waiting for it to turn into the hand icon. It works this way for all 4 'buttons': "Enter", "Edit", "Specify Lots", "Delete."

Anyone else see this behavior?

Best Answers

  • Mark Stevens
    Mark Stevens Member ✭✭
    Accepted Answer
    One of the above suggestions seems to help. TLDR; Changing register row height from 'comfortable' to 'standard' or 'compact'. Thanks UKR

    An additional data point, since monitor size/resolution seems to be a factor. I am on a 1920x1080 24" monitor. In Windows Display Settings the "Change the size of text, apps, and other items" is set to 100%, with no changes to advanced settings.

    Regarding Jim Harman's suggestion about "Enhanced Pointer Control", my mouse was already set that way.

    The 12 bullets (UKR - how did you do bullets?) from UKR starting with "Close Quicken..." through "Now Start Quicken" didn't apply because they weren't set in the first place or making changes there didn't fix the problem.

    --I didn't try the 4k monitor work-around.
    --I don't "Use large fonts"
    --Changing font size/style only affects bank registers and not investment registers (which is weird in and of itself) so doesn't help.

    But the following does help: Changing the Row Height setting in the register options to either "Standard" or "Compact", rather than "Comfortable." I've settled with "Compact"

    I'd say this is something for Quicken to look into. I don't understand why buttons in an investment register need to behave differently than buttons in a bank register (such as 'save', which darkens when you hover over it and has never caused me a problem).

    As Tom Young alluded to, I don't think this is the only place where I have had trouble clicking an entity in Quicken, but was top of mind as I was editing 50 some-odd transactions and rapidly losing my sanity.

    Thanks.

Answers

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    I've noticed this behavior too, and it seems to have slowly gotten worse over the last few years.  Don't know if it's a "Quicken" issue or a "Windows" issue, but it exists in several spots within an Investment Account.  A previous poster complained that they couldn't mark a transaction as "cleared" and this too came down to having to place the cursor in just the right spot" of the drop-down menu available under the Clr column.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited July 2019
    I don't see this issue. You might experiment with the Windows mouse speed and  "Enhance pointer precision" options in the Windows mouse properties to see if they have any effect.

    The mouse settings are described here
    https://www.howtogeek.com/321763/what-is-enhance-pointer-precision-in-windows/
    QWin Premier subscription
  • Mark Stevens
    Mark Stevens Member ✭✭
    Accepted Answer
    One of the above suggestions seems to help. TLDR; Changing register row height from 'comfortable' to 'standard' or 'compact'. Thanks UKR

    An additional data point, since monitor size/resolution seems to be a factor. I am on a 1920x1080 24" monitor. In Windows Display Settings the "Change the size of text, apps, and other items" is set to 100%, with no changes to advanced settings.

    Regarding Jim Harman's suggestion about "Enhanced Pointer Control", my mouse was already set that way.

    The 12 bullets (UKR - how did you do bullets?) from UKR starting with "Close Quicken..." through "Now Start Quicken" didn't apply because they weren't set in the first place or making changes there didn't fix the problem.

    --I didn't try the 4k monitor work-around.
    --I don't "Use large fonts"
    --Changing font size/style only affects bank registers and not investment registers (which is weird in and of itself) so doesn't help.

    But the following does help: Changing the Row Height setting in the register options to either "Standard" or "Compact", rather than "Comfortable." I've settled with "Compact"

    I'd say this is something for Quicken to look into. I don't understand why buttons in an investment register need to behave differently than buttons in a bank register (such as 'save', which darkens when you hover over it and has never caused me a problem).

    As Tom Young alluded to, I don't think this is the only place where I have had trouble clicking an entity in Quicken, but was top of mind as I was editing 50 some-odd transactions and rapidly losing my sanity.

    Thanks.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Good detective work, @Mark Stevens

    I also see an issue with the register row height setting:

    With the height set to "Comfortable", the clickable area where the cursor changes from an arrow to a finger is lower than and barely overlaps the Edit, Enter, and Delete buttons on a transaction in the list.

    It appears that the button is aligned to the top of the row but the clickable area is aligned to the bottom.

    The clickable area is also shifted downwards when the height is set to "Standard"  but not so much.
    QWin Premier subscription
This discussion has been closed.