Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Help with SELL Lot No shares available Error when lots shows a share

Windows QR21.16 Build 27.1.21.16

I am trying to enter a SELL transaction for 1 share of stock. I enter the pertinent data in the sell dialog box, when I finish inputting the data and select enter/new, I get an ERROR dialog indicating the number of shares selected is more than the available, and that the maximum available is 0.

When I look at the lots, the security has 1 share, which was entered as an "ADD" transaction. In the SELL dialog, I have selected "sell all shares" which then enters 1 in the number of shares box, and have tried entering the number of share manually. Both result in the same error.

I haven't been having trouble with any other sale transactions. Thoughts? Workarounds? Reminder how to report a bug? Etc.

Thanks!
Janet

Comments

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    What you're seeing shouldn't be happening, of course.  So my thought is some sort of data corruption is the cause. 

    Do File > File Operations > Copy... and then File > File Operations > Validate & Repair... on the copied file.  Select both "Validate file" and "Rebuild investing lots" in the validation window.
  • jrm
    jrm Member ✭✭
    Thanks, Tom. Unfortunately, that did not resolve my issue. I did this in multiple steps, just for kicks. Validating found a number of errors... none involving this account or the specific security. (There were damaged transfer transactions, a security with price data in the future, and 25 bought or added transactions that were incorrectly categorized as a realized gain.) As a side note, I found all these errors to be interesting, as I last validated before going to 2019 subscription and I had none of these.

    Second step I did a repair for correcting price history (mostly b/c I selected the wrong box from your suggestion.) == 0 prices repaired

    Lastly, I rebuild my investing lots --no errors logged.

    After each step, I retried the sale transaction with the same results.

    Interestingly, after I tried your suggestion, I decided to try a different tactic, thinking about a work around.

    Q allowed me to entered a REMOVE transaction for this share, and when I subsequently looked at my holdings, as I would expect, the security no longer is listed. I thought I would then enter a CASH ADDED transaction to complete the work around.

    However, before doing that, I deleted the REMOVE transaction and retried a SOLD transaction and received the same error.

    I then, entered the REMOVE transaction. I then line item edited (not using the EDIT dialog) and changed the REMOVE to SOLD and entered a price. Q allowed this. However, if I EDIT using the edit "button" (the dialog box) I can see the information, as soon as I try to save I get the same error, even though if I cancel the edit dialog box, and let it revert to the transaction list, it allows the SOLD transaction that I was able to create from the line item edit. I do see the cash balance changing.

    So, what should I be concerned about? Would you continue with the line item edited transaction? Or, would you use a remove and cash added combination?

    Thanks!
    Janet
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Are there any Placeholder transactions in your account register? If there is one related to the Shares added transaction you did for this security, resolve it first.

    About Placeholders (Quicken Windows)

    "N/A" in certain fields of an investment transaction indicates that you have Placeholder transactions in your account that need to be deleted and replaced with the correct Buy / Sell / etc. transaction that should have been recorded here.
    For more about Placeholders please go into Quicken Help (press the F1 key from anywhere in Quicken) and perform a Contents search for "placeholder".
    Alternatively or in addition to the above, read the first few articles found here: https://www.quicken.com/support/search/placeholder


  • jrm
    jrm Member ✭✭
    Thanks, UKR.

    In the current account, with the security, there are no placeholder transactions at all. The security was transferred from another Q account, and I searched that account and there are no placeholder transactions related to this security, nor any others. Lastly, this security was held in one additional Q account, different lot, but I also checked re placeholders, and there are none in that Q account as well.

    As an aside, I've had other placeholder entries, in retirement accounts, but have not had difficulty liquidating the security.
  • rickexner2
    rickexner2 Member ✭✭
    I was getting the "number of shares selected" message tonight in an account to which I had just rolled over from a different security. Then I accidentally entered today's date, and the transaction went through fine. Apparently Quicken "knew" that the funds weren't available on the (earlier, actual) date of the transfer that I had been entering.
This discussion has been closed.