Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Trouble with entering a "Buy - Shares Bought" transaction in the Investment accounts.

When entering a "Buy - Shares Bought" transaction in the Investment accounts, the "Use Cash for this transaction" box disappears once I enter in the Security Name. This causes the cash balance and securities value to be off. I am trying to do this for the initial securities purchase. This issue does not happen with subsequent securities purchases. I have tried to correct this several ways, but it is impossible to figure out. I have made sure there is sufficient cash reflected in the account prior to the date of the initial securities purchase. I have updated the opening balance on the account, to no avail. Please help!
Tagged:

Best Answer

Answers

  • KetanG
    KetanG Member
    Thank you! I am assuming this would have worked and this is where the problem was. I went a different route. I was able to create a transaction for the initial securities purchase with cash balance in the account, dating it as of the present date. Then, after recording/posting the transaction, I changed the date on the transaction back to the original date of the initial securities purchase.

    Afterwards, I followed the directions Jim provided, find the placeholder entry, and delete it.

    Again, thank you very much!
  • Radler
    Radler Member
    > @Jim_Harman said:
    > I would guess that there is a hidden Placeholder transaction in the account for the security in question, dated after the date you are trying to enter. This blocks earlier transactions for the security from affecting your cash balance.

    That second line is key. I was going back and trying to manually re-enter transactions, but the re-entered transactions would not affect the cash balance either. Thanks to Jim's suggestion to "show hidden transactions" I was finally able to locate the source of the problem and fix it, saving my sanity after hours of frustration. Thanks, Jim.
This discussion has been closed.