Is there a way to force removal of shares?

Here is my situation: I have 4636 number of shares of a stock in a brokerage account. I need to remove them, or move them to a new brokerage account, but when I attempt either, it says I do not have enough shares...yet when I look at my holdings in Quicken, it says I have exactly that number of shares!

At some point in time, years ago, I had a few shares in a brokerage account, and many shares, from quite a few different lots in an ESPP account. At some point, years ago when I left that job, those shares moved from my ESPP account into the brokerage account. I thought everything was fine until now.

If I go to that stock in my securities list, it shows me all of the buys and sells correctly -- everything is right for the old ESPP account and everything shows up as being moved to the brokerage account. So from the STOCK view, everything is great and when I add up everything, it comes to exactly the number of shares I own (4636), and it shows them all being in the brokerage account.

Within the brokerage account, when I go into the holdings list, it paints a different story. There, it shows the total number of shares correctly (4636), and the value of those shares is reflected in my net worth, HOWEVER it only shows lots for two purchases (44+194). As a result, when I try to move all 4636 shares (or try to remove them), it says I don't have that many.

How the heck can I fix this?

And of course, I can't just delete the old brokerage account because it won't let me do that while it contains securities.

At this point and level of frustration, I don't care if I move them to my new brokerage account or remove them from the old one and just add them as one lot to my new account. (I'll forego using quicken to track basis for this stock if I have to -- the brokerage firm has all that info anyway.) I just want them gone from the old brokerage account so I can mark it as closed!

Best Answer

  • ftdatl
    ftdatl Member
    Accepted Answer
    Thanks, Splasher. Before I saw your reply, I clicked on the option to use average cost. That gave me a link to click for more info, which I read, and then when I cancelled (wanting to wait until I got a reply here), it actually went ahead and did it using the average cost! Since I don't rely on Quicken for taxes, I guess it doesn't hurt anything. Anyhow, problem solved.

    At this point there's no way to know if your suggestion would have worked, but if I run into this again, I'll try that.

Answers

  • splasher
    splasher SuperUser ✭✭✭✭
    Use the "Sell All" checkbox



    It is check-able once you enter a Security.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • ftdatl
    ftdatl Member
    Accepted Answer
    Thanks, Splasher. Before I saw your reply, I clicked on the option to use average cost. That gave me a link to click for more info, which I read, and then when I cancelled (wanting to wait until I got a reply here), it actually went ahead and did it using the average cost! Since I don't rely on Quicken for taxes, I guess it doesn't hurt anything. Anyhow, problem solved.

    At this point there's no way to know if your suggestion would have worked, but if I run into this again, I'll try that.
  • splasher
    splasher SuperUser ✭✭✭✭
    ftdatl said:

    At this point there's no way to know if your suggestion would have worked, but if I run into this again, I'll try that.
    Sure there is, you can delete the transaction that you created and do it again.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.