Mutual fund share conversion not working

Tech support couldn't help me without suggesting that I restore from a back-up and re-enter all of my transactions since then (it's just been a week, but I'm still not going to do that). So let's see if the community can help me.

About 18 months ago, I had a mutual fund conversion. I followed the steps here: https://www.quicken.com/support/how-do-i-enter-share-class-conversion-mutual-fund. This resulted in 1 auto-generated Removed transaction and 12 auto-generated Added transactions. The first Added transaction has no share price associated with it, so it is leading to incalculable/infinite returns in reports. Also, I traded in 114.94 shares of the original class and received 114.93 shares of the new class, which may also be causing trouble.

The recommended procedure from tech support was:
• Create a back-up
• Re-store from an older back-up
• Delete the transaction
• Re-enter the transaction

Like I said, I would also have to re-enter all transactions since my back-up, which I am not going to do.

Any other solutions out there?

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    You may correct the erroneous Added transactions manually or you remove transactions introduced by the Mutual Fund Conversion wizard and use the Corporate Acquisition wizard instead.  Note: The Corporate Acquisition applies across accounts so, if you have holdings of the mutual fund in other accounts that should not be converted, you will want to remove the Remove and Added transactions introduced in these other accounts.

  • Roger M
    Roger M Member ✭✭✭✭
    Is "Use Average Cost" selected for the cost basis method in the security details window for the security in question? (Click on the security name, then click Edit Security Details). If so, then uncheck it, provided that you agree to use lot identification as your cost basis method. Then remove all of the transactions from the account that were generated by the Mutual Fund Conversion process. Then rerun the Mutual Fund Share Conversion tool. You can remove the transactions easily by generating a Banking Transaction report, customized for that account, and with custom dates corresponding to the date of the transactions. Then click on each transaction, then right click, and select Delete to remove it.

    Apparently, the Mutual Fund Conversion process does not work properly when Average Cost is selected for the cost basis method. This procedure worked for me. My holdings were already set up as using lot identification, FIFO, as the cost basis method at my brokerage. So, the Use Average Cost Basis box never should have been checked.
    Quicken Windows Premier - Subscription **** Windows 10 Home *** Quicken user since 1996
  • pswillia1
    pswillia1 Member
    I tried Sherlock's method and it generated even goofier results. So ended up tackling the math and manually adjusting the $0 share price. All is well now.

    Roger M, no I didn't have Average Cost selected, so that must not have been the cause of this problem.
This discussion has been closed.