Formerly sold securities continue appearing in my investment accounts

Gary
Gary Member ✭✭✭
Continuing the closed discussion from https://community.quicken.com/discussion/7755964/formerly-sold-securities-keep-appearing-in-my-investment-accounts.
This discussion describes the issue with Quicken where a sold, closed out security appears in the Investing view with zero values.

I want to add to that closed discussion, that for me, removing the problem security from appearing on the watchlist ALSO removes it from the Investing Asset Allocation - Asset Class view.

I used the Tools->Security List, scrolled to the security I dis not want to appear in the Investing - Asset Allocation - Asset Class view, and I removed the check mark in the Watchlist column.
Tagged:

Comments

  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    By "appears in the investing view" do you mean the Portfolio CTRL-U?
    If so, in that view, check OPTIONS (in the upper right corner) and UNcheck "Show Closed Lots".
    If not, explain exactly where you're seeing this.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Also in the Investing > Portfolio views, securities that are on your Watch list are included in the views whether or not you have ever held them. This would explain why securities you have sold continue to be displayed in these views.

    The indexes and Watch List are treated like special accounts in these views.

    As you have found, removing securites from the Watch List will remove them from these views.

    You can also customize these views to select which securities and accounts you want to include in each view, so if you want to keep certain securities on your watch list but exclude all the Watch list securites from a view, you can customize the view to exclude the Watch list "account".
    QWin Premier subscription
This discussion has been closed.