Error Message "Please check internet connection and try again."

When I try to run Quicken for Windows Version 23.17, Build 27.1.23.17 (i.e. the 2020 version), I get an error message "Please check internet connection and try again." When Quicken opens, it briefly shows my account, the the entire screen is greyed out and filled with the error message. I can do nothing. I tried downloading and reinstalling Quicken from my account. The reinstall ran fine, but upon opening Quick, I got the same problem. At the moment, I can't run Quicken at all.

I'm running Quicken for Windows on an iMac, using the latest version of Parallels Desktop 15 for Mac Pro Edition (version 15.1.2) and running Windows 10 Home edition.

My internet connection is running fine (not sure why Quicken doesn't think so).

Thanks for any help you can offer. This is very frustrating.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    In Windows, open Internet Options, select the Advanced tab, uncheck all the use SSL options, check all of the use TLS options, and select OK.
  • Great idea ... one I had not thought about. Unfortunately it didn't work. I unchecked SSL 3.0 (the only SSL available) and checked TSL 1.0, 1.1, 1.2, and 1.3 (experimental) (most were already checked. It didn't solve the problem. I even then unchecked 1.3 (experimental) and tried again. Throughout, I rebooted both the iMac and windows a couple times, just in case, but it didn't matter. Bottomline, the problem is still there. I can't get into Quicken at all.

    I guess the good news is I have an PC laptop with Quicken on it that I'm going to try to use in the interim (move over my datafiles, etc.) so my financial world doesn't come to a halt. But the laptop is nowhere near as capable/convenient as my iMac.

    Thanks for the suggestion. I really appreciate it.
  • I think I know the problem, but I haven't yet figured out how to fix it. Quicken for Windows on my iMac (running parallels) for some reason, loads to Quicken Home, Business & Rental Property, when my subscription is for Quicken Premier.

    I removed Quicken completely from the iMac (windows version), uploaded from Quicken.com and ran again and sure enough, even though my subscription is for Quicken Premier, Quicken Home, Business & Rental Property loads and runs. And unfortunately, keeps giving me the "Please check internet connection and try again" error message. I'm not sure if this is the issue, but I haven't figured out yet how to get the right version of Quicken to run on my computer.
  • thecreator
    thecreator SuperUser ✭✭✭✭✭
    Hi @""[email protected]" ,

    Forget Quicken as being the problem, for the time being. Since you have Windows 10 Home installed in Parallels, install Skype for Windows in Windows in Parallels and see if you have a Connection to the Internet using Skype for Windows. The latest is 8.55.0.141 but install an older version then upgrade to the latest and see if it upgrades. If not, you have an Internet Connection problem between iMac,. Parallels and Windows 10 Home. Make sure that Windows Update is working in Parallels, that winver shows the latest Public Build of 18363.535.

    If Windows Update doesn't work, Quicken is going to work, either.
    thecreator - User of Quicken Subscription R36.23  USA & Quicken 2017 HBRP R20.6 USA
                       Windows 10 Pro 32-Bit Build 19043.1288
                       Windows 11 Pro 64-Bit Build 22000.194
    also            Windows 10 Pro 64-Bit Build 19043.1288

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • thecreator … Appreciate the response … I acknowledge it could be more than a Quicken problem, but I'm confident it's not because I don't have a good internet connection. I've had no problem connecting to the internet in any programs other than Quicken on both the Mac side and when running Windows in Parallels. Specifically in Windows, while I was trying to trouble shoot last night (and use this system) I was using edge, outlook, etc. with now problem.

    I will check the Windows build when I get home this evening. It did run an update recently, but I didn't note the build number.
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    @[email protected] 

    Is the network connection for Windows set as pass through?
    Quicken Subscription HBRP - Windows 10
  • If I understand correctly, no it's not a pass through ... but I'm not 100 percent sure ... not sure how to check that. I assume not, as it's been working just fine for a long time. Now it's not :-(

    For thecreator ... I did check the Windows OS build and it is 18363.535, version 1909, installed 11/17/19.
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    It should be in the settings for your Virtual Machine. If it's not pass through, you're going to have double NAT (Network Address Translation).
    Quicken Subscription HBRP - Windows 10
  • Greg the Geek ... Unfortunately you are beyond my understanding. I'm not sure how to check that ... though I'm skeptical it's the issue as it's been working for a long time, and now is not ... but who knows.

    For what it's worth ... I called Quicken support ... basically they gave me a long list of other people to call because it couldn't be their problem ... kind of a bummer!
  • ggkrupp
    ggkrupp Member ✭✭
    > @Sherlock said:
    > In Windows, open Internet Options, select the Advanced tab, uncheck all the use SSL options, check all of the use TLS options, and select OK.

    I had a similar problem getting Quicken 2020 to connect through my Windows 8 VM an your solution fixed it. Thank you!
This discussion has been closed.