Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

I cannot get the NASDAQ composite to display under the "market indexes" portion of the portfolio

I tried to use the chat feature of Quicken help to resolve it but all they suggested is starting over. My Q file is 51,179 kb and that ain't a reasonable solution.

Best Answer

Answers

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Do you have the security typed as Market Index?

    Do you have the Portfolio View customized to include the "Account" "Indexes"?
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Check that all of the following are set up properly:
    -- In your Security list, the index has the correct symbol COMPX, has a Type of Market Index, and has Download Quotes checked.
    -- When you click on Customize in the Portfolio view, Indexes is checked on the Accounts tab and Nasdaq Composite is checked on the Securites tab.




    QWin Premier subscription
  • JohnC
    JohnC Member ✭✭
    Ok, I'll struggle to explain what I'm seeing. I've checked everything Jim has suggested and found nothing out of line.

    In the security list there are 11 indexes that appear to be preloaded by Quicken and are not editable. When I check mark any of them they are then listed in the security list and added to the "indexes" at the bottom of the portfolio page. Except for the NASDAQ composite will not show on the portfolio page.

    Conversely if you uncheck the indexes they no longer appear in the security list. I've tried adding the NASDAQ composite manually in the security list but it didn't help. I'm going to try to call Quicken but past experience doesn't bode well for that method.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    JohnC said:
    In the security list there are 11 indexes that appear to be preloaded by Quicken and are not editable. When I check mark any of them they are then listed in the security list and added to the "indexes" at the bottom of the portfolio page. Except for the NASDAQ composite will not show on the portfolio page.

    Conversely if you uncheck the indexes they no longer appear in the security list. I've tried adding the NASDAQ composite manually in the security list but it didn't help. I'm going to try to call Quicken but past experience doesn't bode well for that method.
    My QW2017 -- Security list (Ctrl-Y) offers a "Choose Market Indexes" button at the bottom of the screen.  That option brings up 11 possible "Quicken-provided" indices.from Dow Jones Industrials (DJI) to S&P 100 Index (OEX).  I happen to have 4 of those checked to be included (DJI, COMPX, IUX, and INX).  Those four appear in the Security List with the Type set as Market Index.  

    I don't have any trouble editing any of those four from the security list.  I can change name, ticker, type, class, etc. without objection from Quicken.

    I have also added my an index not in their list - S&P 500 TR INDEX incl Div (INDEX:SPXT) to which I assigned the Market Index security type. 

    If I pull up a portfolio view (Ctrl-U), include the 'account' Indexes, include all securities and group the view by Security Type, all five of these indices appear in the Market Index grouping.

    All that says is that a Market Index should behave substantially the same as any other security in the list (except it can't be bought and sold).

    For your issue, I'd be looking to create on a temporary basis another test file and seeing if that test file shows the same aberrant behavior.  If the test file behaves correctly, then file validation or restoring a backup of your main file might be in order.  
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    same here - things all work -

    Quicken 2020 Deluxe - Subscription - Windows 10
  • JohnC
    JohnC Member ✭✭
    thanks Q_lurker for the suggestions, I added (index:spxt) and it did display on the portfolio page under indexes. Since it is not in the original Quicken index list it can't be turned off, as expected.

    The details can be edited in the security list but it does not change the listing in the market indexes drop down. if you uncheck the indexes it removes them index from the security list so you lose any edits if you decide to recheck it.

    The biggest clue to my problem is that I can't uncheck the NASDAQ index listing in the Quicken list of 11 available. When I uncheck it and open up the list again it shows it still checked.

    I created a new Quicken file and all indexes were properly displayed, so my file has a problem. There is no way I can re-enter 20 years of information.

    I don't know which upgrade messed it up but I don't have a backup that old. It's not a crippling fault but would be nice to know the problem. I've run the validate and repair routine several times.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Is there a chance that somewhere along the line, somehow, you recorded a purchase of the COMPX security?  That could (partially) explain an inability to delete the security -- even if it was in a hidden or closed account. 

    In a quick test, I could change the Type, Buy and Sell shares, change the type back to Market Index.  At that point, I could not delete the index directly from the Security List (Delete button greyed out), but I could uncheck and recheck the box via the "Choose Market Index" button and popup.  So there is some parallel to your situation, but not completely.  Since there were buys and sells, those transactions did appear in the Transaction History portion of the Security Detail View.

    Another possibility:  Might you have two securities in the list with the COMPX ticker?  To sort the list by Ticker, click the Symbol header.  When I create that situation, I get behavior similar to yours -- Unchecking the box on the "Choose Market Index" button and popup does not stick. 

    If you find two COMPX securities, you might be able to edit the ticker for one of them -- COMPX(bad) or similar -- and alleviate the problem.     
  • JohnC
    JohnC Member ✭✭
    there was no duplication of ticker. I unchecked all indexes and it removes the listing in the security list and from the portfolio view. I then checked the indexes and they are added back to both locations but the NASDAQ isn't shown in the portfolio view.
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited February 2020
    hmmm.... interesting ...

    Quicken 2020 Deluxe - Subscription - Windows 10
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    As a separate cross-check, under the Investing options, should be a set of Performance options (if you are running Quicken Premier or higher).  Those presentations for Growth of $10,000 and Average Annual Return also make use of the Market Indices.  If available to you, do those include the NASDAQ (COMPX) index?

    Trying to focus in on whether the portfolio view is the ONLY place you are missing this NASDAQ information.  


  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I am reminded also that for a portfolio view, I would expect to see the Market Index securities grouped together if the view was grouped by "Account" or by "Security Type".  Obviously, you are not seeing NASDAQ (COMPX) reported under your current setting.  Not sure why you would thus see it under a different grouping, but you might check, just to see if that sheds any light on anything.  You might also try customizing some other view (Show: ___) to include that security and account just to see if that becomes enlightening.  
  • JohnC
    JohnC Member ✭✭
    q_lurker think you helping it get narrowed.. It does appear that the portfolio listing is the only place it's missing.
  • JohnC
    JohnC Member ✭✭
    Thanks q_lurker, The problem is resolved. I had not looked at the customization of the display at the individual security level (not sure why i'd want to shut off an issue that doesn't show unless you own it). Just goes to show that even after 20 years of use I only know 20% of it's capabilities
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    @JohnC Just keep in mind that each view (Show) in the portfolio view is individually customized.  So selecting or unselecting a security in one view does not carry over to any other view.  I do a lot more toggling of accounts as selected or unselected and typically have the security selection as Select All including the show hidden securities.  YMMV.

    Glad we found the source of the issue without taking the "start over" option.  It is rare in my estimation that "start over" is the best or only choice.    
This discussion has been closed.