Home Quicken for Windows New to Quicken/Getting Started (Windows)

Why does Quicken rounds 3 place to 2 place when printing register?

Quicken Windows Subscription R24.14 rounds 3 place share balance to 2 place when printing register. This occurs when printing to printer, text file and pdf file.
Tagged:

Best Answer

Answers

  • JustMeHereJustMeHere Member ✭✭✭✭
    edited February 19
    Maybe because that is what you have in your settings?
    To change it:
    Edit -> Preferences -> Reports only -> Decimal places for prices and shares: X


    [Edit I just tried changing this setting {mine was set to 4} and it didn't make a difference.  But my number decimal places of shares exceed 2 places (3 and 4 mostly), and my shares are 6 decimal places.  This is while printing an investment register]
    Using Quicken Subscription Premier (and have a copy of Starter to test things on)
  • FishermanFisherman Member
    I checked preferences and my reports only setting was already 3 decimal places.
    I am trying to print a register.
  • UKRUKR SuperUser ✭✭✭✭✭
    Please try this:
    Open the report view that you are having problems with (I've just been working with an Investment Transactions report).
    Look at the columns for number of shares and quote/price per share. Make sure they are wide enough to show all numbers. If they show a number like 33.00... with the 3 dots at the end, widen the column.
    Click the "Aa" icon in the upper right of the report view to go into Report settings.
    Change the decimal places setting to "6" and click OK.
    The report should immediately refresh and now show all numbers with 6 decimal places.
    Does it?
    If yes, change the setting back to 3, 4 or 5, depending on how many decimal places you really need (my brokerage reports fractional shares with up to 5 decimal places, so that's my setting)
    If no,  is this a saved report created in an earlier version if Quicken? You may have to recreate it from scratch, recustomize it and then save it, replacing the old saved report.
  • FishermanFisherman Member
    I am trying to print a register, not a report. I am having trouble with share
    balance, not shares. My problem appears on file sent to printer, Microsoft
    print to pdf file, and print to txt file.

    My steps are: FILE -> Print " displayed account name"
    i.e. FILE ->Print Vanguard

    This is the last line in the File dropdown menu.
  • UKRUKR SuperUser ✭✭✭✭✭
    I don't seem to be able to recreate this using my Q 2020 R 25.10
    Columns Price and Shares (i.e., price per share and number of shares) show up to 6 decimal places, as needed and exactly as recorded in the transaction register.

    Can you please capture one or more images of the parts of your Quicken window showing the issue, sensitive information blacked out as necessary to protect your privacy but annotated to describe the situation, and attach the image(s) here?
    https://community.quicken.com/discussion/7867159/faq-how-do-i-post-a-screenshot-in-the-community-from-windows#latest


  • FishermanFisherman Member
    Hello UKR,
    I noticed your version and updated my R24.14 to R25.10. Unfortunately,
    this did not fix my problem.
  • UKRUKR SuperUser ✭✭✭✭✭
    Thank you for the images.
    Is this investment account register an IRA account configured as a Single Mutual Fund account (in Edit Account Details, the "Yes" radio button next to "Single Mutual Fund account" is selected)?
    If so, I would consider this a bug in the report writer. Share Balance, when printed, should show up to 6 decimal places.
    I'm not sure if that has been reported before ... if so, I can't find the discussion in the Community.
    Please use Help / Report a Problem in Quicken to send the images and a problem description, including a link to this webpage, to Quicken.
  • Quicken_NatalieQuicken_Natalie Moderator mod
    Hello All,

    Thank you for your patience while this was being investigated.

    I've received confirmation that the fix for this will be complicated to implement, and have been provided with some work-around solutions for the meantime.

    One would be to create a register report to print instead of printing from the register directly. 

    The other would be to change the operating system settings at Control Panel -> Region -> Formats -> Additional Settings -> Currency tab> No. of digits after decimal:



    This should allow the transactions to print without rounding to 2 decimal places.

    Please let us know if anyone has any questions or concerns regarding this.

    Thank you,

    Quicken Natalie

     
This discussion has been closed.