Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

How to get rid of comma for amount over 1000$ when exporting to Excel

Hi. I live in Canada. When I export a report to Excel, the amounts below 1000$ are correctly transfered (for example 899,95$), but if the amount is 1899,95$ it is transfered as 1,899.95$ (there should not be a comma after the 1 and the decimal point should be replaced by a comma).

Is there a solution to that problem? For the moment, I do a "Find & Replace" in Excel to change the comma to "nothing" for amounts over 1000$ and then I do another "Find & replace" to change the decimal point to a comma.
Tagged:

Best Answer

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    I suspect there is a conflict between your settings for the numeric separators between Quicken, Windows and Excel.

    In Excel 2010 you can over-ride the default separators by going to File > Options > Advanced > Editing Options > and un-checking Use system separators. I suspect the option is hidden somewhere else in newer versions of Excel.
    QWin Premier subscription
  • Eric DT
    Eric DT Member
    edited April 2020
    My settings in Windows and Excel are identical (and exactly what I want). In Quicken, the numbers over 1000 are shown as 1,000. Should I change something in Quicken?

    (edited to remove image for privacy)
  • Eric DT
    Eric DT Member
    Sorry image got stuck in there by mistake
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I'm a little puzzled why you are using the Comma as Decimal Point, as it's usual in Europe.
    The US default is "." period as decimal point and Comma as thousands separator. Changing my Region settings in Control Panel from "English(US)" to "English(Canada)" defaults to the same values, period as decimal point.
    What kind of settings are you using in Region in Control Panel?
  • Eric DT
    Eric DT Member
    I live in Canada, using the metric system in which the comma is used as the decimal point. In my control panel, I use "Francais(Canada)". That might be the problem...
  • Eric DT
    Eric DT Member
    It worked! Thank you!
This discussion has been closed.