Date Format in Check Register

Hello all, I just updated my Quicken Deluxe since Quicken will no longer allow use of my 2017 version. All was well until I wanted to enter items in the Check Register. It has the weirdest date format I have ever seen. How do I get it back to a "normal" date format like 01/01/2020? Thanks in advance!

Answers

  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    Check your Windows date settings.  That's where Q gets its date format info.
    BTW, how IS it showing today's date?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • bobspunkin
    bobspunkin Member
    Thanks. My date format in Windows is 4/21/2020. My date format in Quicken is 21042020. It took my brain a minute or two to figure that out. :) The Windows format is much easier for me to use but I don't see anywhere in Quicken to change it to the Windows format. Thanks again.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    So you're seeing DDMMYYYY.  Curious.
    What country are you in?  Because in my US Windows, I don't even see that as an option.
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • bobspunkin
    bobspunkin Member
    I am in the US! I would prefer "regular" date format but there is no way to change it.
  • volvogirl
    volvogirl SuperUser ✭✭✭✭
    You have to change it in the Windows OS not in Quicken.  You need to check the Windows setting for the short date.
  • bobspunkin
    bobspunkin Member
    Hi, my Windows date format is 4/22/2020. So how would changing the date format in Windows help me in Quicken? Thanks for your answer though.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Hi, my Windows date format is 4/22/2020. So how would changing the date format in Windows help me in Quicken? Thanks for your answer though.

    Quicken uses Date, Numeric and Currency formats depending on what is selected in Control Panel / Region.
    Here are my settings, from Windows 8.1, for reference:
    Quicken uses the "Short date" setting for Dates.
    If you make changes in Control Panel, stop and restart Quicken for the change to take effect.
  • bobspunkin
    bobspunkin Member
    Thank you for your response. I checked the date format in the location you described. It is correct for mo/da/year. This makes 3 times I have checked it just to make sure it is right. LOL
  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you haven't rebooted Windows since you installed the latest software update, please do so now and then try Quicken again.

    Still not working?

    Let's try some "Troubleshooting 101" to ensure the Quicken software is installed and updated properly and that your data file is in good working order.
    Please perform all the steps in this document in the order specified:
    Troubleshooting 101 - Fixing Software Installation and Data File Problems


  • bobspunkin
    bobspunkin Member
    Hi, I went through the steps as outlined in the FAQ and the date format is still what was previously displayed. I have figured it out and I will live with it for now. Maybe a future update will correct it? I had no errors in my Quicken data file which is good. That was worth the time it took to do all this. :) Again, thank you very much for your help.