Home Quicken for Windows Installing and Updating (Windows)

Why does a maximized Quicken window extend across multiple displays?

I have recently upgraded to the Quicken Subscription. Previously, I was using Quicken 2017, and was frustrated that the Quicken window did not seem work with the the display resolution. After the upgrade to the Quicken Subscription last week, I was happy to see the problem did not appear to be in the new release.

HOWEVER, today, Quicken updated as soon as I started to release R26.15, build 27.1.26.15, and a form of the problem as returned. When I move Quicken from my laptop monitor to my secondary monitor, and then maximize the Quicken window, it fills the secondary monitor and part of the laptop display.

How do I fix this????

Best Answer

Answers

  • Quicken FranciscoQuicken Francisco Moderator mod

    Hello @shavde

     

    Thank you for reaching out on the community and telling us about your issue. I just have a couple of questions. Are you using a high resolution monitor on your second screen? Is your laptop screen at a lower resolution?

     

    I would recommend looking at this article here to see if we're able to get it to just stay on one screen.

     

    Let us know how it goes! 

     

    Thanks,

     

    Quicken Francisco


  • shavdeshavde Member
    Both of my monitors are 1920 x 1080.

    I have the "Scale and layout" in Windows "Display Settings" set to 125%, as I need the larger scale for my eyesight.

    I noticed that if I set the scaling to 100%, Quicken will not extend beyond the one monitor when maximized. It appears that the Quicken app is not considering scaling when it is maximized.

    Keeping my scaling at 100% is not really an option. I am expecting that Quicken will be updated to match the behavior of other Windows programs.

    Dennis Shaver
  • Quicken FranciscoQuicken Francisco Moderator mod
    edited April 29
    @shavde

    Thank you for the information. I've been able to replicate the same issue and am taking a look to see what I can find in order to resolve it. I'll report back to you as soon as I can. 

    In the mean time we have a community post here as well that one one of the superusers UKR has a list of things that potentially could work as well.  I am on a different resolution on my monitors so the fixes didn't work for me but I would definitely give them a shot to see if we're able to make some progress

    https://community.quicken.com/discussion/comment/20023169#Comment_20023169

    Let me know how it goes! I will report back as soon as I can as well

    Thanks,

    -Quicken Francisco
  • shavdeshavde Member
    Thank you. This seems to have resolved the issue. Specifically, here is what I found and did:

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.

    Users of older Quicken versions please try the following:

    Close Quicken !!! (This process won't work while Quicken is running!)
    Check the Compatibility tab settings in your Quicken Desktop program icon:
    In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
    or
    Go to the traditional Windows Desktop and right-click the Quicken program icon.
    Now click Properties.
    Select the Compatibility tab.
    Uncheck all settings.
    Windows 7, 8.1: Check "Disable display scaling on high DPI settings".
    Windows 10: Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application" (also try the other available options!)
    Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    Click the "Change settings for all users" button.
    Click Apply and exit.
    Now start Quicken and see if that makes a difference.

    Dennis Shaver
  • Quicken FranciscoQuicken Francisco Moderator mod
    @shavde

    Great to hear that you were able to get it to size properly. If something does change us know so we can look into a bit more. Have a great day as well!

    -Quicken Francisco
  • Joel SteinbrunnerJoel Steinbrunner Member ✭✭
    Team,
    I'm still having this same issue after making the changes described above (Override high DPI scaling behavior; Scaling performed by: Application; No other compatibility options are checked).

    The exact behavior: whenever I maximize the window, It spans accross my external monitor and onto my laptop screen. I have to manually adjust the window size to match the display. If I maximize the Quicken Window when displayed on my laptop screen, however, it performs as expected and doesn't span. May sound trivial, but I prefer it to be displayed on my larger external monitor.

    I'm using a laptop (1366x768) with an external monitor (1920x1080). Windows 10. Quicken version: 2020 (R26.33, build 27.1.26.23).

    Any help would be greatly appreciated!

    -Joel
Sign In or Register to comment.