Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Quicken Window moves when I click on it to get focus

This has been bothering me since I upgraded to subscription based Quicken a few months ago. I did not have this problem with Quicken 2017 or earlier versions. When I click on the background Quicken window to bring it back to the front, it just moves most of it out of my viewable area. This does not happen all the time but frequent enough to be very annoying. Am I the only one seeing this issue? Any suggestions to fix this? I am using the Windows version, Year 2020, R26.23 Build 27.1.26.23. Thanks.

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you haven't rebooted Windows since the installation of the latest Quicken update, please do that first and try Quicken again.

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
      or
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10:  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options repeating the entire procedure!)
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Try this workaround for 4k monitors
      https://www.quicken.com/support/work-around-display-issues-high-resolution-monitors
    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level.

  • tdub
    tdub Member ✭✭
    I intermittently see this, too. I've gotten to where I use Alt-Tab with Quicken to avoid this random issue. NOTE that I don't have high-res monitors, and both are set to 100% scaling (i.e. I don't use scaling).
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    This doesn't surprise me in the least given the screw "fake main window" they are using.  It creates all kinds of strange problems like this.  Like not always setting the proper size and position on multiple display setups.  When it starts up the window frame is slight the wrong size and then resizes when Quicken gets fully up.  Displaying a black window when it gets busy...  Also so that they can put the global search in a place where it shouldn't be.

    I actually don't see the jumping around because I always run Quicken on a second monitor in maximized mode, but I'm sure this is all caused by the above.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.