Renaming Rules Disappear

I have a persistent issue with my renaming rules. About once a year they disappear from my file. Sounds odd but they also disappear from any backup that have been created (backups where I know the renaming rules still existed at the time of backup). It's getting a little old, the rules disappear, I rebuild them again over a few months, then they disappear again a few months later. At the suggestion of Quicken Tech Support I rebuilt my file from scratch several years ago. I've checked the most recent file for errors. Nothing keeps this from happening.

Does anyone have any ideas? Does anyone know where the renaming rules are kept? Since they also disappear from my backup files they must be in a different file than the data.

Comments

  • splasher
    splasher SuperUser ✭✭✭✭
    No solution or suggestions, just some clarification.
    The Renaming Rules are Quicken data file specific and are retained in each data file.  The QDF data file itself is a variation of a zipped file with multiple files in it.  It can be taken apart using zip software, but you can NOT put it back together using zip software.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi @ren46566,

    My understanding is that the renaming rules are located in the QDF (Quicken Data File).  I know that seems to fly in the face of your restoring a backup and finding that they are also missing from the backup file, but it makes more sense that they'd be in the QDF.

    I do have a question that might help figure this out - where are you keeping your QDF file?  Also can you tell us which versions (and builds) of both Quicken & windows that you are on?

    I am sorry that I don't have any ideas or solution to your problem but since you've not talked to Quicken Support, I would encourage you to connect with them now and see if they can get to the bottom of this for you.  Here's the link.

    Frankx

                      Quicken H&B-Subscription Ver. 34.24 - Windows 10-Home Version
                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • splasher
    splasher SuperUser ✭✭✭✭
    Another important thing to tell us is, Are you using QMobile or Q-Web with your data file?
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • ren46566
    ren46566 Member ✭✭
    Thank you both Splasher and Frankx for your comments. I'm using R27.28 Build 27.1.27.28. My files are kept on my Windows desktop and backed up to Dropbox. I am not using Qmobile or Q-Web although it does appear that my file is enabled for Q Mobile & Web and is uploading the information.

    I have spoken with support regarding this issue. They have no idea what is going on and their only suggestion is that my file must be corrupt and that I rebuild it. I did rebuild it (very painfully) about 2 years ago, but the issue still occurs.

    Any additional thoughts are appreciated.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I recommend you turn off Sync since you're not using the web or mobile apps. Go to Edit / Preferences / Mobile & Web to do so.
    This eliminates one possible source of data corruption. And you can't use a Sync file to restore a lost data file from.
    Do make sure that you are sending the backup files created as you close Quicken to Dropbox. Do not allow Dropbox (or any other cloud backup program) to directly access the active Quicken data file!
This discussion has been closed.