For one of my securities, the "Cost Basis" for the security does not match the lot basis.

I have one security where there have been many transactions. However, after much cleanup and assigning sales to specific lots, there is only one lot with any shares. The cost basis for this lot is correct, but the total cost basis for this security is not the same as shown for this single, and the only lot with any shares.

Answers

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited September 2020
    Well, you shouldn't be seeing that, but I'll admit that I have seen a similar instance where the multiple lots of a particular security didn't add up to the total shown for the security.  I attributed that - rightly or wrongly - to having posted more than one return of capital transaction against the security.  That used to be a common complaint in the Quicken forums, though I don't remember seeing one of these for a few years.
    If this is a security that you've had for a long time and if you did have multiple return of capital entries for that security that might explain the problem,
    You could try opening the Account where that security lives and do a {Ctrl}-Z to force Quicken to recalculate the Account's security holdings.  If that doesn't work might try making a "just in case" backup of the file, doing a "Remove" action for all the shares and then an "Added" action to put the shares back in, at the correct basis and holding period.
  • Thanks for this suggestion. I did delete the one transactions where I purchased the shares for the one lot that I do still own, to take the number of shares down to zero. But even with zero shares, I am showing a cost basis.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    My three suggestions:
    1. Make sure there are no placeholders in the records for that security. They may be hidden. 
    2. The Ctrl-z from the account transaction list that Tom mentioned. That should recalculate the account data.
    3. Have Quicken copy the file (deleted deleted transactions) and then validate the copy including rebuilding investment lots. 
  • Thanks for the suggestions. There are no placeholders, and at Tom's suggestion, I tried the Ctrl-Z recalculation. I am not sure how to accomplish your suggestion #3.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    File / File Operations / Copy

    then

    File / File Operations / Validate and Repair.  First two check boxes.  Select the newly created copy as the file to Validate (Browse if necessary).  
  • Those are all good suggestions. And I learned something new about Quicken as I did the file copy and file repair operations. Thanks for that. However, it did not resolve the issue.

    I would absolutely like to know the root cause here. At the same time, I am wondering if there is a way that I can place some type of transaction into Quicken to just force it to zero?
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited September 2020
    ......
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    PRamstad said:
    Those are all good suggestions. And I learned something new about Quicken as I did the file copy and file repair operations. Thanks for that. However, it did not resolve the issue.

    I would absolutely like to know the root cause here. At the same time, I am wondering if there is a way that I can place some type of transaction into Quicken to just force it to zero?
    This sounds like a security you have done some trading in (buys and sells over time).  To get to the root cause, I would walk the portfolio view through time changing the As of date.  At some stage, does it go from having the right cost basis to not?  What transactions occurred then?  Delete and re-enter those transactions.  It might be helpful to customize the portfolio to only that security and to also choose to show closed lots (an Options selection).  You might also be able to make use of the Portfolio Value Cost Basis report to narrow down time frames.      
Sign In or Register to comment.