New Defect: Pop Up (Tooltip) Obscures Transaction Save Button

Dave Ings
Dave Ings Member ✭✭✭
I just installed the latest Quicken Windows Canada release, build 27.1.28.15, released earlier this week.

Now when I go to save a transaction, a pop up / tooltip obscures most of the save button icon. Needless to say, this is quite annoying! I have attached a screen shot to illustrate. (I've not found any way to turn off tooltips in Quicken.)

Note that there appears to be a semi-transparent rectangle under the tooltip, and it is mostly the rectangle that interferes.

Please fix this in the next release! :smile:

Best Answer

Answers

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭
    @Dave Ings - I see the same thing in the US version.  It pops up just 1-2 seconds after hovering the cursor over the save icon.  For me it does not actually interfere with clicking on and saving the transaction.  I just click on it as if it weren't there and the transaction saves.  Is it causing interference for you?
    (QW Premier Subscription: R33.24 on Windows 10)
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @Dave Ings You will find tooltips in just about any Windows application and they can be annoying.

    In the case of Save in Quicken, just press the enter key instead of using the mouse.

    In previous versions of Quicken this button said Save, so it was self explanatory.
    Quicken 2017 Premier - Windows 10 Pro
  • Dave Ings
    Dave Ings Member ✭✭✭
    edited October 2020
    Hi @Boatnmaniac and @Rich_M

    1) This is a behaviour change with the most recent release. Hasn't been an issue for, oh, the last ten years or so. smile
    2) Yes it is interfering, mostly. I can't click on the button without first dismissing the tooltip, unless I very carefully move the mouse to the 25% of the save button that is not obscured.
    3) The semi-transparent rectangle below the tooltip is a pretty good clue that whoever wrote this code likely has made an error. It should not be visible.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Dave Ings said:
    Hi @Boatnmaniac and @Rich_M

    1) This is a behaviour change with the most recent release. Hasn't been an issue for, oh, the last ten years or so. smile
    2) Yes it is interfering, mostly. I can't click on the button without first dismissing the tooltip, unless I very carefully move the mouse to the 25% of the save button that is not obscured.
    3) The semi-transparent rectangle below the tooltip is a pretty good clue that whoever wrote this code likely has made an error. It should not be visible.
    1) Yes, it's new. You know the old saying "If it works, don't fix it"? How about "If it works, tweak it until it breaks, then fix it"? That's actually my personal motto, but it shouldn't be Quicken's.
    2) I find I can click right through it in the US version without any problem.
    3) Agreed.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @Dave Ings Just to reiterate, this is not a change in behavior to Quicken due to a recent update, this is the way the "tooltips" work in Windows for this application.

    I'm still using an older version of Quicken, where the button says Save, so no tooltip is necessary.  I do have the gear and split icons, which have tooltips to explain what they do and exhibit the same behavior you're complaining about.  My understanding is that it's really the rectangular area below the tooltip that you have an issue with.

    Since they replaced the Save button with an icon for a disk, they have added a tooltip to explain what that does, so you have tooltips for all of those icons now.

    This rectangular area you have an issue with is actually a shadow under the "tooltip".

    It turns out that the tooltips in Quicken were implemented with tiny windows, which have a shadow under them by default, they are not true tooltips.

    You can eliminate this annoying shadow in Advanced Systems Settings in Control Panel.

    On the Advanced tab, Performance, click the Settings button and uncheck Show shadows under windows on the Visual Effects tabafter you click OK you will immediately see the difference in the tooltips in Quicken.

    Note that this change will have an effect on all windows in Windows.
    Quicken 2017 Premier - Windows 10 Pro
  • Dave Ings
    Dave Ings Member ✭✭✭
    Thank you @Rich_M for taking the time to offer suggestions.

    I was hopeful your suggestion would work, but it did not. The Show shadows under windows setting does indeed make the drop shadow around the rectangle go away, but the rectangle under the tooltip is still present, and it's the larger rectangle itself (and not the tooltip per se, or the drop shadow per se) causing the usability issue. (If this is unclear, please have another look at the screen capture I posted above.) 

    As you observe, in the latest release Quicken replaced a button which said Save with an icon and tooltip, which has created a usability problem, and to me that's a change. Odd to hear they aren't really Windows tooltips, but perhaps this is an example of how neglected the codebase was before the new product team took over.

    Anyhow, at this point I think the Quicken development team has what they need to address this if in fact they decide to fix it. Thanks for your insights.

  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @Dave Ings I don't see the updated screen shot you posted.
    Quicken 2017 Premier - Windows 10 Pro
  • Dave Ings
    Dave Ings Member ✭✭✭
    edited October 2020
    @Rich_M I have two Windows 10 systems nearby, a desktop and a laptop. I just went to post a revised screenshot, and discovered your Shadows under windows workaround works on the desktop but not the laptop. That's given me something to think about :smile: as nominally both systems are at the same patch level.

    (Edit) I have attached a revised screen capture from the laptop, with the workaround enabled (drop shadows turned off).


  • Dave Ings
    Dave Ings Member ✭✭✭
    Hi @Rich_M it never hurts to double check!

    But yes, even after rebooting, the problem persists on the laptop (but not the desktop) using the Visual Effects setting workaround. I can only speculate that subtle differences in the graphics engines are the root cause.

    Approaching from above (with the mouse pointer) is a great workaround! Thanks! Between that and the enter key, I can live with the situation! (Until I retired I was a professional software developer, so I'm used to living with workarounds! :smile:
    )

    Thanks again for taking the time to help.

  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @Dave Ings They could eliminate this issue with this custom tooltip if they would always position it so it does not obscure the button when you hover over it.
    Quicken 2017 Premier - Windows 10 Pro
  • YingDave
    YingDave Member ✭✭✭✭
    You should still be able to click the button even with the Tool tip over the top of it?
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @YingDave Yes, as long as the pointer is a hand, you might have to move it a bit to see that.
    Quicken 2017 Premier - Windows 10 Pro
This discussion has been closed.