Why is the amount in my spending reports displayed with an nbsp?

Hi to all,
I am new to Quicken, running Quicken Starter Version 5.18.2 on macOS 10.15.7.
Why is the amount in my spending reports displayed with an nbsp?
To be precise, the amount is displayed as [XXX (currency)] " & nbsp ; " [amount]
(no spaces before and after nbsp)
Any ideas why, and how to correct?
Thank you


  • UKR
    UKR SuperUser ✭✭✭✭✭
    An old discussion explained the cause and showed how to resolve it:
    There is a known bug where if the currency symbol follows the amount, the HTML code for non-breaking space (&nbsp) gets displayed instead of the space character. This occurs when the chosen macOS system language puts the currency symbol after the amount (eg. French).
    For now, you can change your language setting in macOS System Preferences > Language & Region to one that puts the currency symbol in front of the amount (eg. English). Unfortunately, macOS does not provide a way to force the currency symbol in front of the amount for languages that don't normally display this way. Understand that this will affect language display throughout your Mac. You may still use Euro as your main currency even with your Mac language set to English or any other language.
    We hope that Quicken will get this fixed eventually, but it is probably low priority since it is a display-only issue that affects relatively few users. Nonetheless, it would be good for you to report it using menu Help > Report a Problem in Quicken. (Your post here will not likely be seen by the developer team.) If they get enough reports, maybe they'll get it fixed.

    Does that work for you?

  • Thank you for finding this for me. In my case, the currency symbol PRECEDES the amount, but I will assume given the above that this bug is not serious to the point of corrupting data or any such thing.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    What is the exact currency symbol that you are using? It must be something more elaborate than just a simple $ or € ...

  • I use USD, EUR (shows up as €) and CHF, and have the non-breaking space problem with all three.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    If you were to change your Mac OS settings to use the US - English settings for region, language and currency (need to be sure to have numeric display of amounts set to the US way: decimal point and comma as thousands separator, e.g. $1,234.56 instead of €1.234,56 with no space between leading currency symbol and amount), would that help work around the display issue? Please try that and see if it works better for you. You need to stop and restart Quicken after making Mac OS setting changes.
    Quicken is marketed primarily for the US and Canadian markets, not world-wide. Therefore I don't think, that Quicken would ever allocate programmer time to permanently fixing this issue.

  • Thank you, I tried changing my Mac OS settings to the US-English settings as proposed. That fixes the issue for my USD and EUR spending reports, but not for the CHF spending report. I'll just (try to) ignore this issue going forward, as I understand there is no major issue attached to it (such as data corruption).
This discussion has been closed.