Some of my reports are very slow

spaman
spaman Windows Beta Beta
Some reports are fast and some say searching transactions and take a long time. Did not do that before. Nothing changed. 

Answers

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Try the "Fourth, Copy your file and Validate" step on this troubleshooting page.
    If that doesn't help, you'll have to tell us exactly which reports are fast and which are slow and we can take a look.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • spaman
    spaman Windows Beta Beta
    it did not work. how do i tell you the reports

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Every report has a name, visible in the upper left of its window.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • spaman
    spaman Windows Beta Beta
    these are my reports that I named: Business expenses by year, then the one that works: tax categories

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    When you say the copy and validate did not work, did it fail in some way, or did it complete successfully but the reports are still slow?

    Are the slow reports ones that you have customized and saved, or do some of the standard reports accessed from the Reports > Banking , spending, investing, etc. menus running slowly? If so which ones are slow? 
    QWin Premier subscription
  • spaman
    spaman Windows Beta Beta
    validate worked but reports slow. These are all customized reports (for taxes)
    It makes no sense why some slow and others not. the slow one is just a standard one item detail for a particular category over last 3 years. 
  • spaman
    spaman Windows Beta Beta
    stuck on searching transactions. 
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Let's have a look at your Quicken's innards. Do Help, then hold CTRL while clicking About Quicken. Show us the resulting display, which shows various statistics about the size of your data.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Sometimes internal changes to Quicken cause problems with older saved reports.

    You might try starting with the standard report and making the same customizations as the problem report and seeing if the new report has the same problems.

    If you share the starting report and what customizations were made, we can try it and see if it runs slow with our data as well.
    QWin Premier subscription
  • spaman
    spaman Windows Beta Beta
    Here it is
  • spaman
    spaman Windows Beta Beta
    Jim, I think you have the best idea and it makes sense. I will just recreate the reports. 
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    @spaman, are you using attached statements, or other images, to your Q transactions? Because your "Size of QDF file" is quite large.
    Also quite large is your number of Memorized Payees.  Your might consider a "Renaming Rule" so that "Gas Station #247" and "Gas Station # 298" are both recorded as simply "Gas Station" and you can delete all of the presumably redundant payees.
    I'd also suggest that you turn OFF "Automatically Memorize new Payees" and set your "Remove memorized Payees ..." value to something smaller.  Mine is set at 4 months, and that covers everything except my annual RE tax payment and other "Scheduled Transactions".  The only Memorized payees that I have are recurring (weekly, monthly, etc) transactions.  These settings are at: EDIT, Preferences, "Data entry & Quickfill"
    All of these suggestions will reduce the size of your Q data file ... and thus speed up your reports.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    NotACPA said:
    @spaman, are you using attached statements, or other images, to your Q transactions? Because your "Size of QDF file" is quite large.
    That's the size of the inner QDF, not counting attachments. So it is very large as are numbers of payees, securities, and transactions. That's a big file.
    With that many securities, it might be worthwhile to do an Archive of the investment accounts. This would move securities no longer held into new archive accounts and then reports could be restricted not to include those accounts.
    Recreating the reports is the easiest thing to try, but if that doesn't help, try Archive Transactions from the investment accounts' gear menu.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Before you archive investments, be sure to have a good backup at hand - mostly in case you don't like the results.  (I have not personally worked with having archived investment transactions and securities, so I can't comment on what issues it might raise.) 

    FWIW, I don't consider 552 securities "that many".  I don't think that is the cause of your issues.  
This discussion has been closed.