Retirement Account, Foreign Currency

ceschnurr
ceschnurr Member ✭✭
I have a retirement account through a Financial Advisor with RRIF investments in both $Cdn and $US in the same account. My understanding is that Quicken can't handle this, and I must create an separate Quicken account for each currency.

In Quicken, when I 'Add Account', Select ''Retirement', it does not provide an option to define the currency and defaults to $Cdn. I have used this to create the Quicken account to hold the $Cdn investments of my Advisor account.

My question is, How do I create a Quicken retirement account in $US currency for the $US investments in my Advisor account?

I have navigated around Quicken, and found that if I 'Add Account', 'Brokerage', I am prompted to define the currency. Should I use 'Brokerage' instead of 'Retirement'. What is the difference?

For info, I don't plan on using Quicken to download transactions from my Financial Advisor's website.

I am using Quicken Deluxe
Year: 2020,
Version: R28.15
Build: 28.1.28.15
Edition: Canada

Thanks

Best Answer

  • YingDave
    YingDave Member ✭✭✭✭
    edited February 1 Accepted Answer
    Hi @ceschnurr
    Not sure I am with you at the end there, my experience differs. I think it depends on what your home currency is. Mine is Australian Dollars and the net worth on my home page screen converts all my US$ shares back to A$ on the net worth total at today's exchange rate. Meanwhile on the Portfolio view I see separate currency entries with the local amounts, but the total on the bottom line they are all converted back to home currency of A$.

    Have your converted your file across from US to Canadian product in the past? Can you verify what your home currency is actually C$? Sounds obvious but the tricky thing is the Canadian version does not actually show the green tick mark on the home currency in the list (Ctrl+Q) nor does it let you change it. In the US version it is clearly marked and can be changed! Especially difficult if display symbols are the same for US & CA as just "$"? Hence the question if you switched it to C$ prior to converting from US Version file?

    Only place to see home currency in Canadian product is it at the bottom line of portfolio where it is spelt out long version, and as the default currency when creating a new report.

    However on your initial problem you are correct - if you set up a "Retirement" Quicken does not give you an opportunity to select the currency it just uses the home currency. However if you set up a Brokerage account - you can specify the currency. I have 3 US$ investment accounts based on title holder (ie. me, wife, Me&Wife Joint Tennants etc) and 3 A$ accounts. Since you are not intent on automatic down loads I suggest you create them as brokerage accounts?

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    What might be "close" is if you select Brokerage, and then go into the account details, and select "Tax deferred".  That will at least get you to the point where it tax handling should be correct.  And after you set that you might even be able to set it as a retirement account.  That is one of the few paths to changing the account type in Quicken.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • ceschnurr
    ceschnurr Member ✭✭
    Thanks Chris,
    That worked as described. I had been manually updating the few $US share prices to Quicken manually. With a separate $US account, I can get real time updates.

    HOWEVER,
    I assumed that Quicken would be able to apply the currency conversion to the $US accounts so when I view my Investment Portfolio View, Account Bar, and reports such as Networth etc; I would be able to see the applicable values in $Cdn. I can't seem to figure out how to make that work.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I don't know what to say on that last part.  I don't use multiple currencies, but it is my understanding that the conversion should have taken place because the portfolio view is in just one currency.  And to make it harder to test things like this the US version has "less multiple currency support" than the Canadian version, so they can work differently.  Maybe a Canadian user will come around and provide more insight.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    BTW I should have mentioned that you should report each of the problems so that the Quicken developers are aware of them: Help -> Report a problem
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • ceschnurr
    ceschnurr Member ✭✭
    edited January 31
    Thanks Chris,

    The Porfolio can be customized to Show / Not Show only accounts and securities that match the portfolio currency. I had thought this implied that if my Portfolio was in $Cdn, and any $US accounts would be converted to $Cdn. Per Quicken documentation, my Portfolio can only accurately show one currency. So it's best to select to 'Show only in portfolio currency', and then refresh Portfolio View for each Currency.

    Unfortunately, the Accounts Bar, which conveniently states Net Worth at the bottom acts the same way and does not convert the foreign currency to the Home Currency.

    The various Reports appear to show the values converted to $Cdn.
  • YingDave
    YingDave Member ✭✭✭✭
    edited February 1 Accepted Answer
    Hi @ceschnurr
    Not sure I am with you at the end there, my experience differs. I think it depends on what your home currency is. Mine is Australian Dollars and the net worth on my home page screen converts all my US$ shares back to **** on the net worth total at today's exchange rate. Meanwhile on the Portfolio view I see separate currency entries with the local amounts, but the total on the bottom line they are all converted back to home currency of ****.

    Have your converted your file across from US to Canadian product in the past? Can you verify what your home currency is actually C$? Sounds obvious but the tricky thing is the Canadian version does not actually show the green tick mark on the home currency in the list (Ctrl+Q) nor does it let you change it. In the US version it is clearly marked and can be changed! Especially difficult if display symbols are the same for US & CA as just "$"? Hence the question if you switched it to C$ prior to converting from US Version file?

    Only place to see home currency in Canadian product is it at the bottom line of portfolio where it is spelt out long version, and as the default currency when creating a new report.

    However on your initial problem you are correct - if you set up a "Retirement" Quicken does not give you an opportunity to select the currency it just uses the home currency. However if you set up a Brokerage account - you can specify the currency. I have 3 US$ investment accounts based on title holder (ie. me, wife, Me&Wife Joint Tennants etc) and 3 **** accounts. Since you are not intent on automatic down loads I suggest you create them as brokerage accounts?
  • ceschnurr
    ceschnurr Member ✭✭
    I went back to check, and you are correct. I didn't look close enough. My Account Bar is actually correct. The $values of each Investment Account listed is in its own currency and designated by a $C or $ (US implied). But the summed total has the Exchange rate applied.

    Eg, If I had 2 investing Accounts
    Account1, $2Cdn
    Account2, $1US

    Account Bar would Show ($1US=$1.30Cdn Exchange Rate)
    Investing, C$3.30 (Total)
    Account1, C$2
    Account2, $1

    I really don't know how to verify that my home currency is $Cdn. I may have entered it during the initial setup of Quicken, or I just assumed that since I have the Cdn Edition, that it would be $Cdn.

    That's not quite my experience. I now have separate accounts for $US and $Cdn investments.

    On my Portfolio Tab, I have a drop down for Currency. When I enter $CDN it shows me only investments I have in $Cdn. When I enter $US, it shows only the $US investments. The 'Totals in' text at the bottom of each Portfolio simply reflects the currency entered in the dropdown.

    My reports Net Worth, (and I suspect most others) have a dropdown to select Currency. When I set this to $Cdn, it applies the exchange rate to the applicable $US investments.

    Thanks for the help,
    Carl
  • YingDave
    YingDave Member ✭✭✭✭
    @ceschnurr
    Yes as I mentioned above it is a little more obscure to see that in CA product. However if you start a blank report it should select the home currency as the display before you change anything. If you converted from US to CA or vice versa using the same data file it does not move the home currency. Sounds like you have not done though. 

    Any way if you set up brokerage account you should be able to specify the currency of that account to what ever you like. A Retirement account seems to locked to the home currency - probably for no real good reason except shortcutting some programming or lack of consideration that people would want that option when it was developed?
  • ceschnurr
    ceschnurr Member ✭✭
    Thanks YingDave. As Chris mentioned above, I initially set it up as a brokerage account, then changed the definition to 'Retirement', and it seems to be working as I expected.
    Thanks

    > @Chris_QPW said:
    > What might be "close" is if you select Brokerage, and then go into the account details, and select "Tax deferred".  That will at least get you to the point where it tax handling should be correct.  And after you set that you might even be able to set it as a retirement account.  That is one of the few paths to changing the account type in Quicken.
This discussion has been closed.