Double entry of stock symbol after Schwab download.

Hopefully, someone here will have an answer to my dilemma even though similar situations with Quicken seem to be never ending.

Quicken added a new ETF (VTI), in a download from Schwab, even though it already existed in Quicken from previous Schwab downloads. Consequently, I now have two VTI symbols in Schwab. In the process it deleted the CUSIP number from the old VTI symbol, with a large number of shares, and now the new VTI symbol has the same CUID number with the correct number of shares.

In the old version of VTI the various transactions go back to 2005 so going back through a couple of hundred entries and changing to the new VTI entry is out of the question.

I jumped though a number of hoops with tech support but to no avail.

Ideally, I'd like to just delete all the transactions in the old VTI and that particular security. At this point I don't care about the old transactions as I have a cost basis in the new VTI entry with the correct number of shares. I just need to have Quicken reflect the correct number of shares.

Thank you and any help much appreciated!

Best Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited February 6 Accepted Answer
    If you just want Quicken to reflect the correct number of shares, enter a Removed action transaction to remove the original security holdings and an Added action transaction for the new security holdings.

    The correct way is to fix the problem so you may maintain an accurate cost-basis and track performance.  If the problem just happened, you should be able toarestore backup.  Otherwise, you should delete the placeholder transactions and use the same  security in all the transactions.  Generally, there should be fewer transactions of the newer security.  If you have removed all the referenced to the new security, you may delete the security and the next time Quicken compares the holdings, you should be able to select the original security.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    Thanks for the reply Sherlock.

    Wouldn't that require me to "Remove" every instance of transactions in the original VTI listing? As I mentioned there are hundreds so I'm trying to avoid that. Maybe I missed an option to select all of them to delete?

    The new VTI listing has the correct number of shares and I used an average cost basis. I don't really care about it being that accurate at this point.

    I did tried deleting the new VTI listing, and their transactions, but Quicken would not recognize the original VTI listing and once again added the new VTI listing.
    I was not suggesting you "Remove" every instance of transactions in the original VTI listing but we are able to select multiple transactions and delete them.

    I suspect there is something set on the original security preventing Quicken from seeing it as available to be matched to the imported security.  For example, perhaps the original security has been given the wrong type.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    > @Sherlock said:
    > I was not suggesting you "Remove" every instance of transactions in the original VTI listing but we are able to select multiple transactions and delete them.
    >

    That's the thing. Where do I select multiple transactions (250 of them) in the brokerage account register in Quicken? I can search for those older listings but the search results do not let me select all of them to delete. The check boxes are grayed out and says to go to each individual transaction.

    > I suspect there is something set on the original security preventing Quicken from seeing it as available to be matched to the imported security.  For example, perhaps the original security has been given the wrong type.
    >

    For years it had been updating correctly. This all started about 3 months ago. At first Quicken tech support fobbed it off to Schwab but Schwab claims they haven't made any changes.

    I do really appreciate you taking the time to help Sherlock.
    The original way to delete lots of transactions in investment account is to use a customized Transaction report.  This approach still provides the most flexibility.  Recently, Quicken added the Edit Multiple Transactions option to the Actions menu which can also be used.

    If you would like further assistance fixing the security matching issue, please provide a screen capture of the Edit Security Details window of the two VTI securities.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    >The original way to delete lots of transactions in investment account is to use a >customized Transaction report.

    I did that and I can see no way to delete those transactions.
    Select Reports > Banking > Transaction, press Alt + C, select the Accounts tab, Clear All, check the investment account, select the Securities tab, Clear All, check the security, select OK, select Include all dates in the Date range: pull-down menu, select all the transactions, right-click and select Delete transaction(s)

    >Quicken added the Edit Multiple Transactions option to the Actions menu >which can also be used.

    Yes but those boxes are grayed out and unable to delete. Works fine in a check register though.
    Open the investment account, press Ctrl + Shift  + N, select Edit Multiple Transactions, click on the Security column title, select the range of transactions with the security, and Delete

    Art_M said:
    First listing is old VTI, third is new VTI.
    I requested the Edit Security Details window of each security: right click on the security in the Security List and select Edit
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    >Change the Security type for the old VTI
    >Edit the transactions for the new VTI to refer to the old VTI
    >After all the edits, delete the new VTI.

    Tried changing to either stock or mutual fund.

    Tried that before but unfortunately the drop down box for the security name only shows the existing VTI. If I select a transaction from the new VTI the drop down only shows the new security. Likewise if I select a transaction from the old VTI, the drop down only shows the old VTI. There is no option to select one or the other. The images may help explain.
    To select a different security from the security menu, type over the currently selected (highlighted) security.

    Art_M said:
    >Select Reports > Banking > Transaction, press Alt + C, select the Accounts...

    Yep, that works and returns all transactions back to 2005. Thank you!

    >Open the investment account, press Ctrl + Shift + N, select Edit Multiple Transactions...

    That only returns current year's transactions.
    I can not reproduce the behavior.  Selecting Edit Multiple Transactions...
    consistently provides all the transactions in the investment register.
    Thanks for those tips. Very helpful!

    Attached are the correct screen shots, I believe.
    The securities should be of type Mutual Fund if you are using average cost.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    Thanks to all of these helpful tips I have managed to get the new VTI listing transactions into the old VTI listing transactions. Even though the new VTI listing has no transactions, I am unable to delete (delete greyed out). A report search shows no transactions as well.

    I have been a Quicken user since the 90s and this is/was a tough one for me.

    My fear is that once Schwab has new VTI transactions to download, I will be right back where I started. Quicken will ask me add a new security. Stay tuned...

    Thanks again to Sherlock and q_lurker!

    I suspect you may not have deleted all the placeholder transactions referencing the new VTI security.  To view the placeholder transactions in the investment account, I suggest you check the Show hidden transactions preference: select Edit > Preferences...


Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited February 6 Accepted Answer
    If you just want Quicken to reflect the correct number of shares, enter a Removed action transaction to remove the original security holdings and an Added action transaction for the new security holdings.

    The correct way is to fix the problem so you may maintain an accurate cost-basis and track performance.  If the problem just happened, you should be able toarestore backup.  Otherwise, you should delete the placeholder transactions and use the same  security in all the transactions.  Generally, there should be fewer transactions of the newer security.  If you have removed all the referenced to the new security, you may delete the security and the next time Quicken compares the holdings, you should be able to select the original security.
  • Art_M
    Art_M Member ✭✭
    Thanks for the reply Sherlock.

    Wouldn't that require me to "Remove" every instance of transactions in the original VTI listing? As I mentioned there are hundreds so I'm trying to avoid that. Maybe I missed an option to select all of them to delete?

    The new VTI listing has the correct number of shares and I used an average cost basis. I don't really care about it being that accurate at this point.

    I did tried deleting the new VTI listing, and their transactions, but Quicken would not recognize the original VTI listing and once again added the new VTI listing.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    Thanks for the reply Sherlock.

    Wouldn't that require me to "Remove" every instance of transactions in the original VTI listing? As I mentioned there are hundreds so I'm trying to avoid that. Maybe I missed an option to select all of them to delete?

    The new VTI listing has the correct number of shares and I used an average cost basis. I don't really care about it being that accurate at this point.

    I did tried deleting the new VTI listing, and their transactions, but Quicken would not recognize the original VTI listing and once again added the new VTI listing.
    I was not suggesting you "Remove" every instance of transactions in the original VTI listing but we are able to select multiple transactions and delete them.

    I suspect there is something set on the original security preventing Quicken from seeing it as available to be matched to the imported security.  For example, perhaps the original security has been given the wrong type.
  • Art_M
    Art_M Member ✭✭
    > @Sherlock said:
    > I was not suggesting you "Remove" every instance of transactions in the original VTI listing but we are able to select multiple transactions and delete them.
    >

    That's the thing. Where do I select multiple transactions (250 of them) in the brokerage account register in Quicken? I can search for those older listings but the search results do not let me select all of them to delete. The check boxes are grayed out and says to go to each individual transaction.

    > I suspect there is something set on the original security preventing Quicken from seeing it as available to be matched to the imported security.  For example, perhaps the original security has been given the wrong type.
    >

    For years it had been updating correctly. This all started about 3 months ago. At first Quicken tech support fobbed it off to Schwab but Schwab claims they haven't made any changes.

    I do really appreciate you taking the time to help Sherlock.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    > @Sherlock said:
    > I was not suggesting you "Remove" every instance of transactions in the original VTI listing but we are able to select multiple transactions and delete them.
    >

    That's the thing. Where do I select multiple transactions (250 of them) in the brokerage account register in Quicken? I can search for those older listings but the search results do not let me select all of them to delete. The check boxes are grayed out and says to go to each individual transaction.

    > I suspect there is something set on the original security preventing Quicken from seeing it as available to be matched to the imported security.  For example, perhaps the original security has been given the wrong type.
    >

    For years it had been updating correctly. This all started about 3 months ago. At first Quicken tech support fobbed it off to Schwab but Schwab claims they haven't made any changes.

    I do really appreciate you taking the time to help Sherlock.
    The original way to delete lots of transactions in investment account is to use a customized Transaction report.  This approach still provides the most flexibility.  Recently, Quicken added the Edit Multiple Transactions option to the Actions menu which can also be used.

    If you would like further assistance fixing the security matching issue, please provide a screen capture of the Edit Security Details window of the two VTI securities.
  • Art_M
    Art_M Member ✭✭
    >The original way to delete lots of transactions in investment account is to use a >customized Transaction report.

    I did that and I can see no way to delete those transactions.

    >Quicken added the Edit Multiple Transactions option to the Actions menu >which can also be used.

    Yes but those boxes are grayed out and unable to delete. Works fine in a check register though.
  • Art_M
    Art_M Member ✭✭
    First listing is old VTI, third is new VTI.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    >The original way to delete lots of transactions in investment account is to use a >customized Transaction report.

    I did that and I can see no way to delete those transactions.
    Select Reports > Banking > Transaction, press Alt + C, select the Accounts tab, Clear All, check the investment account, select the Securities tab, Clear All, check the security, select OK, select Include all dates in the Date range: pull-down menu, select all the transactions, right-click and select Delete transaction(s)

    >Quicken added the Edit Multiple Transactions option to the Actions menu >which can also be used.

    Yes but those boxes are grayed out and unable to delete. Works fine in a check register though.
    Open the investment account, press Ctrl + Shift  + N, select Edit Multiple Transactions, click on the Security column title, select the range of transactions with the security, and Delete

    Art_M said:
    First listing is old VTI, third is new VTI.
    I requested the Edit Security Details window of each security: right click on the security in the Security List and select Edit
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    The source of your troubles is that you gave the security the type of "Market Index".  It should be "Mutual Fund" or possibly "Stock". 

    If you have just 3 months of the new VTI I would:
    1. Back up your data file.
    2. Change the Security type for the old VTI
    3. Edit the transactions for the new VTI to refer to the old VTI
    4. After all the edits, delete the new VTI.
    5. The next download from Schwab, you should be able to reset the Schwab security to match with you old VTI (likely it will be almost seamless). 
  • Art_M
    Art_M Member ✭✭
    >Change the Security type for the old VTI
    >Edit the transactions for the new VTI to refer to the old VTI
    >After all the edits, delete the new VTI.

    Tried changing to either stock or mutual fund.

    Tried that before but unfortunately the drop down box for the security name only shows the existing VTI. If I select a transaction from the new VTI the drop down only shows the new security. Likewise if I select a transaction from the old VTI, the drop down only shows the old VTI. There is no option to select one or the other. The images may help explain.
  • Art_M
    Art_M Member ✭✭
    >Select Reports > Banking > Transaction, press Alt + C, select the Accounts...

    Yep, that works and returns all transactions back to 2005. Thank you!

    >Open the investment account, press Ctrl + Shift + N, select Edit Multiple Transactions...

    That only returns current year's transactions.

    Thanks for those tips. Very helpful!

    Attached are the correct screen shots, I believe.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    >Change the Security type for the old VTI
    >Edit the transactions for the new VTI to refer to the old VTI
    >After all the edits, delete the new VTI.

    Tried changing to either stock or mutual fund.

    Tried that before but unfortunately the drop down box for the security name only shows the existing VTI. If I select a transaction from the new VTI the drop down only shows the new security. Likewise if I select a transaction from the old VTI, the drop down only shows the old VTI. There is no option to select one or the other. The images may help explain.
    To select a different security from the security menu, type over the currently selected (highlighted) security.

    Art_M said:
    >Select Reports > Banking > Transaction, press Alt + C, select the Accounts...

    Yep, that works and returns all transactions back to 2005. Thank you!

    >Open the investment account, press Ctrl + Shift + N, select Edit Multiple Transactions...

    That only returns current year's transactions.
    I can not reproduce the behavior.  Selecting Edit Multiple Transactions...
    consistently provides all the transactions in the investment register.
    Thanks for those tips. Very helpful!

    Attached are the correct screen shots, I believe.
    The securities should be of type Mutual Fund if you are using average cost.
  • Art_M
    Art_M Member ✭✭
    Thanks to all of these helpful tips I have managed to get the new VTI listing transactions into the old VTI listing transactions. Even though the new VTI listing has no transactions, I am unable to delete (delete greyed out). A report search shows no transactions as well.

    I have been a Quicken user since the 90s and this is/was a tough one for me.

    My fear is that once Schwab has new VTI transactions to download, I will be right back where I started. Quicken will ask me add a new security. Stay tuned...

    Thanks again to Sherlock and q_lurker!
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    Art_M said:
    Thanks to all of these helpful tips I have managed to get the new VTI listing transactions into the old VTI listing transactions. Even though the new VTI listing has no transactions, I am unable to delete (delete greyed out). A report search shows no transactions as well.

    I have been a Quicken user since the 90s and this is/was a tough one for me.

    My fear is that once Schwab has new VTI transactions to download, I will be right back where I started. Quicken will ask me add a new security. Stay tuned...

    Thanks again to Sherlock and q_lurker!

    I suspect you may not have deleted all the placeholder transactions referencing the new VTI security.  To view the placeholder transactions in the investment account, I suggest you check the Show hidden transactions preference: select Edit > Preferences...


  • Art_M
    Art_M Member ✭✭
    Yep, that did it Sherlock. Can't thank you enough for all of your help!
Sign In or Register to comment.