How do I remove of securities listed as "active" which are long gone?

pjw7
pjw7 Member ✭✭
Why do I have to scroll through dozens of securities which are no longer in my portfolio?

Best Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited March 2021 Answer ✓
    From your post, there are two possible issues here, and I'm not sure which you're concerned with.

    In the Window > Securities list, do you see the Currently Held column? If not, Control-click in the column headings, and select Currently Held from the pop-up list of available columns.

    If there are any securities which have the green check mark for Currently Held which you do no town any more, then you need to tell Quicken you don't own what it thinks you do. This can sometimes happen if there's a tiny fraction of a share Quicken has due to rounding from years ago.

    Click on the Investing group heading in the left sidebar, click on Portfolio view, and set the filters to Portfolio Value and Group by Security. Make sure the Shares column is visible, and look at what Quicken is showing for the securities you don't own any more. If it's a tiny fraction, like 0.000001 share, then you can fix this by going to Transaction view and entering a Remove Shares transaction for the amount of shares Quicken believes you have. the security should then disappear from the Portfolio view entirely.

    On the other hand, if you are talking about securities which Quicken shows you don't hold, and wish were no longer in your securities list at all, that's a different matter. Having a way to Hide Securities is a request many Quicken users have, and there is a thread on this site discussing that. The good news is that the developers have stated there that this functionality is planned for a future update; the bad news is that we don't know when this feature will be released. If you read towards the bottom of that thread, you'll find some ideas users have shared about making the security list less painful by renaming securities they no longer hold with a prefix like "z" so they drop out of active sight to the bottom of the list. 
    Quicken Mac Subscription • Quicken user since 1993
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    @pjw7  So your options are to (a) rename old securities with a "z" prefix, or (b) wait for an update which adds hiding of inactive securities. There's unfortunately no way to know whether this is high, medium or low on the developers' priority list; it could come out next month or next year.
    Quicken Mac Subscription • Quicken user since 1993
  • pjw7
    pjw7 Member ✭✭
    edited August 2021 Answer ✓
    Just clogging the securities list with their green check marks.

    And, thank you, I didn't notice the pencil icon, so I can send all five securities to the end of the 'Currently held" set. I would like eventually to send them to their rightful place amid the 249 "not currently held" others.
    Still don't know why a bond that matured in May and has no residual bits, didn't lose its check mark. Thanks.

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited March 2021 Answer ✓
    From your post, there are two possible issues here, and I'm not sure which you're concerned with.

    In the Window > Securities list, do you see the Currently Held column? If not, Control-click in the column headings, and select Currently Held from the pop-up list of available columns.

    If there are any securities which have the green check mark for Currently Held which you do no town any more, then you need to tell Quicken you don't own what it thinks you do. This can sometimes happen if there's a tiny fraction of a share Quicken has due to rounding from years ago.

    Click on the Investing group heading in the left sidebar, click on Portfolio view, and set the filters to Portfolio Value and Group by Security. Make sure the Shares column is visible, and look at what Quicken is showing for the securities you don't own any more. If it's a tiny fraction, like 0.000001 share, then you can fix this by going to Transaction view and entering a Remove Shares transaction for the amount of shares Quicken believes you have. the security should then disappear from the Portfolio view entirely.

    On the other hand, if you are talking about securities which Quicken shows you don't hold, and wish were no longer in your securities list at all, that's a different matter. Having a way to Hide Securities is a request many Quicken users have, and there is a thread on this site discussing that. The good news is that the developers have stated there that this functionality is planned for a future update; the bad news is that we don't know when this feature will be released. If you read towards the bottom of that thread, you'll find some ideas users have shared about making the security list less painful by renaming securities they no longer hold with a prefix like "z" so they drop out of active sight to the bottom of the list. 
    Quicken Mac Subscription • Quicken user since 1993
  • pjw7
    pjw7 Member ✭✭
    It's the second one, alas.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    @pjw7  So your options are to (a) rename old securities with a "z" prefix, or (b) wait for an update which adds hiding of inactive securities. There's unfortunately no way to know whether this is high, medium or low on the developers' priority list; it could come out next month or next year.
    Quicken Mac Subscription • Quicken user since 1993
  • pjw7
    pjw7 Member ✭✭
    I cannot edit the security name in the security list to add a prefix "Z".
    I have bonds that have matured, and are still hanging around contaminating the securities list!
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    pjw7 said:
    I cannot edit the security name in the security list to add a prefix "Z".
    I have bonds that have matured, and are still hanging around contaminating the securities list!
    Please add more information to the first statement. I'm wondering what prevents you from editing the name of a security? Where along this sequence do you get stopped, and is there amen message which comes up?
    1. Open Windows > Securities
    2. Click on a security to highlight it
    3. Click on the pencil icon at the bottom of the window
    4. Edit or re-type a security name
    5. Click Done.
    For the matured bonds, are they just clogging up your securities list, or do any of them show up in your portfolio view? In other words, is Quicken telling you it thinks you still hold some of these securities? Or do they all have zero values, and you just want to clean up your securities list?

    Quicken Mac Subscription • Quicken user since 1993
  • pjw7
    pjw7 Member ✭✭
    edited August 2021 Answer ✓
    Just clogging the securities list with their green check marks.

    And, thank you, I didn't notice the pencil icon, so I can send all five securities to the end of the 'Currently held" set. I would like eventually to send them to their rightful place amid the 249 "not currently held" others.
    Still don't know why a bond that matured in May and has no residual bits, didn't lose its check mark. Thanks.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Well, if you have green check marks indicating Currently Held, that means Quicken thinks you have some of this security remaining. 

    Click on Investing in the left sidebar
    Click on Portfolio on the right side
    Set the first filter to Portfolio Value
    Set the second filter to Group by Security
    Make sure the Shares column is visible

    Do you see any of these securities in the portfolio list? You likely should, since Quicken is saying it believes you currently hold these securities.

    In some cases, dues to rounding, Quicken might show you have something like 0.000001 share of a security, even though it amounts to no dollar value. If you find such fractional holdings, you can then enter Remove Shares transactions to make these fractional amounts disappear -- and the securities window should reflect that you no longer hold these securities.

    Quicken Mac Subscription • Quicken user since 1993
  • pjw7
    pjw7 Member ✭✭
    Thanks, I'd read and tried this solution previously.
    None of the five securities appear in my portfolios, and since four of the five were very ancient, I suspect I did some short-cutting when I moved from Qn2007. The bond one though was bought in 2017, and matured this past May. The $5000 and the interest were both recorded as transactions, so it should have vanished, yet there it is, in Securities, with its green check mark! Never mind. It's been Zedded.
This discussion has been closed.