Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

OL-301-A Error Updating from Schwab

pippy
pippy Member ✭✭
Starting 3/15/2021 I started getting Error OL-310-A when trying to update from Schwab. I have had no problems for many months, maybe years. My last error free downloads were on 3/12/2021 and 3/13/2021. The error started on 3/15/2021 and has persisted regardless of what time of day I have tried. I have made no changes to my Schwab account settings or Quicken settings. The FI files appear to have been download / updated today 3/16/2021. All other financial institutions that connect via Direct Connect work with errors. I developed software for many years so not a novice at this. Your guidance is appreciated. Thank you.

Running Windows 10, Quicken R31.20 Build 27.1.31.20

Connection Log looks like this on all attempts:
==== Mini-OSU Start (20210316/20:36:26) ====
20210316 20:36:26: Marketing session sending to: https://ofx.schwab.com/index.ini
20210316 20:36:26: QFN: Beginning get from https://ofx.schwab.com/index.ini
20210316 20:36:27: ***QFN kQFFinished: returns 67305875
20210316 20:36:27: The application has been denied access to the server. Try again now, or wait and try later.
20210316 20:36:28: QFN: End get from https://ofx.schwab.com/index.ini, netstatus 15
20210316 20:36:28: QFN: Beginning send to https://services.quicken.com/ofx-secure-plus/8888
20210316 20:36:30: QFN: End send to https://services.quicken.com/ofx-secure-plus/8888, netstatus 0
20210316 20:36:30: General error
20210316 20:36:31:

==== Mini-OSU End (20210316/20:36:36) ====

Best Answer

  • pippy
    pippy Member ✭✭
    Accepted Answer
    @UKR @Quicken_Tyka It's certainly possible that it was an overloaded system but I am dubious for a variety of reasons. 1) Logging into Schwab and accessing the accounts via the web has had no issues, regardless of time of day 2) I have tried doing a Quicken download at various times of the day and received the same error messages and log file entries. But something has definitely changed in the software pipeline somewhere between Quicken and Schwab because the error disappeared from Quicken this afternoon without me changing anything. Now maybe this points to something at Schwab but here's the thing. The CONNLOG file shows the exact same failure status for the attempts that worked today as it does for the attempts that failed. In fact I looked back to early March and the CONNLOG entries are the same. Why would Quicken behave differently in each case unless there was some change to Quicken or the software that connects Quicken to Schwab since I changed nothing and the CONNLOG shows the exact same entries for failed and successful attempts at communicating with the Schwab OFX server?

    FAILURE
    ==== Mini-OSU Start (20210317/17:40:37) ====
    20210317 17:40:37: Marketing session sending to: https://ofx.schwab.com/index.ini
    20210317 17:40:37: QFN: Beginning get from https://ofx.schwab.com/index.ini
    20210317 17:40:37: ***QFN kQFFinished: returns 67305875
    20210317 17:40:37: The application has been denied access to the server. Try again now, or wait and try later.
    20210317 17:40:38: QFN: End get from https://ofx.schwab.com/index.ini, netstatus 15
    20210317 17:40:38: QFN: Beginning send to https://services.quicken.com/ofx-secure-plus/8888
    20210317 17:40:40: QFN: End send to https://services.quicken.com/ofx-secure-plus/8888, netstatus 0
    20210317 17:40:40: General error
    20210317 17:40:42:

    ==== Mini-OSU End (20210317/17:40:47) ====

    SUCCESS
    ==== Mini-OSU Start (20210318/14:04:12) ====
    20210318 14:04:12: Marketing session sending to: https://ofx.schwab.com/index.ini
    20210318 14:04:12: QFN: Beginning get from https://ofx.schwab.com/index.ini
    20210318 14:04:12: ***QFN kQFFinished: returns 67305875
    20210318 14:04:12: The application has been denied access to the server. Try again now, or wait and try later.
    20210318 14:04:14: QFN: End get from https://ofx.schwab.com/index.ini, netstatus 15
    20210318 14:04:14: QFN: Beginning send to https://services.quicken.com/ofx-secure-plus/8888
    20210318 14:04:16: QFN: End send to https://services.quicken.com/ofx-secure-plus/8888, netstatus 0
    20210318 14:04:17:

    ==== Mini-OSU End (20210318/14:04:21) ====

    The good news is things seem to be working today so I think we can close this issue out for now. Thanks for your responses.

Answers

  • pippy
    pippy Member ✭✭
    I also Reset the Accounts (Deactive / Reactivate) and checked that Third Party Access for Quicken was enabled at Schwab for my accounts and it is.
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @pippy

    Thank you for taking the time to visit the Community to report this issue, although I apologize that you have not received a response.

    Have there been any changes to this account, such as the account being closed? If not, I would try updating the password for your Schwab account to see if that corrects the error.

    There are special characters that can interfere with OSU they are,(but are not limited to) the ampersand (&), left carat (<), right carat (>), backslash (\), and forward-slash (/).  I would try to avoid using any of these special characters in the password.

    Please let me know how it goes!

    -Quicken Tyka
    ~~~***~~~
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Error OL 301 with Schwab accounts (or "General error 2000")?

    Logon to your Internet account at Schwab's website and make sure that in your profile, Security Center, "Third Party Access" is set to "Allow".
    Wait several minutes before attempting to download from Quicken again.

    Quicken Mac users: Make sure that your account is connected to Schwab using the "Direct Connect"  method by clicking the "Options" button in the Add Account screen.


  • pippy
    pippy Member ✭✭
    edited March 18
    > @Quicken_Tyka said:
    > Hello @pippy
    >
    > Thank you for taking the time to visit the Community to report this issue, although I apologize that you have not received a response.
    >
    > Have there been any changes to this account, such as the account being closed? If not, I would try updating the password for your Schwab account to see if that corrects the error.
    >
    > There are special characters that can interfere with OSU they are,(but are not limited to) the ampersand (&), left carat (<), right carat (>), backslash (\), and forward-slash (/).  I would try to avoid using any of these special characters in the password.
    >
    > Please let me know how it goes!
    >
    > -Quicken Tyka

    Thanks Tyka. There are no special characters in the password and there are have been no account changes. As I mentioned everything worked fine up through Saturday 3/13/2021. The failures started Monday 3/15/2021 and have continued since then. Have others reported any issues with Schwab download? Having developed software for many years, my instinct tells me that something changed in the ecosystem somewhere. Interestingly, while the Connection Log shows an error, the OFX log shows that position and price information were downloaded and don't seem to show any errors. How can this be? Something is off here? What does the 67305875 status mean in the Connection Log?
  • pippy
    pippy Member ✭✭
    > @UKR said:
    > Error OL 301 with Schwab accounts (or "General
    > error 2000")?
    >
    > Logon to your
    > Internet account at Schwab's website and make sure that in your profile,
    > Security Center, "Third Party Access" is set to
    > "Allow".
    >
    > Wait several minutes before attempting to download from Quicken again.
    >
    > Quicken Mac users:
    > Make sure that your account is connected to Schwab using the "Direct
    > Connect"  method by clicking the
    > "Options" button in the Add Account screen.

    Thanks UKR. Everything was working fine until 3/15/2021, including my last successful download on 3/13/2021. The Schwab security center has been set to Allow Quicken 3rd party access forever and is still that way when I checked it. Any other ideas?
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Could it be that the Schwab server is temporarily overloaded, trying to digest the latest round of economic impact direct deposits from the government?
    Only a call to Schwab Support by a Schwab customer could shed some light on this ...
    I recommend waiting a day or two. If the problem persists after that, please call Schwab Support.

  • pippy
    pippy Member ✭✭
    Accepted Answer
    @UKR @Quicken_Tyka It's certainly possible that it was an overloaded system but I am dubious for a variety of reasons. 1) Logging into Schwab and accessing the accounts via the web has had no issues, regardless of time of day 2) I have tried doing a Quicken download at various times of the day and received the same error messages and log file entries. But something has definitely changed in the software pipeline somewhere between Quicken and Schwab because the error disappeared from Quicken this afternoon without me changing anything. Now maybe this points to something at Schwab but here's the thing. The CONNLOG file shows the exact same failure status for the attempts that worked today as it does for the attempts that failed. In fact I looked back to early March and the CONNLOG entries are the same. Why would Quicken behave differently in each case unless there was some change to Quicken or the software that connects Quicken to Schwab since I changed nothing and the CONNLOG shows the exact same entries for failed and successful attempts at communicating with the Schwab OFX server?

    FAILURE
    ==== Mini-OSU Start (20210317/17:40:37) ====
    20210317 17:40:37: Marketing session sending to: https://ofx.schwab.com/index.ini
    20210317 17:40:37: QFN: Beginning get from https://ofx.schwab.com/index.ini
    20210317 17:40:37: ***QFN kQFFinished: returns 67305875
    20210317 17:40:37: The application has been denied access to the server. Try again now, or wait and try later.
    20210317 17:40:38: QFN: End get from https://ofx.schwab.com/index.ini, netstatus 15
    20210317 17:40:38: QFN: Beginning send to https://services.quicken.com/ofx-secure-plus/8888
    20210317 17:40:40: QFN: End send to https://services.quicken.com/ofx-secure-plus/8888, netstatus 0
    20210317 17:40:40: General error
    20210317 17:40:42:

    ==== Mini-OSU End (20210317/17:40:47) ====

    SUCCESS
    ==== Mini-OSU Start (20210318/14:04:12) ====
    20210318 14:04:12: Marketing session sending to: https://ofx.schwab.com/index.ini
    20210318 14:04:12: QFN: Beginning get from https://ofx.schwab.com/index.ini
    20210318 14:04:12: ***QFN kQFFinished: returns 67305875
    20210318 14:04:12: The application has been denied access to the server. Try again now, or wait and try later.
    20210318 14:04:14: QFN: End get from https://ofx.schwab.com/index.ini, netstatus 15
    20210318 14:04:14: QFN: Beginning send to https://services.quicken.com/ofx-secure-plus/8888
    20210318 14:04:16: QFN: End send to https://services.quicken.com/ofx-secure-plus/8888, netstatus 0
    20210318 14:04:17:

    ==== Mini-OSU End (20210318/14:04:21) ====

    The good news is things seem to be working today so I think we can close this issue out for now. Thanks for your responses.
This discussion has been closed.