Quicken bugsplat crashes on QFX file import

questionsforever
questionsforever Member ✭✭
when i go to import a quicken qfx file it crashes after asking me to link the register with an account. If I import the qfx into a brand new investment account it works. what is happening? last month i was able to import no problem. this month just crashes. It seems that even if a new investment account is created for import, then trying to link to that to import again also crashes. It seems every time you select a linked account as opposed to a new one for qfx import it crashes.

PS. I have a partial observation. It only crashes if the investment register to import to has a ´linked checking account´. I have tested with a new investment account that is empty that has NO linked checking account and it imports.
If after the FID connection was made, I can split it into a linked checking account and new imports will work.

It seems the problem is the initial connection with the FID and the initial state of the investment account. But how can this be fixed in an old investment account that has wrong FID info or is disconnected from a connection? It seems that there is a corruption of an old investment account and it cannot get the correct FID link from the qfx file. Nothing I do seems to get this link back. Any ideas short of having to manually move every transaction from the linked investment account or just closing that account and starting fresh on a new account? How can an investment account be corrupted so that it cannot get the link with the FID properly anymore?
Tagged:

Answers

  • questionsforever
    questionsforever Member ✭✭
    every time i move transactions or import qfx files, I keep getting a pop-up about currency exchange rate box for every single transaction. The currency is correct for all accounts but this popup says to calculate the correct investment reports i have to accept this box. if you have thousands of transactions it takes forever to accept. any way to avoid it? or quicken development can figure out a way to stop it popping up on all imports and transaction movements?
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello @questionsforever

    Thank you for taking the time to visit the Community to report your issue, although I apologize that you have not received a response.

    As I do not see that it has been done yet,  I would save a backup and run the Validate & Repair as well as Rebuild Investing Lots from the File menu > File Operations > Validate & Repair option.

    In the Validate File window that opens, click the top box to "validate file" and "Rebuild Investing Lots" then click OK.

    When the validation completes, a data log will open in Notepad, please let us know if any errors or issues are found/repaired, and when ready close and re-open Quicken.

    Please let me know how it goes!

    -Quicken Tyka

    ~~~***~~~
  • questionsforever
    questionsforever Member ✭✭
    edited April 3
    no, doesn't work. I deleted all my data and started again just to track expenses. I won't be renewing subscription. this software is not updated , new updates have no improvements and the software is poorly written with many bugs. I spent 48 hours non stop doing nothing but seeing crashes. i have huge data files , I can't wait around 10 hours pressing enter key on every pop up to move transactions around or collapse a linked checking account.
  • questionsforever
    questionsforever Member ✭✭
    It worked! But not because of the reason above. The FID connection from an old file already existed and the account number, userid, and bank id had to match exactly the qfx file. for some reason it reads it exactly. Ok all is good now )
This discussion has been closed.