Costco Citi Credit Card hasn’t updated, why? (Q Mac)

Costco citi credit card hasn’t downloaded in over a week. Says error with url but I can log on no problem to the sight. When will this been remedied


  • RickO
    RickO SuperUser, Mac Beta Beta
    Are you connecting via Quicken Connect? If so, change to Direct Connect. Use FI name "Citi Cards". This is a free service.

    Choosing Direct Connect

    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Note that for Direct Connect a Citi Cards you also have to authorize it at the Citi Cards website:
    On the Citi Cards website hover over the Profile icon and select More Settings, and then Manage Desktop Apps.
    From there you can authorized Quicken access.
    This is my website:
  • KMJ
    KMJ Member
    After 2 weeks of no updates with my Costco Anywhere Visa, I had to edit the Settings and change the download site from "Costco Anywhere Visa" to "Citi Cards," then it worked and downloaded 2 weeks of transactions.
  • mmaltar
    mmaltar Windows Beta Beta
    edited April 2021
    Same problem here.  Unlink Old Costco account. Then Just add a new account, select citi cards, put in your credentials. It will find the old Costco Citi account and should  show up as link to existing account.  Then it will download the transactions. There should be notice of the change,  how many others are sitting there wondering where their Costco Citi transactions are? 
  • Steve_O
    Steve_O Member
    edited April 2021
    Thanks KMJ and mmaltar, this worked for me as well. [Removed - Rant]
  • I had the same issue. You need to go to this web site and authorize Citi to release data to the Quicken app. You do this at this web site: You have 9 minutes to enter your log in info and then log in from Quicken. Updates all data with a new account in Quicken.
  • sdunixgeek
    sdunixgeek Member ✭✭
    Tried adding Access through the Citi website with no success have tried for weeks same response each time I try and connect in quicken. Anyone find a workaround for this. I saw the same issue was being reported for windows as well.

    date: 2021-04-26 09:35:10 (PST)
    OS: macOS Big Sur 11.2.3
    Product: Quicken
    Version: 6.1.1
    Build: 601.37924.100
    poll response:
    "status" : "AGGREGATOR_IN_ERROR",
    "aggregators" : [
    "channel" : "FDS_DEFAULT",
    "cpAggStatusCode" : "ccscrape.105",
    "aggStatus" : "FI_WEBSITE_UNAVAILABLE",
    "isProcessing" : false,
    "cpAggStatusDetail" : "URL. Website is currently unavailable or intermittently available."
    "institutionLoginId" : "271166286714058752",
    "isProcessing" : false
  • sdunixgeek
    sdunixgeek Member ✭✭
    edited April 2021
    Hello CORRECTION to my last post. I used direct connect and it successfully added the account. Just like the poster RickO suggested.
This discussion has been closed.