Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Report that shows full paycheck detail by quarter, including 401(k) transfers

When I enter a paycheck into Quicken, I have several typical category lines (simplified for this post): Salary, Federal Tax, State Tax, Health Insurance, Disability, and Life Insurance. It's very easy to run a report showing all of those together.

But my client's paycheck also has two additional lines: 401(k) contribution and Cash Balance Plan contribution, both of which are TRANSFERS. I cannot find any report that will display the 401(k) and Cash Balance Plan deductions correctly as outflows (only) like I could in QMac2007.

When I run a Transaction by Payee report and choose the employer, it shows all the typical category lines (salary, tax, insurance, etc.) but does NOT show the 401(k) and Cash Balance Plan transfers.

So I choose Edit Report, go to the Advanced tab, and select "Include all transfers." But that adds TWO lines for each retirement contribution – the money in (incorrectly showing it being deposited into the bank account which doesn't actually happen) and the money out to the 401(k) & Cash Balance Plan. This throws off the total because these are Salary DEDUCTIONS and not income, and yet this report can't show it that way.

Same problem using the Category Summary by Quarter – if I include transfers, at the bottom of the report it shows the 401(k) and Cash Balance Plan transactions as BOTH income and expense, when they're ONLY supposed to be expenses (from the point of view of the paycheck).

This was never a problem with QMac2007, so I'm perplexed as to why QMac2021 can't do this simple thing. I just want to see the complete details per quarter for my client's paychecks.

I've attached three example reports: QMac2007, QMac2021 Summary, and QMac2021 Detail. In the 2007 PDF, the highlighted lines show how the report SHOULD look. In the 2021 PDFs, the highlighted lines show the lines that SHOULDN'T be there.

Thank you for any insights or advice.

Best Answer

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    You almost nailed it. The trick is to go back to the Advanced tab and set Transfer=Include only transfers with accounts outside or report, and go to Accounts and select just the Checking account (or, more specifically, exclude the 401k and Cash Balance Plans accounts). Now, the report will show one side of the transfer, without zeroing itself out by showing the other side of the transfer.
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    You almost nailed it. The trick is to go back to the Advanced tab and set Transfer=Include only transfers with accounts outside or report, and go to Accounts and select just the Checking account (or, more specifically, exclude the 401k and Cash Balance Plans accounts). Now, the report will show one side of the transfer, without zeroing itself out by showing the other side of the transfer.
    Quicken Mac Subscription • Quicken user since 1993
  • Blastphemy
    Blastphemy Mac Beta Beta
    edited April 7
    Thank you – that worked for the Summary report!

    But for the Detail (transaction) report, the line item for the 401(k) or Cash Balance Plan transfers just shows the word "Transfer" (i.e., it doesn't show "Transfer: 401(k)" or "Transfer: Cash Balance Plan"). Any suggestions for fixing that? (I had hoped that showing the 'Transfer' column would be the solution, but naturally all that column shows is the incredibly unhelpful "1 transfer" – typical QMac2021 nonsense).

    I just can't understand why something like your solution for the Summary report has to be so complicated and counter-intuitive with QMac2021 (de-selecting an Account to make it show up in a report!). Everything was so simple and easy with QMac2007; it all got convoluted and messed up with this current reinvention of perfection.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @Blastphemy  I'm not seeing what you're describing. I have a paycheck which includes withholding for "XYZ 401k". In the Transactions by Category report, I see the full name of the account listed:



    This may be obvious, but make sure all the triangles are pointing down so you're seeing the detail of each transaction.
    Quicken Mac Subscription • Quicken user since 1993
  • Blastphemy
    Blastphemy Mac Beta Beta
    edited April 7
    I've attached what my report looks like. No triangles for the 401(k) or Cash Balance Plan transfers. The two highlighted lines at the bottom of the report only show "Transfer" but ideally should show "Transfer: 401(k)" and "Transfer: Cash Balance Plan."

    If it matters, this report began as a "Quicken Reports > Transaction > Transactions by Payee" report. I suspect the report you referenced above is 'Transaction by Category'. Unless there's some magic solution you can find, it does appear that the only workaround is to use a Transaction by Category report instead of by Payee.

    Below is an image of my Advanced settings for my report that's attached as a PDF:



  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Yes, on all counts. I was using a Transactions by Category report; when I do a Transactions by Payee report, I get the same result you show above. The problem is that transfers don't really have categories, so Quicken is needing to create text for the report's category field.

    So you have something of a workaround, but could also report this as a bug. (I don't know if the engineers will view it as a bug or not, but it's worth reporting.)
    Quicken Mac Subscription • Quicken user since 1993
Sign In or Register to comment.