Does Quicken not allow for special characters in a password to a FI?

Used Q17 for Mac and versions prior to that. Now using the subscription Mac version 6.1.1 Never had a problem with Direct Connect. All my FI passwords use a special character and most require that you have one. I started to have problems with importing a QFX file to one account so support suggested I start a new file as the old one was probably corrupted. I did so, and set up all accounts with Direct Connect. Every account, banks with several accounts, credit card accounts, and my brokerage account with one exception worked fine, all of which contained a special character in the password. My FI, Wealthscape has 3 accounts in it. I set up the first two with no problem. They all have the same account id and password. The only thing that is different is the account number. When I tried to add the third account, a Roth IRA, the message returned indicated the 2 previously setup accounts where up to date. No indication of the third account being connected to and set up. These 3 accounts had worked fine in the previous Quicken file.

I contacted chat support and went through my problem. The final answer I received was that "These characters will result as an error since they are part of Quicken’s own programming they will read out as a command rather than data input, in this case you will require to change your password to something without a special character or only using the $". That made absolutely no sense to me since the same password worked for the other 2 accounts and for all 3 accounts in the prior quicken file I was using. As mentioned all the other accounts I set up with Direct Connect worked seamlessly with a passwords using special characters. I explained this to the person and she came back and just said the same thing. I have to take it up with my FI.

Does anyone else use passwords with special characters and have any problems using Direct Connect? It would boggle my mind if Quicken, after all these years, has not figured out how to differentiate a string of characters entered as a password from its own programming commands. Never saw that in my many years working in software development.


  • jacobs
    jacobs SuperUser, Mac Beta Beta
    I'll only say that there have not likely been any changes in this area of the program since Quicken 2017, so if these passwords worked with Quicken 2017, they should work now. Different financial institutions have different rules for passwords, but if you're saying these passwords work with 2 Wealthscape accounts, I don't think that's your problem here. You could do a simple test by changing your passwords temporarily at Wealthscape, and then trying with these new passwords in Quicken. That would conclusively prove whether the special characters are the issue or not.
    Quicken Mac Subscription • Quicken user since 1993
  • Gasport
    Gasport Member ✭✭✭
    Not only did the password work with the other 2 Wealthscape accounts, it worked with all 3 Wealthscape accounts in the previous instance of the Quicken data file I am currently using.

    This was the actual reply I got from them.

    "This characters will result as an error since they are part of Quicken’s own programming they will read out as a command rather than data input, in this case you will require to change your password to something without a special character or only using the $
    if it doesn’t work, you will have to excalate with your financial institution, since that connection method is provided by them and not by us We are unable to access their servers"

    First of all, I have no idea what the reference to Quicken's own programming means. Does this mean anything I type into Quicken that has a special character is treated as a command and not a string of characters? I am also of the impression that any sensitive data such as any password I enter is encrypted and stored in the OS X Keychain and not visible to Quicken. If this is the case, and I hope it is, then whatever Quicken's own programming is would never see the actual password. This resides only on my Mac in encrypted form. I assume that when Quicken sends an update request to my FI, it sends the login data that is encrypted and then decrypted at the FI servers. So, I see no way that "Quicken's own programming" would recognize the special character, which happen to be comma (,) which I can enter into most any field in Quicken, especially the amount fields... So I am at a loss as to what they mean....

    I did try to change the password, but as I told the Quicken support person, many FI require a special character in the password. Wealthscapes does require a special character and $ is not one of them. So that means, for whatever reason Quicken can only access 2 of the 3 accounts .

    I had my financial advisor contact Wealthscapes and inquire about why Quicken can only access 2 accounts. He did so and was told that there was no reason on their end that would prevent this from happening. I have no problem with a competing software app, as all 3 accounts are established and updated.
This discussion has been closed.