What macOS is compatible with Quicken Deluxe v6.1.1

I've purchased a new Mac Mini, and macOS Catalina is installed. Is Quicken Deluxe v6.1.1 compatible?

Best Answer

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    Quicken 6.1.1 will run on any macOS from High Sierra and later, so yes, you'll be fine with Catalina.
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    Quicken 6.1.1 will run on any macOS from High Sierra and later, so yes, you'll be fine with Catalina.
    Quicken Mac Subscription • Quicken user since 1993
Sign In or Register to comment.