My Checking Account Register Transactions are out of order.

This has happen to me twice over the last three months.

Something happens where my cleared and entered checking account transactions will appear at the bottom of the screen/register and the future/anticipated transactions will display at the top/beginning, above the date when I first opened my Quicken Account around 2013. Normally everything is in ascending order.

The future/anticipated entries start with tomorrow's date and go out for 30 days, i.e 4/14-5/14, followed by the 2013 transactions i.e 4/01/13 and continue to today's date 4/13/2021.

I have tried changing from ascending to descending, but nothing works.

The only way to fix it is to download my backup.

Any idea as to what might cause this and how to fix it without reverting to my backup?

Best Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    Accepted Answer
    If you are sorted by date with most recent at the top, then you should see the future transactions at the top, followed by the most recent past transaction going down to the oldest transaction at the bottom.

    If clicking the Date header is not doing this, then I'd suggest you contact Quicken Support (by phone) so they can screen-share with you to see what's going on.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    @Detective  What you describe -- future transactions (gray) at the top, then other transactions from oldest to newest -- is typically what happens when you click on the Status column heading, the one with a • in the heading:



    Clicking on the Date heading fixes the order, in this case future on top followed by most recent to oldest.



    You can see what column is sorted, and in which order, by the ^ or ˇ symbol.

    Could you post a screen shot showing the column headings and the dates which are out of order?

    The only other thing I've seen to get dates appear to be out of order is if there's a problem with the date format between the data and macOS. In your Mac System Preferences > Language & Region, are you set for Region=United States? Could you click on the Advanced button, then the Dates tab, and set the Short setting for year from 2 digits to 4 digits; then quit and relaunch Quicken. Are the dates still out of order? And are they all in the 2000s, or are any in the 1900s? 
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    It sound like you inadvertently clicked the Clr column header which causes the register to be sorted by that column. To restore the sort to date order, simply click on the Date column header. To reverse the sort order by Date, click the Date column header again.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Detective
    Detective Member
    Thank you,! I do not think that was the case, but I will keep that in mind if it happens again.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    You know, a similar thing happened to me. While moving the mouse across the Quicken window I got a little heavy-handed and I managed to inadvertently click the mouse. If that happened while the mouse pointer was moving across the register's column header fields, the register would be re-sorted by whatever column header the mouse happened to cross at the time.
    Easy to do. Easy to fix without any permanent damage. And I learned to keep the trigger finger off the mouse button while moving around ... :blush:
  • Detective
    Detective Member
    I have been training my wife on Quicken and I think she may have hit the Action column. Although I tried reserving it, I could not.

    Could advice regarding the mouse button.
  • RickO
    RickO SuperUser, Mac Beta Beta
    Just click (single click, left mouse button) the word "Date" at the top of the Date column. That will sort the register by date. Click it again to reverse the order.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Detective
    Detective Member
    Thank you, but as I noted in my original post I tried that, changing from ascending to defending and back, and it did not work. The problem was, the future dates were placed at the top before the 2013 date when I joined Quicken.
  • RickO
    RickO SuperUser, Mac Beta Beta
    Accepted Answer
    If you are sorted by date with most recent at the top, then you should see the future transactions at the top, followed by the most recent past transaction going down to the oldest transaction at the bottom.

    If clicking the Date header is not doing this, then I'd suggest you contact Quicken Support (by phone) so they can screen-share with you to see what's going on.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Accepted Answer
    @Detective  What you describe -- future transactions (gray) at the top, then other transactions from oldest to newest -- is typically what happens when you click on the Status column heading, the one with a • in the heading:



    Clicking on the Date heading fixes the order, in this case future on top followed by most recent to oldest.



    You can see what column is sorted, and in which order, by the ^ or ˇ symbol.

    Could you post a screen shot showing the column headings and the dates which are out of order?

    The only other thing I've seen to get dates appear to be out of order is if there's a problem with the date format between the data and macOS. In your Mac System Preferences > Language & Region, are you set for Region=United States? Could you click on the Advanced button, then the Dates tab, and set the Short setting for year from 2 digits to 4 digits; then quit and relaunch Quicken. Are the dates still out of order? And are they all in the 2000s, or are any in the 1900s? 
    Quicken Mac Subscription • Quicken user since 1993
  • Detective
    Detective Member
    Thank you. Yes that is what it looked like. I am quite sure I clicked on the date column, but I may be wrong.

    I cannot send a screen shot because I fixed it by using my backup.

    But, I will try that if it happens again.
Sign In or Register to comment.