Date Picker Shows Mostly Off-Screen After Recent Update

:/ I've been using Quicken for Windows on my larger 3840x2160 monitors for a long time without any issues. I noticed a few weeks ago that, when I click on the calendar icon in the register that brings up the date picker, it now shows mostly off-screen. I am running the latest R32.12 version. I can't move the picker and this happens when the window is sized or maximized. The date picker works as expected on my laptop screen, but I really need the extra screen real estate.

I chatted with Support and they had me try out some DPI settings in the compatibility tab, but nothing helped. Any ideas from the community?

Best Answer

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Accepted Answer
    UKR said:
    R 32.12 ... US or Canadian version?
    The most recent version/release numbers are really confusing ...
    The new Canadian version is R32.10, so this is the US version.

    As for the problem it sounds like given the combination of Windows scaling (and maybe Large Fonts in Quicken) Quicken is miscalculating the size of the display that Quicken is on.  I'm guessing you are at or near the bottom of the register and the calendar is posted below the transaction and partly off the screen, right?

    The way it suppose to work it when you are near the top of the register the calendar should popup downward to avoid going off the screen at the top.  When you "crossover" the mid point in the register it should switch to popping above the transaction.  It sounds like given the window scaling you are doing there are very few transactions and Quicken is getting the "mid point" wrong.

    The only thing I can think to try if the DPI settings don't work is to set the display that Quicken is on to be the "main display".


    In the past there was definitely a bug where Quicken would look at the main display for sizing information even when Quicken wasn't on the main display.  I'm not sure if that bug was ever fixed or not, in this case if they reintroduced such a bug.  But it is worth a try.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    R 32.12 ... US or Canadian version?
    The most recent version/release numbers are really confusing ...
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Accepted Answer
    UKR said:
    R 32.12 ... US or Canadian version?
    The most recent version/release numbers are really confusing ...
    The new Canadian version is R32.10, so this is the US version.

    As for the problem it sounds like given the combination of Windows scaling (and maybe Large Fonts in Quicken) Quicken is miscalculating the size of the display that Quicken is on.  I'm guessing you are at or near the bottom of the register and the calendar is posted below the transaction and partly off the screen, right?

    The way it suppose to work it when you are near the top of the register the calendar should popup downward to avoid going off the screen at the top.  When you "crossover" the mid point in the register it should switch to popping above the transaction.  It sounds like given the window scaling you are doing there are very few transactions and Quicken is getting the "mid point" wrong.

    The only thing I can think to try if the DPI settings don't work is to set the display that Quicken is on to be the "main display".


    In the past there was definitely a bug where Quicken would look at the main display for sizing information even when Quicken wasn't on the main display.  I'm not sure if that bug was ever fixed or not, in this case if they reintroduced such a bug.  But it is worth a try.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Darrell P
    Darrell P Member
    Chris, your suggestion about main display did solve the problem. I could see in Compatibility -> DPI settings that there was some magic about using the main display resolution. I was resisting the idea of switching the main display at first, but I don't see any ill effects. Kudos for solving the problem! Still, they should fix this in the product.
Sign In or Register to comment.