How to fix desktop application saying 'Invalid Quicken ID or password.'?

Hello,
When i try to launch Quicken I am getting the message 'Invalid Quicken ID or password.' and then the application closes.
This is a new install on a new computer that I have.
I am logged into the Quicken site here with the same Quicken ID and password, so not sure why the desktop is not liking it.

Any suggestions?

Thanks,
BT

Answers

  • BTBT
    BTBT Member ✭✭
    So I went to my old computer and logged into my quicken account on the desktop using the same Quicken ID and password. Works on the old computer, but not on the new install on the new computer. That is a bit weird and frustrating.
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    BTBT said:  This is a new install on a new computer that I have.
    I am logged into the Quicken site here with the same Quicken ID and password, so not sure why the desktop is not liking it.
    Where or how did you perform the NEW install on the other 2nd computer ?

    Quicken Subscription - Windows 10
  • BTBT
    BTBT Member ✭✭
    I used the same install file as when I installed it 2 years ago on the older computer. One the new computer I installed it installed in the default location c:\program files (x86)\quicken\.

    Very strange. I can still use my old computer to access my quicken Desktop application and my web account. However with my new computer it will give the error above for both the desktop application and now the web page as well. I can't log into quicken.com on my new system.

    I wonder if Quicken is checking the system and I need to authorize the new system? I would expect a different error message though. I'll take a look around and see if there are options about authorizing another device.

    Let me know if you have any other thoughts.

    Cheers!
  • BTBT
    BTBT Member ✭✭
    I clicked on the 'sign out of all devices'. After about 10 minutes I was able to login with the quicken application on the new system. However it said that I have to use a previous version from when my subscription was active. So I did that, and I then again had the same issue as above. I tried to 'sign out of all devices' again. It has been more than 15 minutes and still no access.

    Well, I will try again Sunday morning.

    The instructions for installing Quicken up to the last patch that you had a subscription are a bit lacking. I downloaded the patch I qualify for and the instructions don't say what to do next. Between this and the not being able to access my financial data it is quite frustrating.

    Cheers,
    Brian
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Is your Quicken Subscription expired at this time?
    I keep hearing that there may be issues trying to (re-)install an expired Quicken Subscription version.
    https://www.quicken.com/support/reinstalling-and-patching-your-quicken-subscription-version-after-your-membership-has

    Stuck in loop with logon to Quicken.com? Quicken fails or is slow to start? Quicken won't save changes to lists or transactions? (Windows 10)

    Check if Windows Defender feature Ransomware protection is enabled.
    If so, configure it to add Quicken as an "allowed app" without turning off Ransomware protection. Perform the last step in:
    https://community.quicken.com/discussion/7857675/faq-windows-defender-controlled-folder-access

     

    Are you getting "Oops, something went wrong"?
    Have you recently enabled a VPN? If so, this might be the problem. Try turning the VPN off and see if that helps.

    Is there a corporate or otherwise external firewall getting in the way? Contact the IT people maintaining the firewall and ask for permission.
    Does your Antivirus software allow Quicken to connect to the Internet?
    Quicken needs to be able to establish outbound Internet connections for the program to work.


  • BTBT
    BTBT Member ✭✭
    Hello UKR, thanks for your response. Yes, my subscription is currently expired as of 9 Feb 2021. I followed the directions below to reinstall:
    https://www.quicken.com/support/reinstalling-and-patching-your-quicken-subscription-version-after-your-membership-has

    However, it is still not working. The directions are a bit lacking as when I do step 2 'Go to quicken.com/download to download and install Quicken for Windows.' It automatically installs the latest versions. Step 3 'From the list below, download the patch that was released before your expiration date.' Is then useless. I downloaded the patch but there are no instructions to apply it to go back to the 3rd Feb 2021 version that I am qualified for.

    When I launch it now I get 'You have exceeded the number of data sets....etc etc etc...' Then, I get the 'Your subscription is expired before this patch, etc etc etc. Then points out the link above to install Quicken to the latest patch version that I qualify for. Then Quicken closes. So, even if there was an option to downgrade within the desktop application Quicken closes before I can try it out. I already related that the 'install the latest version that I qualify for' link and instructions don't work.

    Thanks for the advice. I will look for some articles from the community about installing a version without an active subscription since the Quicken ones don't seem to work.

    Cheers!
  • BTBT
    BTBT Member ✭✭
    Oh, by the way UKR. When I hit the 'sign out of all devices' and waited about 30-60 minutes I was finally able to login to the Quicken on the new system. So now I am at the problems above. :) Weeeeeeee!

    Cheers!
  • BTBT
    BTBT Member ✭✭
    Ok, well I am back to the original issue. I used my 2019 Quicken installer while having my internet connection disconnected, so that I would not get the latest updates during install. Now when trying to launch Quicken I am back to the 'Invalid Quicken ID or password' error message when launching the desktop application.

    Windows defender Ransomware protection is disabled

    I am not getting the 'Oops, something went wrong' error.

    I am at home and my other computer can connect fine, so nothing with the gateway or firewall at home.

    I think I will probably just wait to contact Quicken support Monday.

    Thanks for all the suggestions and help.

    Cheers.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    What the instructions are supposed to tell you is to download and install Quicken at the latest patch level and don't run it. Then download and install an older patch level to revert your installation to the latest patch level that was available before your subscription expired.
    Hopefully, that will make your installation work on the new computer ...
    I have updated the install instructions here by adding the missing Step 4.
    1. Find your Membership expiration date (you can see this by signing into My Account and going to the Subscriptions section).
    2. Go to quicken.com/download to download and install Quicken for Windows. 
    3. From the list below, download the patch that was released before your expiration date.
    4. Install the downloaded patch file to revert your installed software to a patch level that was valid before your subscription expired.
    I can only guess, but since your subscription is expired, you are not authorized to install and run a software release level which is higher than the one which was available before your expiration date. Quicken seems to know which is which and won't let you run a higher patch level than your (now expired) subscription indicates.
    And yes, using these Mondo Patch files one can up- or downlevel Quicken as needed, to add or remove software fixes. If, for example, R 33.19 doesn't work for you, fall back to R 31.20

  • BTBT
    BTBT Member ✭✭
    Well, I waited 2 hours and then tried again and I can now login with the 2019 version. So now to see how I can install up to the latest patch.

    Also, when I copied my quicken file over from my other system it seems like there is 1 week or more missing data. Weird!
  • BTBT
    BTBT Member ✭✭
    Thanks UKR. I followed your step 4 and looks like I am up to the version just before my subscription expired.
    A few errors along the way, but finally got it to work for now.

    Although 1 account that was closed 3 years ago is now showing a balance.

    I copied the quicken file straight over from my old computer and that old account that I closed over 3 years ago in Quicken is showing a balance. Very weird.

    Anyway thank you for your help UKR

    Cheers
  • BTBT
    BTBT Member ✭✭
    Found out that my old computer was using a different quicken file for the last 10 days. So, I grabbed that one and now the new computer matches the old one. Whew!

    Still an error about 'exceeding a maximum number of datasets' that I will search the community for a resolution, but other than that I am good.

    Thank you UKR and Ps56k2 for jumping in to help. Much appreciated.

    I will probably end up subscribing again, but I wanted to resolve all the issues before subscribing just on the principle of it. LOL! Probably a lot easier if I had just subscribed again, but oh well. :)

    Cheers!
This discussion has been closed.