Unable to upgrade from 5.17.6 to 6.2.2

I am running Quicken 5.17.6 and have not been able to upgrade it until now. When I launch Quicken it tells me that a new version is available, but in the lower part of the window it says: "And error occurred while processing your request. Reference #132.4c7132b8.1625686504.20a7ee2". If I click on Install Update anyway it says that an error occurred downloading the update. Unfortunately, I must update. What to do?

Answers

  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    What MacOS version are you using?

    The newer versions all require MacOS 10.13 or higher, with Quicken 5.18 being the last to support anything older. That version has a dialog informing you that you must upgrade your OS if you wish to make further upgrades.

    You are using a slightly older release, and it likely doesn't have that dialog. Hence, the cryptic error message if you are running 10.12 or older.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @Deborah Loth  What version of macOS are you running?

    And why must you update? (Not that you shouldn't be able to; I'm just curious why you're several versions behind and now say you must update.)
    Quicken Mac Subscription • Quicken user since 1993
Sign In or Register to comment.