How to get rid of N/A in stock purchase

Dana
Dana Member ✭✭
Why can't I get rid of a N/A investment purchase that is wrong? It was downloaded from a broker's website. If I delete it and re-enter it manually, it still shows up as "N/A" amount. All "Validate and Repair" efforts did not work.

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    The N/A is an indication that there are one or more Placeholders in the account for the security in question at a later date than the transaction you are trying to fix.

    First go to Edit > Preferences  > Investment Transactions and make sure the Show hidden transactions box is checked.

    Then find and delete the placeholder and you should be able to enter the correct transaction.
    QWin Premier subscription
  • Dana
    Dana Member ✭✭
    Jim,
    Thanks for your response. I clicked "show hidden transactions" and I got 7 placeholder entries, including the one in question. All but one showed 0 shares and one had 0.28 shares. I tried to delete all 7 but it didn't happen. Also, the security in question had the corrected history of two lots totaling 119 shares, but the cash is still off for the first transaction amount for this security.
    I appreciate the tip in Preferences, but still not at a solution. Any ideas?
    Thx
  • Dana
    Dana Member ✭✭
    Jim,
    UPDATE (to the above): I picked a zero share security placeholder at random, clicked on Enter History, then clicked okay. Not only did it disappear, so did the other six placeholders! Then, back to the account register, I saw that the 'N/A' had disappeared, but an "XIn" was added by the cash amount of the share purchase (previously, the N/A), so I deleted the cash entry and was back in cash balance. I will change all security share balances for this account, but I have no concern that they won't agree with the brokerage statement.
    Thanks for your assistance!
    [happy emoji face goes here ->___ ]
Sign In or Register to comment.