Price history adds a null closing price to days in which I don’t download anything

I have four 401K accounts for which I enter price updates manually - no automated download is available. For three of these accounts, on days when I don’t input a price update the price history simply skips those days and the portfolio graph shows only the data that is entered; i.e., a smooth curve. However, on one of the accounts Quicken automatically inserts a date for every weekday and a price of 2.05 into every price column. This results in the graph showing a 0 balance for those days, making it impossible to use for trends.

I have deleted this account and re-entered the starting balances and have batch-loaded the price history, but the behavior persists.

How do I stop this one account from entering null data by default so that it behaves like the other three of the same type?

Quicken Deluxe for Mac Version 6.2.2 (Build 602.39004.100)

Best Answer

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    Quicken Mac, in its infinite wisdom, prevents you from removing a symbol from a security. If there's a way to do it, I haven't found it yet. 

    SO I'll suggest a different workaround. In the Securities window, Control-click on any column heading and you'll get a small pop-up list of available columns. Check the one for "Download Quote", which is normally hidden by default. Now, find this security and uncheck it in the Download Quote column. That should prevent it from trying to download quotes for the non-existent security symbol. Post back and let us know if that works. 
    Quicken Mac Subscription • Quicken user since 1993

Answers

  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi @mikep2k1

    I apologize if you've already tried this, but have you double checked to ensure that this particular "security" does not have both a Symbol or a CUSIP ID in your Quicken datafile?  If it does have either one, that could be the cause of this problem and you should delete them.

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • mikep2k1
    mikep2k1 Member ✭✭
    edited July 2021
    Hello Frankx: the problematic security does have a symbol, but I don’t know how to delete the symbol. I tried to do it under "Edit Security", to no avail. Can you advise how I can delete the symbol?

    Should I just delete the thing and create the account from new?
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Answer ✓
    Quicken Mac, in its infinite wisdom, prevents you from removing a symbol from a security. If there's a way to do it, I haven't found it yet. 

    SO I'll suggest a different workaround. In the Securities window, Control-click on any column heading and you'll get a small pop-up list of available columns. Check the one for "Download Quote", which is normally hidden by default. Now, find this security and uncheck it in the Download Quote column. That should prevent it from trying to download quotes for the non-existent security symbol. Post back and let us know if that works. 
    Quicken Mac Subscription • Quicken user since 1993
  • mikep2k1
    mikep2k1 Member ✭✭
    edited July 2021
    That seems to have worked. It only manifests at the start of each new day, so I will check again tomorrow to confirm success. Thanks!
  • mikep2k1
    mikep2k1 Member ✭✭
    edited July 2021
    I spoke too soon. I think I have found why this one security acts differently from the other three. The accounts I am tracking don't have stock symbols but at one point I assigned symbols as part of a prior workaround that didn’t work. Three of the symbols are nonexistent for any other securities, but the one I am having trouble with is using a symbol that actually belongs to a security. So apparently Quicken is going after that real security, but doesn’t have any login info for it so it gives me a generic entry.

    What I just did was this: I was not able to delete the incorrect stock symbol, but I was able to rename it to a bogus name (XYZABCDOESNTEXIST). Quicken let me do it but told me I'd have to download manually - which I have to do anyway. Let's see what happens tomorrow.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    From what you wrote today, since the security had a valid symbol, it's logical that it was downloading prices for that security all along. And yes, changing it to a non-existent symbol should prevent it from downloading anything.

    I am a little surprised that unchecking the download quotes checkbox for the security did not prevent it from downloading though. That seems to me to be a bug. In earlier incarnations of Quicken Mac, that was the only way to control which securities did or did not download. But then they added the checkbox to only download securities you own, and it's possible that when they implemented that change, and hid the download quotes column by default, they actually made it non-functional. I don't know if that's by design or by mistake. I'll submit a bug report on it, but they don't provide answers to bug report submissions so we won't know the outcome. 
    Quicken Mac Subscription • Quicken user since 1993
  • Quicken Sarah
    Quicken Sarah Alumni ✭✭✭✭
    jacobs said:

    I am a little surprised that unchecking the download quotes checkbox for the security did not prevent it from downloading though. That seems to me to be a bug. In earlier incarnations of Quicken Mac, that was the only way to control which securities did or did not download. But then they added the checkbox to only download securities you own, and it's possible that when they implemented that change, and hid the download quotes column by default, they actually made it non-functional. I don't know if that's by design or by mistake. I'll submit a bug report on it, but they don't provide answers to bug report submissions so we won't know the outcome. 
    Hello @jacobs and @mikep2k1

    Thank you for flagging this behavior!  I have confirmed this is indeed a bug, unchecking the hidden download quotes column should turn off the quote update.

    I've opened a ticket with the team to investigate this matter further and will be back to share any updates and/or a resolution as one is received.

    Thank you again,

    Sarah

    (CTP - 2428)
This discussion has been closed.